summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-04 21:43:50 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-04 21:43:50 +0100
commit5c0c6e7c203ec1cfdc04609b8ddfdce1766a88a0 (patch)
treee517f3f3c100c3cf4988f67db34a09c893ddafc4
parentsys-boot/plymouth: yay finally a release (diff)
downloadgentoo-5c0c6e7c203ec1cfdc04609b8ddfdce1766a88a0.tar.gz
gentoo-5c0c6e7c203ec1cfdc04609b8ddfdce1766a88a0.tar.bz2
gentoo-5c0c6e7c203ec1cfdc04609b8ddfdce1766a88a0.zip
app-arch/lzip: Bump to 1.23
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--app-arch/lzip/Manifest1
-rw-r--r--app-arch/lzip/lzip-1.23.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/app-arch/lzip/Manifest b/app-arch/lzip/Manifest
index 7627a121f501..30ca2e650ed6 100644
--- a/app-arch/lzip/Manifest
+++ b/app-arch/lzip/Manifest
@@ -1 +1,2 @@
DIST lzip-1.22.tar.gz 120769 BLAKE2B d6d4faaff981d64219e27364c7072f9e1309507220e80d4195d866c3429db537a9fa9b7a4ac67ef5c267cad0f6e43ce997a98f1e47a88b228bd1aa437c991140 SHA512 318de74effdbdfa79070d28919459a85bf1efe662b818b8af2a3daa964b6c24e3386c37de360c6d5b8b624d549b5c9ed777c6234561129c477e03d92ac2db206
+DIST lzip-1.23.tar.gz 121817 BLAKE2B 934a35e31b0db76c4dcbe2fe903f04b60471485118aa5d4001599a3c23a7db74f05f703cf430bb299795be7025f71efb225afddff85c8245e962bdadcf82aef7 SHA512 482804205b6e92fdf9cb17fb9482df7987227c7b1bef9e42d78787acfabe73995f5b1a66f847d2176423f22dce56f1122c5b1c9670f0b778c0bdad2852369c85
diff --git a/app-arch/lzip/lzip-1.23.ebuild b/app-arch/lzip/lzip-1.23.ebuild
new file mode 100644
index 000000000000..9472e59e3d1d
--- /dev/null
+++ b/app-arch/lzip/lzip-1.23.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="lossless data compressor based on the LZMA algorithm"
+HOMEPAGE="https://www.nongnu.org/lzip/lzip.html"
+SRC_URI="https://download.savannah.gnu.org/releases/${PN}/${P/_/-}.tar.gz"
+S="${WORKDIR}/${P/_/-}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+src_configure() {
+ # not autotools-based
+ ./configure \
+ --prefix="${EPREFIX}"/usr \
+ CXX="$(tc-getCXX)" \
+ CPPFLAGS="${CPPFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}" || die
+}