summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-10-14 02:57:17 +0100
committerSam James <sam@gentoo.org>2022-10-14 02:57:17 +0100
commit5c1daef22a30511b11d8cdaa01f92210c15717ca (patch)
tree117e7cee700b43c19f328f806479d52d90f434e8
parentmedia-gfx/gphoto2: switch to xz (diff)
downloadgentoo-5c1daef22a30511b11d8cdaa01f92210c15717ca.tar.gz
gentoo-5c1daef22a30511b11d8cdaa01f92210c15717ca.tar.bz2
gentoo-5c1daef22a30511b11d8cdaa01f92210c15717ca.zip
dev-util/umockdev: sync live ebuild
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-util/umockdev/umockdev-0.17.13.ebuild10
-rw-r--r--dev-util/umockdev/umockdev-9999.ebuild2
2 files changed, 9 insertions, 3 deletions
diff --git a/dev-util/umockdev/umockdev-0.17.13.ebuild b/dev-util/umockdev/umockdev-0.17.13.ebuild
index 828c98c13e9e..5e679a5c7ee1 100644
--- a/dev-util/umockdev/umockdev-0.17.13.ebuild
+++ b/dev-util/umockdev/umockdev-0.17.13.ebuild
@@ -6,13 +6,19 @@ PYTHON_COMPAT=( python3_{8..11} )
inherit meson-multilib python-any-r1 vala
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/martinpitt/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/martinpitt/umockdev/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86"
+fi
+
DESCRIPTION="Mock hardware devices for creating unit tests"
HOMEPAGE="https://github.com/martinpitt/umockdev/"
-SRC_URI="https://github.com/martinpitt/umockdev/releases/download/${PV}/${P}.tar.xz"
LICENSE="LGPL-2.1+"
SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86"
IUSE="test"
RESTRICT="!test? ( test )"
diff --git a/dev-util/umockdev/umockdev-9999.ebuild b/dev-util/umockdev/umockdev-9999.ebuild
index bc20bf311552..8015f3762895 100644
--- a/dev-util/umockdev/umockdev-9999.ebuild
+++ b/dev-util/umockdev/umockdev-9999.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit meson-multilib python-any-r1 vala