summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-05-11 03:54:47 +0100
committerSam James <sam@gentoo.org>2023-05-11 04:15:45 +0100
commit5c85b298fa9c9f2e7d808d10b75bc48994951bc6 (patch)
treef205a6fd2281add51ffdc1e2e5a81d6c6852dbed
parentmedia-sound/shorten: fix modern C issues (diff)
downloadgentoo-5c85b298fa9c9f2e7d808d10b75bc48994951bc6.tar.gz
gentoo-5c85b298fa9c9f2e7d808d10b75bc48994951bc6.tar.bz2
gentoo-5c85b298fa9c9f2e7d808d10b75bc48994951bc6.zip
media-sound/splay: build w/ c++14 (-Wregister)
Closes: https://bugs.gentoo.org/897816 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--media-sound/splay/splay-0.9.5.2-r2.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/media-sound/splay/splay-0.9.5.2-r2.ebuild b/media-sound/splay/splay-0.9.5.2-r2.ebuild
index b66657bceebf..df9a369f7c09 100644
--- a/media-sound/splay/splay-0.9.5.2-r2.ebuild
+++ b/media-sound/splay/splay-0.9.5.2-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit autotools
+inherit autotools flag-o-matic
DESCRIPTION="An audio player, primarily for the console"
HOMEPAGE="http://splay.sourceforge.net/"
@@ -28,3 +28,9 @@ src_prepare() {
mv configure.{in,ac} || die
eautoreconf
}
+
+src_configure() {
+ append-cxxflags -std=c++14
+
+ default
+}