summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2018-02-06 16:49:42 +0100
committerAlexis Ballier <aballier@gentoo.org>2018-02-06 20:23:27 +0100
commit5c9b7b5efacd4f037fa15f864db5578430968eb7 (patch)
tree60c1ca50c748ceacc766c26c38c4618d866d2342
parentdev-util/catkin: bump to 0.7.11 (diff)
downloadgentoo-5c9b7b5efacd4f037fa15f864db5578430968eb7.tar.gz
gentoo-5c9b7b5efacd4f037fa15f864db5578430968eb7.tar.bz2
gentoo-5c9b7b5efacd4f037fa15f864db5578430968eb7.zip
dev-ros/ros_environment: initial import
Package-Manager: Portage-2.3.24, Repoman-2.3.6
-rw-r--r--dev-ros/ros_environment/Manifest1
-rw-r--r--dev-ros/ros_environment/files/catkinprefixpath.patch13
-rw-r--r--dev-ros/ros_environment/metadata.xml11
-rw-r--r--dev-ros/ros_environment/ros_environment-1.2.0.ebuild25
-rw-r--r--dev-ros/ros_environment/ros_environment-9999.ebuild25
5 files changed, 75 insertions, 0 deletions
diff --git a/dev-ros/ros_environment/Manifest b/dev-ros/ros_environment/Manifest
new file mode 100644
index 000000000000..f557152cca0e
--- /dev/null
+++ b/dev-ros/ros_environment/Manifest
@@ -0,0 +1 @@
+DIST ros_environment-1.2.0.tar.gz 6366 BLAKE2B ff540b9e861d039739253b9effbfe06ec703f47b48d9bb7009b5caed5010ed8219a207bfd363c03b115d018965c2e584abbf58f649ea868e66e79d4dda11d1ae SHA512 1b89e3d6ea88fc0972bbe980bae0b663e9335adece8eb0d517cac76b0a412cbe6b9783a967d4a9b5ca1c3bf2a432bb826d28f6f1d9a33fcc33a75edeef0be20b
diff --git a/dev-ros/ros_environment/files/catkinprefixpath.patch b/dev-ros/ros_environment/files/catkinprefixpath.patch
new file mode 100644
index 000000000000..ba78a70c2a49
--- /dev/null
+++ b/dev-ros/ros_environment/files/catkinprefixpath.patch
@@ -0,0 +1,13 @@
+Index: ros_environment-9999/env-hooks/1.ros_package_path.sh.em
+===================================================================
+--- ros_environment-9999.orig/env-hooks/1.ros_package_path.sh.em
++++ ros_environment-9999/env-hooks/1.ros_package_path.sh.em
+@@ -4,7 +4,7 @@
+ PYTHON_CODE_BUILD_ROS_PACKAGE_PATH=$(cat <<EOF
+ from __future__ import print_function
+ import os
+-env_name = 'CMAKE_PREFIX_PATH'
++env_name = 'CATKIN_PREFIX_PATH'
+ paths = [path for path in os.environ[env_name].split(os.pathsep)] if env_name in os.environ and os.environ[env_name] != '' else []
+ workspaces = [path for path in paths if os.path.exists(os.path.join(path, '.catkin'))]
+ paths = []
diff --git a/dev-ros/ros_environment/metadata.xml b/dev-ros/ros_environment/metadata.xml
new file mode 100644
index 000000000000..7476e60efa62
--- /dev/null
+++ b/dev-ros/ros_environment/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ros@gentoo.org</email>
+ <name>Gentoo ROS Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ros/ros_environment</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ros/ros_environment/ros_environment-1.2.0.ebuild b/dev-ros/ros_environment/ros_environment-1.2.0.ebuild
new file mode 100644
index 000000000000..14906c3050db
--- /dev/null
+++ b/dev-ros/ros_environment/ros_environment-1.2.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_environment"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+inherit ros-catkin
+
+DESCRIPTION="ROS environment variables"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="!!<dev-ros/roslib-1.14.3"
+DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/catkinprefixpath.patch" )
+
+src_configure() {
+ export ROS_DISTRO="Gentoo"
+ export ROS_DISTRO_OVERRIDE="Gentoo"
+ ros-catkin_src_configure
+}
diff --git a/dev-ros/ros_environment/ros_environment-9999.ebuild b/dev-ros/ros_environment/ros_environment-9999.ebuild
new file mode 100644
index 000000000000..14906c3050db
--- /dev/null
+++ b/dev-ros/ros_environment/ros_environment-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/ros_environment"
+KEYWORDS="~amd64 ~arm"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+inherit ros-catkin
+
+DESCRIPTION="ROS environment variables"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="!!<dev-ros/roslib-1.14.3"
+DEPEND="${RDEPEND}"
+PATCHES=( "${FILESDIR}/catkinprefixpath.patch" )
+
+src_configure() {
+ export ROS_DISTRO="Gentoo"
+ export ROS_DISTRO_OVERRIDE="Gentoo"
+ ros-catkin_src_configure
+}