summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-12-22 12:11:24 -0500
committerIonen Wolkens <ionen@gentoo.org>2023-12-22 12:37:24 -0500
commit5e53d7ae39660784580f720eae5e21811e671d35 (patch)
tree315b397fca362a4134faceb9dd8bbd5b7988b7e9
parentdev-util/mingw64-toolchain: unset DLLTOOL for cross (diff)
downloadgentoo-5e53d7ae39660784580f720eae5e21811e671d35.tar.gz
gentoo-5e53d7ae39660784580f720eae5e21811e671d35.tar.bz2
gentoo-5e53d7ae39660784580f720eae5e21811e671d35.zip
dev-util/mingw64-runtime: unset DLLTOOL for cross
Likely less of an issue on this package than mingw64-toolchain, but doesn't hurt to unset either way. Bug: https://bugs.gentoo.org/920483 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--dev-util/mingw64-runtime/mingw64-runtime-11.0.0.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/dev-util/mingw64-runtime/mingw64-runtime-11.0.0.ebuild b/dev-util/mingw64-runtime/mingw64-runtime-11.0.0.ebuild
index 5e0b60934d20..f58ee0b1fe5e 100644
--- a/dev-util/mingw64-runtime/mingw64-runtime-11.0.0.ebuild
+++ b/dev-util/mingw64-runtime/mingw64-runtime-11.0.0.ebuild
@@ -60,7 +60,7 @@ src_configure() {
# likely cross-compiling from here, update toolchain variables
if ${MW_CROSS} && [[ ! -v MINGW_BYPASS ]]; then
- unset AR AS CC CPP CXX LD NM OBJCOPY OBJDUMP RANLIB RC STRIP
+ unset AR AS CC CPP CXX DLLTOOL LD NM OBJCOPY OBJDUMP RANLIB RC STRIP
filter-flags '-fuse-ld=*'
filter-flags '-mfunction-return=thunk*' #878849
fi