summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-02-24 14:21:12 +0000
committerMarek Szuba <marecki@gentoo.org>2022-02-24 14:22:17 +0000
commit5e914ed3cf60a140b954971a3cde72a1b9462074 (patch)
treedec792c98c252a3ac30123df1427fd385d87cbf7
parentdev-vcs/pre-commit: drop 2.15.0, 2.16.0 (diff)
downloadgentoo-5e914ed3cf60a140b954971a3cde72a1b9462074.tar.gz
gentoo-5e914ed3cf60a140b954971a3cde72a1b9462074.tar.bz2
gentoo-5e914ed3cf60a140b954971a3cde72a1b9462074.zip
app-emulation/protontricks: drop 1.6.0
Signed-off-by: Marek Szuba <marecki@gentoo.org>
-rw-r--r--app-emulation/protontricks/Manifest1
-rw-r--r--app-emulation/protontricks/files/protontricks-1.5.0_no-setuptools-scm.patch36
-rw-r--r--app-emulation/protontricks/protontricks-1.6.0.ebuild57
3 files changed, 0 insertions, 94 deletions
diff --git a/app-emulation/protontricks/Manifest b/app-emulation/protontricks/Manifest
index 1a71b52afbc1..45a071f9157a 100644
--- a/app-emulation/protontricks/Manifest
+++ b/app-emulation/protontricks/Manifest
@@ -1,2 +1 @@
-DIST protontricks-1.6.0.tar.gz 61220 BLAKE2B 8a9af6f8cc134ad0e74b4c5e6c35bc8344687e65cc9811ca54402b16f723264cef8def6e733a532fd412db51d0ec63533baec52699ae994a97ecad0a25ebe847 SHA512 7276d7de1f0c18afc5c67552290888e3851bd5f073bbbf684000be66c2e65abac84b079373b120ff0ab6e4f4919caf8ee1288a2320de6c37629cb1185dfbea29
DIST protontricks-1.7.0.tar.gz 139203 BLAKE2B d93bbb672286d32743da1473e132508084bae527159911367c51e88686c38d3bad0a2f72a2c0f0feb09412e31e6d5bb20dfe113b9e71e4e655693bfbe663a968 SHA512 c12f211051bc23c8eb03c5385e8245361d72dcce1e641a7da1f87f344db5fdc7d698bd7691e0855ae025c1d94944db89b380805664d87123b6252d06259480ff
diff --git a/app-emulation/protontricks/files/protontricks-1.5.0_no-setuptools-scm.patch b/app-emulation/protontricks/files/protontricks-1.5.0_no-setuptools-scm.patch
deleted file mode 100644
index a19d8494657b..000000000000
--- a/app-emulation/protontricks/files/protontricks-1.5.0_no-setuptools-scm.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-Since version 1.4.1 upstream has used setuptools-scm to determine the
-current version number. Unfortunately the package in question does not
-support GitHub release archives, using GitHub VCS snapshots would require
-retrieving and updating commit hashes corresponding to release tags, and
-PyPI tarballs do not contain tests. setuptools_scm_git_archive does not
-help because it requires extra files to be included in the repository,
-which upstream has not done.
-
-Seeing as we already know the version number, bypass setuptools_scm
-altogether and create the version file ourselves. For obvious reasons the
-latter has to be done in ebuilds themselves.
-
---- a/setup.py
-+++ b/setup.py
-@@ -16,9 +16,6 @@
-
- setup(
- name="protontricks",
-- use_scm_version={
-- "write_to": "src/protontricks/_version.py"
-- },
- description=DESCRIPTION,
- long_description=LONG_DESCRIPTION,
- author=AUTHOR,
-@@ -28,11 +25,6 @@
- packages=["protontricks"],
- package_data={"": ["LICENSE"]},
- package_dir={"protontricks": "src/protontricks"},
-- setup_requires=[
-- # setuptools-scm v6 requires Python 3.6+
-- "setuptools_scm<6 ; python_version <= '3.5'",
-- "setuptools_scm ; python_version > '3.5'"
-- ],
- install_requires=["vdf>=3.2"],
- entry_points={
- "console_scripts": [
diff --git a/app-emulation/protontricks/protontricks-1.6.0.ebuild b/app-emulation/protontricks/protontricks-1.6.0.ebuild
deleted file mode 100644
index 2f2c167b9165..000000000000
--- a/app-emulation/protontricks/protontricks-1.6.0.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-DISTUTILS_SINGLE_IMPL=1
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="app-emulation/winetricks wrapper for Proton (Steam Play) games"
-HOMEPAGE="https://github.com/Matoking/protontricks"
-SRC_URI="https://github.com/Matoking/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="+gui"
-
-RDEPEND="app-emulation/winetricks
- $(python_gen_cond_dep '
- dev-python/vdf[${PYTHON_USEDEP}]
- ')
- gui? ( gnome-extra/zenity
- || (
- app-emulation/winetricks[gtk]
- app-emulation/winetricks[kde]
- )
- )"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.5.0_no-setuptools-scm.patch
-)
-
-DOCS=( CHANGELOG.md README.md )
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- distutils-r1_python_prepare_all
- echo "version = '${PV}'" > "${S}"/src/${PN}/_version.py || die "Failed to generate the version file"
-}
-
-pkg_postinst() {
- elog
-
- if ! use gui; then
- ewarn "Please note that disabling USE=gui does *not* presently remove the --gui command-line option,"
- ewarn "it just means using this option will fail unless gnome-extra/zenity happens to be installed."
- ewarn
- fi
-
- elog "Protontricks can only find games for which a Proton prefix already exists."
- elog "Make sure to run a Proton game at least once before trying to use protontricks on it."
- elog
-}