summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNikita Zlobin <nick87720z@gmail.com>2021-07-01 00:02:19 +0500
committerMiroslav Šulc <fordfrog@gentoo.org>2021-07-01 07:00:35 +0200
commit5f5c7b85b427f0a26cf6fed2d29fe8a7e8da33d0 (patch)
tree57b55c550f45ebbc31ed5752356d8bba99a619a5
parentdev-ruby/rr: add 3.0.5 (diff)
downloadgentoo-5f5c7b85b427f0a26cf6fed2d29fe8a7e8da33d0.tar.gz
gentoo-5f5c7b85b427f0a26cf6fed2d29fe8a7e8da33d0.tar.bz2
gentoo-5f5c7b85b427f0a26cf6fed2d29fe8a7e8da33d0.zip
media-sound/a2jmidid: python support is back
Bug: https://bugs.gentoo.org/798411 Signed-off-by: Nikita Zlobin <nick87720z@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/21418 Signed-off-by: Miroslav Šulc <fordfrog@gentoo.org>
-rw-r--r--media-sound/a2jmidid/a2jmidid-9.ebuild21
-rw-r--r--media-sound/a2jmidid/a2jmidid-9999.ebuild21
2 files changed, 36 insertions, 6 deletions
diff --git a/media-sound/a2jmidid/a2jmidid-9.ebuild b/media-sound/a2jmidid/a2jmidid-9.ebuild
index 62228ef8c0d6..1d5c181d312a 100644
--- a/media-sound/a2jmidid/a2jmidid-9.ebuild
+++ b/media-sound/a2jmidid/a2jmidid-9.ebuild
@@ -1,9 +1,12 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit meson
+PYTHON_COMPAT=( python3_{6..10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit meson python-single-r1
DESCRIPTION="Daemon for exposing legacy ALSA sequencer applications in JACK MIDI system"
HOMEPAGE="https://github.com/linuxaudio/a2jmidid"
@@ -12,7 +15,8 @@ SRC_URI="https://github.com/linuxaudio/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm x86"
-IUSE="dbus"
+IUSE="dbus python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
BDEPEND="
virtual/pkgconfig
@@ -21,6 +25,7 @@ CDEPEND="
media-libs/alsa-lib
virtual/jack
dbus? ( sys-apps/dbus )
+ python? ( ${PYTHON_DEPS} )
"
RDEPEND="${CDEPEND}"
DEPEND="${RDEPEND}"
@@ -34,3 +39,13 @@ src_configure() {
meson_src_configure
}
+
+src_install() {
+ meson_src_install
+
+ if use python; then
+ python_fix_shebang "${ED}"
+ else
+ rm "${ED}/usr/bin/a2j_control" || die
+ fi
+}
diff --git a/media-sound/a2jmidid/a2jmidid-9999.ebuild b/media-sound/a2jmidid/a2jmidid-9999.ebuild
index 7609deb0eba6..eeb15605c52f 100644
--- a/media-sound/a2jmidid/a2jmidid-9999.ebuild
+++ b/media-sound/a2jmidid/a2jmidid-9999.ebuild
@@ -1,9 +1,12 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit meson git-r3
+PYTHON_COMPAT=( python3_{6..10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit meson python-single-r1 git-r3
DESCRIPTION="Daemon for exposing legacy ALSA sequencer applications in JACK MIDI system"
HOMEPAGE="https://github.com/linuxaudio/a2jmidid"
@@ -12,7 +15,8 @@ EGIT_REPO_URI="https://github.com/linuxaudio/a2jmidid.git"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS=""
-IUSE="dbus"
+IUSE="dbus python"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
BDEPEND="
virtual/pkgconfig
@@ -21,6 +25,7 @@ CDEPEND="
media-libs/alsa-lib
virtual/jack
dbus? ( sys-apps/dbus )
+ python? ( ${PYTHON_DEPS} )
"
RDEPEND="${CDEPEND}"
DEPEND="${RDEPEND}"
@@ -34,3 +39,13 @@ src_configure() {
meson_src_configure
}
+
+src_install() {
+ meson_src_install
+
+ if use python; then
+ python_fix_shebang "${ED}"
+ else
+ rm "${ED}/usr/bin/a2j_control" || die
+ fi
+}