summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2020-04-23 11:26:26 +0200
committerPacho Ramos <pacho@gentoo.org>2020-04-23 11:26:26 +0200
commit5f8c3ff63258843e6cdf926ca37f663147ec33dc (patch)
tree3a3bd42a433f118a9398b7e0f5808ac071507a36
parentprofiles: arch/*mask: Sync ayatana and appindicator arch masks (diff)
downloadgentoo-5f8c3ff63258843e6cdf926ca37f663147ec33dc.tar.gz
gentoo-5f8c3ff63258843e6cdf926ca37f663147ec33dc.tar.bz2
gentoo-5f8c3ff63258843e6cdf926ca37f663147ec33dc.zip
app-misc/workrave: Migrate from 'ayatana' to 'appindicator' USE
Also drop all .la files Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--app-misc/workrave/workrave-1.10.20.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/app-misc/workrave/workrave-1.10.20.ebuild b/app-misc/workrave/workrave-1.10.20.ebuild
index a05c5f7aaf93..a59057629c07 100644
--- a/app-misc/workrave/workrave-1.10.20.ebuild
+++ b/app-misc/workrave/workrave-1.10.20.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
+GNOME2_LA_PUNT="yes"
PYTHON_COMPAT=( python2_7 )
inherit autotools gnome2 python-single-r1 versionator vcs-snapshot
@@ -16,9 +17,9 @@ SLOT="0"
KEYWORDS="amd64 ~ppc x86"
# dbus support looks to be used only for trying to use panel applets on gnome3!
-IUSE="ayatana doc gnome gstreamer introspection mate nls pulseaudio test xfce"
+IUSE="appindicator doc gnome gstreamer introspection mate nls pulseaudio test xfce"
RESTRICT="!test? ( test )"
-REQUIRED_USE="ayatana? ( introspection ) ${PYTHON_REQUIRED_USE}"
+REQUIRED_USE="appindicator? ( introspection ) ${PYTHON_REQUIRED_USE}"
RDEPEND="
>=dev-libs/glib-2.28.0:2
@@ -26,7 +27,7 @@ RDEPEND="
>=dev-cpp/gtkmm-3.18.0:3.0
>=dev-cpp/glibmm-2.28.0:2
>=dev-libs/libsigc++-2.2.4.2:2
- ayatana? (
+ appindicator? (
>=dev-libs/libdbusmenu-0.4[gtk3,introspection]
>=dev-libs/libindicator-0.4:3 )
gnome? ( >=gnome-base/gnome-shell-3.6.2 )
@@ -93,7 +94,7 @@ src_configure() {
--disable-gnome2 \
--disable-static \
--disable-xml \
- $(use_enable ayatana indicator) \
+ $(use_enable appindicator indicator) \
$(use_enable doc manual) \
$(use_enable gnome gnome3) \
$(use_enable gstreamer) \