summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2019-01-11 13:28:11 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2019-01-11 13:34:14 -0800
commit610a8f49ea590ba36546388e455e5a3e59593fe3 (patch)
tree5050fcd09030794786a8cf983b248876e2abe6eb
parentx11-misc/virtualgl: Add -9999 live version (diff)
downloadgentoo-610a8f49ea590ba36546388e455e5a3e59593fe3.tar.gz
gentoo-610a8f49ea590ba36546388e455e5a3e59593fe3.tar.bz2
gentoo-610a8f49ea590ba36546388e455e5a3e59593fe3.zip
dev-java/openjdk: fix automagic dep on systemtap
Bug: https://bugs.gentoo.org/675174 Package-Manager: Portage-2.3.54, Repoman-2.3.12 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
-rw-r--r--dev-java/openjdk/metadata.xml1
-rw-r--r--dev-java/openjdk/openjdk-11.0.1_p13.ebuild6
2 files changed, 5 insertions, 2 deletions
diff --git a/dev-java/openjdk/metadata.xml b/dev-java/openjdk/metadata.xml
index c76b9ca5d45e..efa076c6f48e 100644
--- a/dev-java/openjdk/metadata.xml
+++ b/dev-java/openjdk/metadata.xml
@@ -11,6 +11,7 @@
<flag name="gentoo-vm">Allow this JDK to be recognised by Gentoo (package manager, eselect, java-config, EXPERIMENTAL!)</flag>
<flag name="jbootstrap">Build OpenJDK twice, the second time using the result of the first</flag>
<flag name="source">Install JVM sources</flag>
+ <flag name="systemtap">Enable SystemTAP/DTrace tracing</flag>
<flag name="webstart">Provide javaws command through symlink to icedtea-web</flag>
</use>
</pkgmetadata>
diff --git a/dev-java/openjdk/openjdk-11.0.1_p13.ebuild b/dev-java/openjdk/openjdk-11.0.1_p13.ebuild
index 5b9ce2a9bd0e..d606429ebcf0 100644
--- a/dev-java/openjdk/openjdk-11.0.1_p13.ebuild
+++ b/dev-java/openjdk/openjdk-11.0.1_p13.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -33,12 +33,13 @@ REQUIRED_USE="
jvm_variant_zero? ( !jvm_variant_server !jvm_variant_client !jvm_variant_minimal )
"
-IUSE="+${IUSE} alsa debug doc examples gentoo-vm headless-awt +jbootstrap nsplugin +pch selinux source +webstart"
+IUSE="+${IUSE} alsa debug doc examples gentoo-vm headless-awt +jbootstrap nsplugin +pch selinux source systemtap +webstart"
CDEPEND="
media-libs/freetype:2=
net-print/cups
sys-libs/zlib
+ systemtap? ( dev-util/systemtap )
!headless-awt? (
x11-libs/libX11
x11-libs/libXext
@@ -170,6 +171,7 @@ src_configure() {
--with-version-pre=gentoo \
--with-version-string=${MY_PV%+*} \
--with-version-build=${MY_PV#*+} \
+ --enable-dtrace=$(usex systemtap yes no) \
--enable-headless-only=$(usex headless-awt yes no) \
--enable-full-docs=no \
--disable-ccache \