summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-03 10:46:27 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-03 10:49:59 +0200
commit61286e7ec6cb061c3d4ddccac8f446ef16866a4f (patch)
treeb0fade9c7cf2ec47b0f86685c73ec6403729eefb
parentdev-python/kconfiglib: Enable py3.12 (diff)
downloadgentoo-61286e7ec6cb061c3d4ddccac8f446ef16866a4f.tar.gz
gentoo-61286e7ec6cb061c3d4ddccac8f446ef16866a4f.tar.bz2
gentoo-61286e7ec6cb061c3d4ddccac8f446ef16866a4f.zip
dev-python/leather: Enable py3.12
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/leather/leather-0.3.4-r1.ebuild18
1 files changed, 14 insertions, 4 deletions
diff --git a/dev-python/leather/leather-0.3.4-r1.ebuild b/dev-python/leather/leather-0.3.4-r1.ebuild
index 8d7d673ac3b5..6008524a98e6 100644
--- a/dev-python/leather/leather-0.3.4-r1.ebuild
+++ b/dev-python/leather/leather-0.3.4-r1.ebuild
@@ -4,13 +4,19 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
DESCRIPTION="Python charting for 80% of humans"
-HOMEPAGE="https://github.com/wireservice/leather https://pypi.org/project/leather/"
-SRC_URI="https://github.com/wireservice/leather/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+HOMEPAGE="
+ https://github.com/wireservice/leather/
+ https://pypi.org/project/leather/
+"
+SRC_URI="
+ https://github.com/wireservice/leather/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
LICENSE="MIT"
SLOT="0"
@@ -20,7 +26,11 @@ RDEPEND="
dev-python/cssselect[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
"
-BDEPEND="test? ( dev-python/lxml[${PYTHON_USEDEP}] )"
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )
+"
distutils_enable_tests pytest
distutils_enable_sphinx docs \