summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-13 20:47:10 -0400
committerSam James <sam@gentoo.org>2024-03-14 01:59:47 +0000
commit6183a5d7f07a7d0e61a72437169ad6554497ce49 (patch)
tree46e1ba9ce5f00eca74fec00a696e93c7c90a679f
parentdev-libs/freexl: make sure elibtoolize is applied (diff)
downloadgentoo-6183a5d7f07a7d0e61a72437169ad6554497ce49.tar.gz
gentoo-6183a5d7f07a7d0e61a72437169ad6554497ce49.tar.bz2
gentoo-6183a5d7f07a7d0e61a72437169ad6554497ce49.zip
dev-db/spatialite: make sure elibtoolize is applied
Needed to e.g. pass LTO warning flags through to the linker. Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-db/spatialite/spatialite-5.0.1-r2.ebuild9
-rw-r--r--dev-db/spatialite/spatialite-5.1.0-r1.ebuild7
2 files changed, 15 insertions, 1 deletions
diff --git a/dev-db/spatialite/spatialite-5.0.1-r2.ebuild b/dev-db/spatialite/spatialite-5.0.1-r2.ebuild
index 3b51ff672d08..fceb9a7de979 100644
--- a/dev-db/spatialite/spatialite-5.0.1-r2.ebuild
+++ b/dev-db/spatialite/spatialite-5.0.1-r2.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
+inherit libtool
+
MY_PN="lib${PN}"
MY_P="${MY_PN}-${PV}"
@@ -31,6 +33,11 @@ DEPEND="${RDEPEND}"
REQUIRED_USE="test? ( iconv )"
+src_prepare() {
+ default
+ elibtoolize
+}
+
src_configure() {
# 1) gcp disabled for now to preserve MPL licence
econf \
diff --git a/dev-db/spatialite/spatialite-5.1.0-r1.ebuild b/dev-db/spatialite/spatialite-5.1.0-r1.ebuild
index a509af0c9b1a..ccfc1ed4aa66 100644
--- a/dev-db/spatialite/spatialite-5.1.0-r1.ebuild
+++ b/dev-db/spatialite/spatialite-5.1.0-r1.ebuild
@@ -3,6 +3,8 @@
EAPI=8
+inherit libtool
+
MY_PN="lib${PN}"
MY_P="${MY_PN}-${PV}"
@@ -31,6 +33,11 @@ DEPEND="${RDEPEND}"
REQUIRED_USE="test? ( iconv )"
+src_prepare() {
+ default
+ elibtoolize
+}
+
src_configure() {
# 1) gcp disabled for now to preserve MPL licence
econf \