summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-10-25 21:15:57 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-10-25 21:20:24 +0200
commit6187339fbad7ca56c3012ce6ec8f7f064b6b4748 (patch)
treec9d9484723014eb8cc7b90888779bf5550a08e74
parentmedia-libs/mlt: enable py3.11 (diff)
downloadgentoo-6187339fbad7ca56c3012ce6ec8f7f064b6b4748.tar.gz
gentoo-6187339fbad7ca56c3012ce6ec8f7f064b6b4748.tar.bz2
gentoo-6187339fbad7ca56c3012ce6ec8f7f064b6b4748.zip
net-libs/libsignon-glib: Support python3_11, EAPI-8
Fedora do it, so we can too. Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--net-libs/libsignon-glib/files/libsignon-glib-2.1-docs-optional.patch28
-rw-r--r--net-libs/libsignon-glib/files/libsignon-glib-2.1-meson-0.61.patch31
-rw-r--r--net-libs/libsignon-glib/libsignon-glib-2.1-r2.ebuild (renamed from net-libs/libsignon-glib/libsignon-glib-2.1-r1.ebuild)14
3 files changed, 68 insertions, 5 deletions
diff --git a/net-libs/libsignon-glib/files/libsignon-glib-2.1-docs-optional.patch b/net-libs/libsignon-glib/files/libsignon-glib-2.1-docs-optional.patch
new file mode 100644
index 000000000000..b31bd46a825e
--- /dev/null
+++ b/net-libs/libsignon-glib/files/libsignon-glib-2.1-docs-optional.patch
@@ -0,0 +1,28 @@
+From fc1098b3a376a04020c9e733eafda9fa0ac51723 Mon Sep 17 00:00:00 2001
+From: Pino Toscano <toscano.pino@tiscali.it>
+Date: Sat, 2 Jan 2021 14:19:18 +0100
+Subject: [PATCH] build: make documentation really optional
+
+Build of the documentation only if the meson option for it is enabled.
+---
+ meson.build | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/meson.build b/meson.build
+index 5d0de55..b10f80d 100644
+--- a/meson.build
++++ b/meson.build
+@@ -23,7 +23,9 @@ endif
+ root_dir = include_directories ('.')
+
+ subdir('libsignon-glib')
+-subdir('docs')
++if get_option('documentation')
++ subdir('docs')
++endif
+
+ if get_option('python')
+ subdir('pygobject')
+--
+GitLab
+
diff --git a/net-libs/libsignon-glib/files/libsignon-glib-2.1-meson-0.61.patch b/net-libs/libsignon-glib/files/libsignon-glib-2.1-meson-0.61.patch
new file mode 100644
index 000000000000..66254e398029
--- /dev/null
+++ b/net-libs/libsignon-glib/files/libsignon-glib-2.1-meson-0.61.patch
@@ -0,0 +1,31 @@
+From 4fae9155a19aca601072f361768e0bf8ed556b1e Mon Sep 17 00:00:00 2001
+From: Heiko Becker <heirecka@exherbo.org>
+Date: Tue, 11 Jan 2022 22:05:11 +0100
+Subject: [PATCH] Fix build with meson >= 0.61.0
+
+Otherwise it fails with "docs/reference/meson.build:21:6: ERROR:
+gnome.gtkdoc keyword argument 'expand_content_files' was of type
+array[File] but should have been array[str]".
+---
+ docs/reference/meson.build | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/docs/reference/meson.build b/docs/reference/meson.build
+index 654404b..3927109 100644
+--- a/docs/reference/meson.build
++++ b/docs/reference/meson.build
+@@ -47,9 +47,9 @@ gnome.gtkdoc(
+ 'libsignon-glib.types',
+ ],
+ content_files: doc_content_files,
+- expand_content_files: files(
++ expand_content_files: [
+ 'migrating-1to2.xml'
+- ),
++ ],
+ fixxref_args: [
+ '--extra-dir=@0@'.format(join_paths(glib_docpath, 'glib')),
+ '--extra-dir=@0@'.format(join_paths(glib_docpath, 'gobject')),
+--
+GitLab
+
diff --git a/net-libs/libsignon-glib/libsignon-glib-2.1-r1.ebuild b/net-libs/libsignon-glib/libsignon-glib-2.1-r2.ebuild
index 1fee6ac93428..7f697f3474bf 100644
--- a/net-libs/libsignon-glib/libsignon-glib-2.1-r1.ebuild
+++ b/net-libs/libsignon-glib/libsignon-glib-2.1-r2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7,8,9,10} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit meson python-r1 vala
DESCRIPTION="GLib binding for the D-Bus API provided by signond"
@@ -38,6 +38,11 @@ BDEPEND="$(python_gen_any_dep)
test? ( dev-libs/check )
"
+PATCHES=(
+ "${FILESDIR}/${P}-docs-optional.patch"
+ "${FILESDIR}/${P}-meson-0.61.patch"
+)
+
python_check_deps() { return 0; }
pkg_setup() {
@@ -46,9 +51,7 @@ pkg_setup() {
src_prepare() {
default
- vala_src_prepare
-
- use doc || sed -e "/^subdir('docs')$/d" -i meson.build || die
+ vala_setup
cp libsignon-glib/*.xml libsignon-glib/interfaces || die
}
@@ -57,6 +60,7 @@ src_configure() {
myconfigure() {
local emesonargs=(
-Ddebugging=$(usex debug true false)
+ -Ddocumentation=$(usex doc true false)
-Dintrospection=$(usex introspection true false)
-Dpython=$(usex python true false)
-Dtests=$(usex test true false)