summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-12-27 13:38:56 +1300
committerKent Fredric <kentnl@gentoo.org>2017-12-27 21:09:52 +1300
commit6302ee6cf776016c21e331233e4614d4c1b9062a (patch)
tree87e3de4973d1e8448db697e1587b57436c30bf7b
parentdev-perl/PDL-Transform-Color: Add missing CPAN remote-id's (diff)
downloadgentoo-6302ee6cf776016c21e331233e4614d4c1b9062a.tar.gz
gentoo-6302ee6cf776016c21e331233e4614d4c1b9062a.tar.bz2
gentoo-6302ee6cf776016c21e331233e4614d4c1b9062a.zip
dev-perl/PGPLOT: EAPI6 + Tests
- EAPI6ify - Enable tests - Fix test failures due to '.' in @INC - Ensure tests render to NULL device instead of XSERVER Package-Manager: Portage-2.3.18, Repoman-2.3.6
-rw-r--r--dev-perl/PGPLOT/PGPLOT-2.210.0-r1.ebuild23
-rw-r--r--dev-perl/PGPLOT/files/PGPLOT-2.21-no-dot-inc.patch25
-rw-r--r--dev-perl/PGPLOT/files/PGPLOT-2.21-null-render.patch30
3 files changed, 78 insertions, 0 deletions
diff --git a/dev-perl/PGPLOT/PGPLOT-2.210.0-r1.ebuild b/dev-perl/PGPLOT/PGPLOT-2.210.0-r1.ebuild
new file mode 100644
index 000000000000..482486e167ff
--- /dev/null
+++ b/dev-perl/PGPLOT/PGPLOT-2.210.0-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=KGB
+DIST_VERSION=2.21
+inherit perl-module
+
+DESCRIPTION="allow subroutines in the PGPLOT graphics library to be called from Perl"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="sci-libs/pgplot
+ >=dev-perl/ExtUtils-F77-1.13"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.21-no-dot-inc.patch"
+ "${FILESDIR}/${PN}-2.21-null-render.patch"
+)
diff --git a/dev-perl/PGPLOT/files/PGPLOT-2.21-no-dot-inc.patch b/dev-perl/PGPLOT/files/PGPLOT-2.21-no-dot-inc.patch
new file mode 100644
index 000000000000..b05067deeee5
--- /dev/null
+++ b/dev-perl/PGPLOT/files/PGPLOT-2.21-no-dot-inc.patch
@@ -0,0 +1,25 @@
+From 6d7ee026a19e889cbadbdaf9134588edf52e22c2 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Wed, 27 Dec 2017 13:23:26 +1300
+Subject: Fix test skips without '.' in @INC on Perl 5.25.7+
+
+---
+ test.pl | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/test.pl b/test.pl
+index d9a787c..d1b75ca 100755
+--- a/test.pl
++++ b/test.pl
+@@ -35,7 +35,7 @@ foreach $jjj (1..12) {
+
+ print "============== Running test$jjj.p ==============\n";
+ %@ = (); # Clear error status
+- do "test$jjj.p";
++ do "./test$jjj.p";
+ warn $@ if $@; # Report any error detected
+ if($dev eq '/PNG' && $^O =~ /mswin32/i) {
+ system("ren pgplot.png pgplot_$jjj.png");
+--
+2.15.1
+
diff --git a/dev-perl/PGPLOT/files/PGPLOT-2.21-null-render.patch b/dev-perl/PGPLOT/files/PGPLOT-2.21-null-render.patch
new file mode 100644
index 000000000000..b5db1d53cf8a
--- /dev/null
+++ b/dev-perl/PGPLOT/files/PGPLOT-2.21-null-render.patch
@@ -0,0 +1,30 @@
+From 39201312abf108ad5af4ff304484379154a237f1 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Wed, 27 Dec 2017 13:32:01 +1300
+Subject: Use NULL render device
+
+This absolves us from needing X11 for testing, while allowing
+explitly testing via X11 possible, including interactively if need be
+---
+ test.pl | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/test.pl b/test.pl
+index d1b75ca..95f7c25 100755
+--- a/test.pl
++++ b/test.pl
+@@ -22,9 +22,9 @@ else {$note = ''}
+ if ($ENV{'PGPLOT_DEV'}) {
+ $dev = $ENV{'PGPLOT_DEV'};
+ } else {
+-print "Default Device for plot tests [recommend /XSERVE] ? $note ";
++print "Default Device for plot tests [recommend /NULL] ? $note ";
+ $dev = <STDIN>; chomp $dev;
+-$dev = "/XSERVE" unless $dev=~/\w/;
++$dev = "/NULL" unless $dev=~/\w/;
+ }
+
+ if($dev eq '/PNG' && $^O =~ /mswin32/i) {system "del /F /Q *.png"};
+--
+2.15.1
+