summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2023-04-07 18:11:47 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2023-04-07 18:12:11 -0500
commit63119145e30db5c40ab9f5b34f8e71ebddc68274 (patch)
treea6c33dc5fed5ef4b44d456674d4732f5a2524b31
parentnet-misc/openvswitch: 2.17.6 fast stable for CVE-2023-1668 (diff)
downloadgentoo-63119145e30db5c40ab9f5b34f8e71ebddc68274.tar.gz
gentoo-63119145e30db5c40ab9f5b34f8e71ebddc68274.tar.bz2
gentoo-63119145e30db5c40ab9f5b34f8e71ebddc68274.zip
net-misc/openvswitch: removing old for CVE-2023-1668 cleanup
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
-rw-r--r--net-misc/openvswitch/Manifest2
-rw-r--r--net-misc/openvswitch/openvswitch-2.15.0.ebuild151
-rw-r--r--net-misc/openvswitch/openvswitch-2.17.2-r2.ebuild166
3 files changed, 0 insertions, 319 deletions
diff --git a/net-misc/openvswitch/Manifest b/net-misc/openvswitch/Manifest
index a4a31088badb..3bebee2ed69e 100644
--- a/net-misc/openvswitch/Manifest
+++ b/net-misc/openvswitch/Manifest
@@ -1,3 +1 @@
-DIST openvswitch-2.15.0.tar.gz 7434380 BLAKE2B c2f855ece89da3277f090d4328ff1659cc4976a4dbdfa44bdd4e750ea80e72592536af00250abe25565a6c2cda9f086ca22dcc16ed9db38692028a758995e9ac SHA512 a4e49268d6dd7d9d8fbf2005e8ffe45ede0998d21c98d7018474142656c65c05b14c8a7e4c7d8e0eea36e28d87550826225205e1fa03055d35a8cb048617c832
-DIST openvswitch-2.17.2.tar.gz 7955727 BLAKE2B da7ffc29b6af5dbf8eeb410725ed4cb6b6c5f4abe22f17d0963429a3333e459e1d4cc4ef06d13518dc2486d5e9e78a090318ad66e50175606e47fcf1d61cfce7 SHA512 e01e41ef2fea21afcc891b8ab0a773fe7c9adf873853e10926b8bde2fd970e12b354010687439238e8d80a87884f497f7396a4a1f2b179104e49e87c66cfc79e
DIST openvswitch-2.17.6.tar.gz 8092331 BLAKE2B 0564a332e8c876552a9a3a068f4e54d3f5d56428e277e32f188aba9626035818c900be45171964ddcb782166a5e5b3b8f3a2fb80d5ed9723b94c9e1ed7410544 SHA512 ff9d19a9101c9a18117a859150d391eecbd6a331e35da3f20a62acaac1febbfbad716874734f9bd0d304d635212884f9f617b944e79bb7e554ddd9e5c53645c8
diff --git a/net-misc/openvswitch/openvswitch-2.15.0.ebuild b/net-misc/openvswitch/openvswitch-2.15.0.ebuild
deleted file mode 100644
index 620028a7b31f..000000000000
--- a/net-misc/openvswitch/openvswitch-2.15.0.ebuild
+++ /dev/null
@@ -1,151 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_9 )
-
-inherit autotools linux-info linux-mod python-r1 systemd tmpfiles
-
-DESCRIPTION="Production quality, multilayer virtual switch"
-HOMEPAGE="https://www.openvswitch.org"
-SRC_URI="https://www.openvswitch.org/releases/${P}.tar.gz"
-
-LICENSE="Apache-2.0 GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="debug modules monitor +ssl"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-RDEPEND="
- ssl? ( dev-libs/openssl:0= )
- ${PYTHON_DEPS}
- ~dev-python/ovs-2.13.3[${PYTHON_USEDEP}]
- dev-python/twisted[conch,${PYTHON_USEDEP}]
- dev-python/zope-interface[${PYTHON_USEDEP}]
- debug? ( dev-lang/perl )"
-DEPEND="${RDEPEND}
- sys-apps/util-linux[caps]"
-BDEPEND="virtual/pkgconfig"
-
-PATCHES="
- "${FILESDIR}/xcp-interface-reconfigure-2.3.2.patch"
-"
-
-CONFIG_CHECK="~NET_CLS_ACT ~NET_CLS_U32 ~NET_SCH_INGRESS ~NET_ACT_POLICE ~IPV6 ~TUN"
-MODULE_NAMES="openvswitch(net:${S}/datapath/linux)"
-BUILD_TARGETS="all"
-
-pkg_setup() {
- if use modules ; then
- CONFIG_CHECK+=" ~!OPENVSWITCH"
- kernel_is ge 3 10 0 || die "Linux >= 3.10.0 and <= 5.8 required for userspace modules"
- kernel_is le 5 8 999 || die "Linux >= 3.10.0 and <= 5.8 required for userspace modules"
- linux-mod_pkg_setup
- else
- CONFIG_CHECK+=" ~OPENVSWITCH"
- linux-info_pkg_setup
- fi
-}
-
-src_prepare() {
- # Never build kernelmodules, doing this manually
- sed -i \
- -e '/^SUBDIRS/d' \
- datapath/Makefile.in || die "sed failed"
- eautoreconf
- default
-}
-
-src_configure() {
- set_arch_to_kernel
- # monitor is statically enabled for bug 596206
- # use monitor || export ovs_cv_python="no"
- # pyside is staticly disabled
- export ovs_cv_pyuic4="no"
-
- # flake8 is primarily a style guide tool, running it as part of the tests
- # in Gentoo does not make much sense, only breaks them: bug 607280
- export ovs_cv_flake8="no"
-
- local linux_config
- use modules && linux_config="--with-linux=${KV_OUT_DIR}"
-
- econf ${linux_config} \
- --with-rundir=/var/run/openvswitch \
- --with-logdir=/var/log/openvswitch \
- --with-pkidir=/etc/ssl/openvswitch \
- --with-dbdir=/var/lib/openvswitch \
- $(use_enable ssl) \
- $(use_enable !debug ndebug)
-}
-
-src_compile() {
- default
-
- use modules && linux-mod_src_compile
-}
-
-src_install() {
- default
-
- local SCRIPT
- if use monitor; then
- # ovs-bugtool is installed to sbin by the build system, but we
- # install it to bin below, and these clash in merged-usr
- # https://bugs.gentoo.org/889846
- rm "${ED}"/usr/sbin/ovs-bugtool || die
-
- for SCRIPT in ovs-{pcap,parse-backtrace,dpctl-top,l3ping,tcpdump,tcpundump,test,vlan-test} bugtool/ovs-bugtool; do
- sed -e '1s|^.*$|#!/usr/bin/python|' -i utilities/"${SCRIPT}"
- python_foreach_impl python_doscript utilities/"${SCRIPT}"
- done
- rm -r "${ED}"/usr/share/openvswitch/python || die
- fi
-
- keepdir /var/{lib,log}/openvswitch
- keepdir /etc/ssl/openvswitch
- fperms 0750 /etc/ssl/openvswitch
-
- rm -rf "${ED}"/var/run || die
-
- newconfd "${FILESDIR}/ovsdb-server_conf2" ovsdb-server
- newconfd "${FILESDIR}/ovs-vswitchd.confd-r2" ovs-vswitchd
- newinitd "${FILESDIR}/ovsdb-server-r1" ovsdb-server
- newinitd "${FILESDIR}/ovs-vswitchd-r1" ovs-vswitchd
-
- systemd_newunit "${FILESDIR}/ovsdb-server-r3.service" ovsdb-server.service
- systemd_newunit "${FILESDIR}/ovs-vswitchd-r3.service" ovs-vswitchd.service
- systemd_newunit rhel/usr_lib_systemd_system_ovs-delete-transient-ports.service ovs-delete-transient-ports.service
- newtmpfiles "${FILESDIR}/openvswitch.tmpfiles" openvswitch.conf
-
- insinto /etc/logrotate.d
- newins rhel/etc_logrotate.d_openvswitch openvswitch
-
- use modules && linux-mod_src_install
-}
-
-pkg_postinst() {
- use modules && linux-mod_pkg_postinst
-
- tmpfiles_process openvswitch.conf
-
- # only needed on non-systemd, but helps anyway
- elog "Use the following command to create an initial database for ovsdb-server:"
- elog " emerge --config =${CATEGORY}/${PF}"
- elog "(will create a database in /var/lib/openvswitch/conf.db)"
- elog "or to convert the database to the current schema after upgrading."
-}
-
-pkg_config() {
- local db="${EROOT%}"/var/lib/openvswitch/conf.db
- if [[ -e "${db}" ]] ; then
- einfo "Database '${db}' already exists, doing schema migration..."
- einfo "(if the migration fails, make sure that ovsdb-server is not running)"
- ovsdb-tool convert "${db}" \
- "${EROOT}"/usr/share/openvswitch/vswitch.ovsschema || die "converting database failed"
- else
- einfo "Creating new database '${db}'..."
- ovsdb-tool create "${db}" \
- "${EROOT}"/usr/share/openvswitch/vswitch.ovsschema || die "creating database failed"
- fi
-}
diff --git a/net-misc/openvswitch/openvswitch-2.17.2-r2.ebuild b/net-misc/openvswitch/openvswitch-2.17.2-r2.ebuild
deleted file mode 100644
index c17e37e3f3bb..000000000000
--- a/net-misc/openvswitch/openvswitch-2.17.2-r2.ebuild
+++ /dev/null
@@ -1,166 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-MODULES_OPTIONAL_USE="modules"
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit autotools linux-info linux-mod python-single-r1 systemd tmpfiles
-
-DESCRIPTION="Production quality, multilayer virtual switch"
-HOMEPAGE="https://www.openvswitch.org"
-SRC_URI="https://www.openvswitch.org/releases/${P}.tar.gz"
-
-LICENSE="Apache-2.0 GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ~ppc64 x86"
-IUSE="debug modules monitor +ssl unwind"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-# Check python/ovs/version.py in tarball for dev-python/ovs dep
-RDEPEND="${PYTHON_DEPS}
- $(python_gen_cond_dep '
- ~dev-python/ovs-2.17.1_p1[${PYTHON_USEDEP}]
- dev-python/twisted[${PYTHON_USEDEP}]
- dev-python/zope-interface[${PYTHON_USEDEP}]
- ')
- debug? ( dev-lang/perl )
- unwind? ( sys-libs/libunwind:= )
- ssl? ( dev-libs/openssl:= )"
-DEPEND="${RDEPEND}
- sys-apps/util-linux[caps]"
-BDEPEND="virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}/xcp-interface-reconfigure-2.3.2.patch"
-)
-
-CONFIG_CHECK="~NET_CLS_ACT ~NET_CLS_U32 ~NET_SCH_INGRESS ~NET_ACT_POLICE ~IPV6 ~TUN"
-MODULE_NAMES="openvswitch(net:${S}/datapath/linux)"
-BUILD_TARGETS="all"
-
-pkg_setup() {
- if use modules ; then
- CONFIG_CHECK+=" ~!OPENVSWITCH"
- kernel_is ge 3 10 0 || die "Linux >= 3.10.0 and <= 5.8 required for userspace modules"
- kernel_is le 5 8 999 || die "Linux >= 3.10.0 and <= 5.8 required for userspace modules"
- linux-mod_pkg_setup
- else
- CONFIG_CHECK+=" ~OPENVSWITCH"
- linux-info_pkg_setup
- fi
-}
-
-src_prepare() {
- default
-
- # Never build kernelmodules, doing this manually
- sed -i \
- -e '/^SUBDIRS/d' \
- datapath/Makefile.in || die "sed failed"
-
- eautoreconf
-}
-
-src_configure() {
- set_arch_to_kernel
- python_setup
-
- # monitor is statically enabled for bug #596206
- # use monitor || export ovs_cv_python="no"
- # pyside is staticly disabled
- export ovs_cv_pyuic4="no"
-
- # flake8 is primarily a style guide tool, running it as part of the tests
- # in Gentoo does not make much sense, only breaks them: bug #607280
- export ovs_cv_flake8="no"
-
- # Only adds a diagram to the man page, just skip it as we don't
- # want to add a BDEPEND on graphviz right now. bug #856286
- export ovs_cv_dot="no"
-
- local linux_config
- use modules && linux_config="--with-linux=${KV_OUT_DIR}"
-
- export ac_cv_lib_unwind_unw_backtrace="$(usex unwind)"
-
- # Need PYTHON3 variable for bug #860240
- PYTHON3="${PYTHON}" CONFIG_SHELL="${BROOT}"/bin/bash SHELL="${BROOT}"/bin/bash econf ${linux_config} \
- --with-rundir=/var/run/openvswitch \
- --with-logdir=/var/log/openvswitch \
- --with-pkidir=/etc/ssl/openvswitch \
- --with-dbdir=/var/lib/openvswitch \
- $(use_enable ssl) \
- $(use_enable !debug ndebug)
-}
-
-src_compile() {
- default
-
- use modules && linux-mod_src_compile
-}
-
-src_install() {
- default
-
- local SCRIPT
- if use monitor; then
- # ovs-bugtool is installed to sbin by the build system, but we
- # install it to bin below, and these clash in merged-usr
- # https://bugs.gentoo.org/889846
- rm "${ED}"/usr/sbin/ovs-bugtool || die
-
- for SCRIPT in ovs-{pcap,parse-backtrace,dpctl-top,l3ping,tcpdump,tcpundump,test,vlan-test} bugtool/ovs-bugtool; do
- python_doscript utilities/"${SCRIPT}"
- done
- rm -r "${ED}"/usr/share/openvswitch/python || die
- fi
-
- keepdir /var/{lib,log}/openvswitch
- keepdir /etc/ssl/openvswitch
- fperms 0750 /etc/ssl/openvswitch
-
- rm -rf "${ED}"/var/run || die
-
- newconfd "${FILESDIR}/ovsdb-server_conf2" ovsdb-server
- newconfd "${FILESDIR}/ovs-vswitchd.confd-r2" ovs-vswitchd
- newinitd "${FILESDIR}/ovsdb-server-r1" ovsdb-server
- newinitd "${FILESDIR}/ovs-vswitchd-r1" ovs-vswitchd
-
- systemd_newunit "${FILESDIR}/ovsdb-server-r3.service" ovsdb-server.service
- systemd_newunit "${FILESDIR}/ovs-vswitchd-r3.service" ovs-vswitchd.service
- systemd_newunit rhel/usr_lib_systemd_system_ovs-delete-transient-ports.service ovs-delete-transient-ports.service
- newtmpfiles "${FILESDIR}/openvswitch.tmpfiles" openvswitch.conf
-
- insinto /etc/logrotate.d
- newins rhel/etc_logrotate.d_openvswitch openvswitch
-
- use modules && linux-mod_src_install
-}
-
-pkg_postinst() {
- use modules && linux-mod_pkg_postinst
-
- tmpfiles_process openvswitch.conf
-
- # Only needed on non-systemd, but helps anyway
- elog "Use the following command to create an initial database for ovsdb-server:"
- elog " emerge --config =${CATEGORY}/${PF}"
- elog "(will create a database in /var/lib/openvswitch/conf.db)"
- elog "or to convert the database to the current schema after upgrading."
-}
-
-pkg_config() {
- local db="${EROOT%}"/var/lib/openvswitch/conf.db
- if [[ -e "${db}" ]] ; then
- einfo "Database '${db}' already exists, doing schema migration..."
- einfo "(if the migration fails, make sure that ovsdb-server is not running)"
- ovsdb-tool convert "${db}" \
- "${EROOT}"/usr/share/openvswitch/vswitch.ovsschema || die "converting database failed"
- else
- einfo "Creating new database '${db}'..."
- ovsdb-tool create "${db}" \
- "${EROOT}"/usr/share/openvswitch/vswitch.ovsschema || die "creating database failed"
- fi
-}