summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2021-11-18 15:55:41 -0500
committerMike Gilbert <floppym@gentoo.org>2021-11-18 15:56:50 -0500
commit63f94351d52a140018ec2f9432131a3c8a3327bd (patch)
tree69b90d3e5739edb1defc64a896215bb166b4dd01
parentdev-perl/MooseX-Types-Path-Class: EAPI=8 bump (diff)
downloadgentoo-63f94351d52a140018ec2f9432131a3c8a3327bd.tar.gz
gentoo-63f94351d52a140018ec2f9432131a3c8a3327bd.tar.bz2
gentoo-63f94351d52a140018ec2f9432131a3c8a3327bd.zip
sys-boot/systemd-boot: add 249.6, drop 249
Closes: https://bugs.gentoo.org/824026 Signed-off-by: Mike Gilbert <floppym@gentoo.org>
-rw-r--r--sys-boot/systemd-boot/Manifest2
-rw-r--r--sys-boot/systemd-boot/files/249-linux-headers-5-15.patch22
-rw-r--r--sys-boot/systemd-boot/systemd-boot-249.6.ebuild (renamed from sys-boot/systemd-boot/systemd-boot-249.ebuild)11
3 files changed, 8 insertions, 27 deletions
diff --git a/sys-boot/systemd-boot/Manifest b/sys-boot/systemd-boot/Manifest
index 209a35c38f4e..ec8fbe294598 100644
--- a/sys-boot/systemd-boot/Manifest
+++ b/sys-boot/systemd-boot/Manifest
@@ -1 +1 @@
-DIST systemd-249.tar.gz 10588828 BLAKE2B f7896dea0bdec25125188b94ee84270b972649b1eb16599bed1967ced79f62dbfd1494e22362934f418823c054b342fb24dc57706b49520814beb95b6956bf27 SHA512 0810d09cc32e4aaa4425ee5b7ddf129262b061ce159cbd43571fabda48285243d8f80b566379ece9215d531b9407ee45e1e72c71935644fea31c7bca1bbf540c
+DIST systemd-stable-249.6.tar.gz 10599611 BLAKE2B 9c0cbaa4319f2ce9a78dbe820d1b6df5191e6c632e2eac9f71f9ff9817564d9b3fc177d2aec0c0daea8ac33bbdc2066ad68a8967cf8857f4af3668b9a3e7d3bf SHA512 7a7791dfe4923c00987b924adcb1cd08c4d17af2b17b4c6c6c701856c6810cfda61f06821c39787339fc05293853c0ea61b9973fcf4495c7bf4f8054ecfae66f
diff --git a/sys-boot/systemd-boot/files/249-linux-headers-5-15.patch b/sys-boot/systemd-boot/files/249-linux-headers-5-15.patch
deleted file mode 100644
index 398119d77432..000000000000
--- a/sys-boot/systemd-boot/files/249-linux-headers-5-15.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-https://github.com/systemd/systemd-stable/pull/132/commits/92bbfcdc733d39ec4097d8678bc92a7aaaf78ae1.patch
-https://bugs.gentoo.org/823810
-
-From: Chris Packham <chris.packham@alliedtelesis.co.nz>
-Date: Fri, 10 Sep 2021 09:51:36 +1200
-Subject: [PATCH 1/2] basic/linux: Sync if_arp.h with Linux 5.14
-
-ARPHRD_MCTP was added in 5.14. Sync if_arp.h to pick up the definition
-
-Fixes #20694
-
-(cherry picked from commit 7c5b9952c4f6e2b72f90edbe439982528b7cf223)
---- a/src/basic/linux/if_arp.h
-+++ b/src/basic/linux/if_arp.h
-@@ -54,6 +54,7 @@
- #define ARPHRD_X25 271 /* CCITT X.25 */
- #define ARPHRD_HWX25 272 /* Boards with X.25 in firmware */
- #define ARPHRD_CAN 280 /* Controller Area Network */
-+#define ARPHRD_MCTP 290
- #define ARPHRD_PPP 512
- #define ARPHRD_CISCO 513 /* Cisco HDLC */
- #define ARPHRD_HDLC ARPHRD_CISCO
diff --git a/sys-boot/systemd-boot/systemd-boot-249.ebuild b/sys-boot/systemd-boot/systemd-boot-249.6.ebuild
index 6a1255a2e06b..8ae443c2d75f 100644
--- a/sys-boot/systemd-boot/systemd-boot-249.ebuild
+++ b/sys-boot/systemd-boot/systemd-boot-249.6.ebuild
@@ -8,7 +8,13 @@ inherit meson python-any-r1 toolchain-funcs
DESCRIPTION="UEFI boot manager from systemd (formerly gummiboot)"
HOMEPAGE="https://www.freedesktop.org/wiki/Software/systemd/systemd-boot/"
-SRC_URI="https://github.com/systemd/systemd/archive/v${PV}.tar.gz -> systemd-${PV}.tar.gz"
+if [[ ${PV} == *.* ]]; then
+ SRC_URI="https://github.com/systemd/systemd-stable/archive/v${PV}.tar.gz -> systemd-stable-${PV}.tar.gz"
+ S="${WORKDIR}/systemd-stable-${PV}"
+else
+ SRC_URI="https://github.com/systemd/systemd/archive/v${PV}.tar.gz -> systemd-${PV}.tar.gz"
+ S="${WORKDIR}/systemd-${PV}"
+fi
LICENSE="GPL-2 LGPL-2.1 MIT public-domain"
SLOT="0"
@@ -46,11 +52,8 @@ RDEPEND="${COMMON_DEPEND}
QA_FLAGS_IGNORED="usr/lib/systemd/boot/efi/.*"
QA_EXECSTACK="usr/lib/systemd/boot/efi/*"
-S="${WORKDIR}/systemd-${PV}"
-
PATCHES=(
"${FILESDIR}/249-libshared-static.patch"
- "${FILESDIR}/249-linux-headers-5-15.patch"
)
src_configure() {