summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2019-08-05 12:16:45 +0200
committerManuel Rüger <mrueg@gentoo.org>2019-08-05 12:16:45 +0200
commit6522e7d94f441274f07f72627f445e989f75813a (patch)
treea17164d055d839419a8596fc77656284d64dc656
parentdev-db/pgpool2: Cleanup 3.7.8, 4.0.3 (diff)
downloadgentoo-6522e7d94f441274f07f72627f445e989f75813a.tar.gz
gentoo-6522e7d94f441274f07f72627f445e989f75813a.tar.bz2
gentoo-6522e7d94f441274f07f72627f445e989f75813a.zip
dev-python/docker-py: Version bump to 3.7.3
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Manuel Rüger <mrueg@gentoo.org>
-rw-r--r--dev-python/docker-py/Manifest1
-rw-r--r--dev-python/docker-py/docker-py-3.7.3.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/docker-py/Manifest b/dev-python/docker-py/Manifest
index d95c1f829b8b..2867c927ee40 100644
--- a/dev-python/docker-py/Manifest
+++ b/dev-python/docker-py/Manifest
@@ -4,3 +4,4 @@ DIST docker-py-3.5.1.tar.gz 209381 BLAKE2B de0992aff9af240eeb79b66f0f7ca11aca413
DIST docker-py-3.6.0.tar.gz 213435 BLAKE2B 28301a508ef346373f8ac4033b697a71092c4162ba1be81bc69c513d1de700326a4e8ffcb1c015e20516aa1a09d31162d54182985eea3dc1dc23d6e79ef28fea SHA512 b32acb2585995c3c5bdef95ea4bbb6bcadba3b9fca81a3e637dc294b5dbd3823ee6c98236c4bb197373a96feafcaae665b9c64b805abd52e1ae27aa42079278d
DIST docker-py-3.7.0.tar.gz 220407 BLAKE2B 3ba217957ff8746fb399ba23e4513810ffd96a758bfc5eba908ab3c66eb0a9711d94e5d9f517c301602961a21490659628d0a3deec3a4286155a4f5469304a3b SHA512 444634a26d0ce7af4850f346286cdac7f2c597aa6ce349c6371dbaa670aa0bcc2fa192221783b2059750d682580e34fcc5e115aeda0884838bf966decf9d0070
DIST docker-py-3.7.1.tar.gz 220882 BLAKE2B a7547d2989b3fc2dfc38dfffb909508b7a5b3f8ee6b0fc874a73d0cdfaa17fe28c971f5a226893a41d893e75b1b2e4c74da806996e85b097b3a85b2d8dadcfcb SHA512 0a89c5fc05423d913b1029390318d9cd4ca54a3b4df1e9a9f459e27fa114fd7b03047ff95f3ea2ef6bb2cb48c5f6fe712da11c940249d3b253aa3fe74b8b1c98
+DIST docker-py-3.7.3.tar.gz 221311 BLAKE2B 6bdfc5cd53fccec6e060d08ebde845d373f961a8a418e3bfbeac79e736f64aa07807a4f2074d243765d10c0e4cc87c672d039cdefe4223ec1b33b56cf4ea31a9 SHA512 d3217361617f12e841bfa443c7ab4b44ca5f7ead8b40834919aad9043220efa7611a8bd18cbec6adc4d98f2551bfb169535e1eec904b90425648093c0d6a1722
diff --git a/dev-python/docker-py/docker-py-3.7.3.ebuild b/dev-python/docker-py/docker-py-3.7.3.ebuild
new file mode 100644
index 000000000000..2573b1681c68
--- /dev/null
+++ b/dev-python/docker-py/docker-py-3.7.3.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python client for Docker"
+HOMEPAGE="https://github.com/docker/docker-py"
+SRC_URI="https://github.com/docker/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-python/docker-pycreds-0.4.0[${PYTHON_USEDEP}]
+ !~dev-python/requests-2.18.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-python/backports-ssl-match-hostname-3.5[${PYTHON_USEDEP}]' 'python2_7' )
+ $(python_gen_cond_dep '>=dev-python/ipaddress-1.0.16[${PYTHON_USEDEP}]' 'python2_7' )
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ dev-python/paramiko[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ >=dev-python/pytest-2.9.1[${PYTHON_USEDEP}]
+ )
+ doc? (
+ dev-python/recommonmark[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.4.6[${PYTHON_USEDEP}]
+ )
+"
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build docs html || die "docs failed to build"
+ HTML_DOCS=( html/. )
+ fi
+}
+
+python_test() {
+ py.test tests/unit/ || die "tests failed under ${EPYTHON}"
+}