summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Laurantin <olivier.laurantin@laposte.net>2021-12-31 10:38:27 +0100
committerSam James <sam@gentoo.org>2022-01-07 05:05:30 +0000
commit673f9ffca5670706d807a4d984c94b32771ad970 (patch)
tree3067e4b18af019c89438ec0708fbac2e53c8ef76
parentsys-process/atop: install init script for netatop (diff)
downloadgentoo-673f9ffca5670706d807a4d984c94b32771ad970.tar.gz
gentoo-673f9ffca5670706d807a4d984c94b32771ad970.tar.bz2
gentoo-673f9ffca5670706d807a4d984c94b32771ad970.zip
net-wireless/blueberry: version bump to 1.4.6
Update to latest upstream version Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Olivier Laurantin <olivier.laurantin@laposte.net> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--net-wireless/blueberry/Manifest1
-rw-r--r--net-wireless/blueberry/blueberry-1.4.6.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/net-wireless/blueberry/Manifest b/net-wireless/blueberry/Manifest
index 54e934943563..551a2dd2958b 100644
--- a/net-wireless/blueberry/Manifest
+++ b/net-wireless/blueberry/Manifest
@@ -1 +1,2 @@
DIST blueberry-1.4.2.tar.gz 1414169 BLAKE2B cd55e2bb572efb2badeab1667324df67c35f5833c53755c76c0793c07e8427c7d4714135014dad90aeaddc806c798f2b89960a051a15f668d214bb95cc0943e3 SHA512 5c2fb94e842cd1229682305f0054061724b958406ea15a64495ca418aa7da73c38b45ddc43c27a193aef995ab860cad985e3369e3dac53d2098463e6e4250493
+DIST blueberry-1.4.6.tar.gz 1415484 BLAKE2B 2b0a737d6e9e10f4f8502ab6af5e90b35e2eb651a48b431a0738cf06817ca49f12e9cdf6e0a3221b42370a00cca23c7da54d75c1f801968f1ee6d87dc3523590 SHA512 580b0a0434bb3c980158361a22ad0d8a502cb8b9c5d92adf4e97fdc28405bd5422709d4c605923371284457389f68aebce3e4599b7dd0c35866b65bb4fc2355a
diff --git a/net-wireless/blueberry/blueberry-1.4.6.ebuild b/net-wireless/blueberry/blueberry-1.4.6.ebuild
new file mode 100644
index 000000000000..d4077a454e74
--- /dev/null
+++ b/net-wireless/blueberry/blueberry-1.4.6.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9} )
+
+inherit gnome2-utils python-single-r1 xdg-utils
+
+DESCRIPTION="A Bluetooth configuration tool"
+HOMEPAGE="https://github.com/linuxmint/blueberry"
+SRC_URI="https://github.com/linuxmint/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ dev-python/xapp[${PYTHON_USEDEP}]
+ ')
+ >=net-wireless/gnome-bluetooth-3.14[introspection]
+ net-wireless/bluez[obex]
+ net-wireless/bluez-tools
+ || (
+ >=sys-apps/util-linux-2.31_rc1
+ net-wireless/rfkill
+ )
+ x11-libs/libnotify[introspection]
+ x11-misc/wmctrl"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ python_fix_shebang usr/lib
+}
+
+src_install() {
+ doins -r etc
+ exeinto /usr/bin
+ doexe usr/bin/*
+ exeinto /usr/lib/blueberry
+ doexe usr/lib/blueberry/*
+ insinto /usr
+ doins -r usr/share
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_icon_cache_update
+}