summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2017-12-28 08:47:03 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2018-01-01 22:01:26 +0100
commit67d8e6ab960a4756354b4b1593648287585529f5 (patch)
tree58567999648f7f8d54dbeada0dd648163f8d6d94
parentx11-plugins/wmload: remove unused patches (diff)
downloadgentoo-67d8e6ab960a4756354b4b1593648287585529f5.tar.gz
gentoo-67d8e6ab960a4756354b4b1593648287585529f5.tar.bz2
gentoo-67d8e6ab960a4756354b4b1593648287585529f5.zip
x11-plugins/wmtz: remove unused patches
-rw-r--r--x11-plugins/wmtz/files/wmtz-0.7-list.patch127
-rw-r--r--x11-plugins/wmtz/files/wmtz-0.7.patch48
2 files changed, 0 insertions, 175 deletions
diff --git a/x11-plugins/wmtz/files/wmtz-0.7-list.patch b/x11-plugins/wmtz/files/wmtz-0.7-list.patch
deleted file mode 100644
index 1b1ac317669e..000000000000
--- a/x11-plugins/wmtz/files/wmtz-0.7-list.patch
+++ /dev/null
@@ -1,127 +0,0 @@
-diff -Naur wmgeneral.orig/list.c wmgeneral/list.c
---- wmgeneral.orig/list.c 2016-01-04 13:28:36.583339716 +0100
-+++ wmgeneral/list.c 2016-01-04 13:28:48.694343645 +0100
-@@ -38,7 +38,7 @@
-
- /* Return a cons cell produced from (head . tail)
-
--INLINE LinkedList*
-+LinkedList*
- list_cons(void* head, LinkedList* tail)
- {
- LinkedList* cell;
-@@ -51,7 +51,7 @@
-
- /* Return the length of a list, list_length(NULL) returns zero
-
--INLINE int
-+int
- list_length(LinkedList* list)
- {
- int i = 0;
-@@ -66,7 +66,7 @@
- /* Return the Nth element of LIST, where N count from zero. If N
- larger than the list length, NULL is returned
-
--INLINE void*
-+void*
- list_nth(int index, LinkedList* list)
- {
- while(index-- != 0)
-@@ -81,7 +81,7 @@
-
- /* Remove the element at the head by replacing it by its successor
-
--INLINE void
-+void
- list_remove_head(LinkedList** list)
- {
- if (!*list) return;
-@@ -101,7 +101,7 @@
-
- /* Remove the element with `car' set to ELEMENT
- /*
--INLINE void
-+void
- list_remove_elem(LinkedList** list, void* elem)
- {
- while (*list)
-@@ -112,7 +112,7 @@
- }
-
-
--INLINE LinkedList *
-+LinkedList *
- list_remove_elem(LinkedList* list, void* elem)
- {
- LinkedList *tmp;
-@@ -132,7 +132,7 @@
-
- /* Return element that has ELEM as car
-
--INLINE LinkedList*
-+LinkedList*
- list_find(LinkedList* list, void* elem)
- {
- while(list)
-@@ -146,7 +146,7 @@
-
- /* Free list (backwards recursive)
-
--INLINE void
-+void
- list_free(LinkedList* list)
- {
- if(list)
-@@ -158,7 +158,7 @@
-
- /* Map FUNCTION over all elements in LIST
-
--INLINE void
-+void
- list_mapcar(LinkedList* list, void(*function)(void*))
- {
- while(list)
-diff -Naur wmgeneral.orig/list.h wmgeneral/list.h
---- wmgeneral.orig/list.h 2016-01-04 13:28:36.583339716 +0100
-+++ wmgeneral/list.h 2016-01-04 13:28:39.471340654 +0100
-@@ -29,31 +29,25 @@
- #ifndef __LIST_H_
- #define __LIST_H_
-
--#if defined(__GNUC__) && !defined(__STRICT_ANSI__)
--# define INLINE inline
--#else
--# define INLINE
--#endif
--
- typedef struct LinkedList {
- void *head;
- struct LinkedList *tail;
- } LinkedList;
-
--INLINE LinkedList* list_cons(void* head, LinkedList* tail);
-+LinkedList* list_cons(void* head, LinkedList* tail);
-
--INLINE int list_length(LinkedList* list);
-+int list_length(LinkedList* list);
-
--INLINE void* list_nth(int index, LinkedList* list);
-+void* list_nth(int index, LinkedList* list);
-
--INLINE void list_remove_head(LinkedList** list);
-+void list_remove_head(LinkedList** list);
-
--INLINE LinkedList *list_remove_elem(LinkedList* list, void* elem);
-+LinkedList *list_remove_elem(LinkedList* list, void* elem);
-
--INLINE void list_mapcar(LinkedList* list, void(*function)(void*));
-+void list_mapcar(LinkedList* list, void(*function)(void*));
-
--INLINE LinkedList*list_find(LinkedList* list, void* elem);
-+LinkedList*list_find(LinkedList* list, void* elem);
-
--INLINE void list_free(LinkedList* list);
-+void list_free(LinkedList* list);
-
- #endif
diff --git a/x11-plugins/wmtz/files/wmtz-0.7.patch b/x11-plugins/wmtz/files/wmtz-0.7.patch
deleted file mode 100644
index adb5c68f1b6c..000000000000
--- a/x11-plugins/wmtz/files/wmtz-0.7.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-diff -ur wmtz-0.7.orig/wmtz/Makefile wmtz-0.7/wmtz/Makefile
---- wmtz-0.7.orig/wmtz/Makefile 2001-03-11 15:57:59.000000000 +0200
-+++ wmtz-0.7/wmtz/Makefile 2008-01-12 15:24:29.000000000 +0200
-@@ -1,5 +1,5 @@
- CC = gcc
--LIBDIR = -L/usr/X11R6/lib
-+LIBDIR = -L/usr/lib
- LIBS = -lXpm -lXext -lX11 -lm
- FLAGS = -O2
- DESTDIR = /usr/local
-@@ -10,7 +10,7 @@
-
-
- .c.o:
-- $(CC) -I/usr/X11R6/include $(FLAGS) -c -Wall $< -o $*.o
-+ $(CC) -I/usr/include $(FLAGS) -c -Wall $< -o $*.o
-
- wmtz: $(OBJS)
- $(CC) $(FLAGS) -o wmtz $^ -lXext $(LIBDIR) $(LIBS)
-diff -ur wmtz-0.7.orig/wmtz/wmtz.c wmtz-0.7/wmtz/wmtz.c
---- wmtz-0.7.orig/wmtz/wmtz.c 2001-04-16 22:26:34.000000000 +0300
-+++ wmtz-0.7/wmtz/wmtz.c 2008-01-12 15:17:37.000000000 +0200
-@@ -51,8 +51,7 @@
- #define STRSIZE 10
- #define LMST 1
- #define GMST 0
--#define ABOUT "xmessage -center -buttons \"Close\" \"WMTZ - Window Maker Time Zone dockapp v0.7
--http://www.geocities.com/jl1n/wmtz/wmtz.html\""
-+#define ABOUT "xmessage -center -buttons \"Close\" \"WMTZ - Window Maker Time Zone dockapp v0.7\nhttp://www.geocities.com/jl1n/wmtz/wmtz.html\""
-
-
- /*
-@@ -479,6 +478,7 @@
- but_stat = -1;
- break;
- default:
-+ break;
- }
- }
-
-@@ -529,6 +529,7 @@
- exit(0);
- break;
- default:
-+ break;
- }
- return;
- }