summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-31 17:30:45 +0200
committerMichał Górny <mgorny@gentoo.org>2024-03-31 17:33:38 +0200
commit68d7dd36ce3112a1229702b1cbcbc3095e3ba574 (patch)
tree534650326c9328c0254e24b27a9728198b05d5c9
parentxfce-base/xfce4-settings: Bump to 4.19.2 (diff)
downloadgentoo-68d7dd36ce3112a1229702b1cbcbc3095e3ba574.tar.gz
gentoo-68d7dd36ce3112a1229702b1cbcbc3095e3ba574.tar.bz2
gentoo-68d7dd36ce3112a1229702b1cbcbc3095e3ba574.zip
xfce-base/xfce4-session: Bump to 4.19.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--xfce-base/xfce4-session/Manifest1
-rw-r--r--xfce-base/xfce4-session/xfce4-session-4.19.2.ebuild89
2 files changed, 90 insertions, 0 deletions
diff --git a/xfce-base/xfce4-session/Manifest b/xfce-base/xfce4-session/Manifest
index cb542eb511d0..1eb66e70afbc 100644
--- a/xfce-base/xfce4-session/Manifest
+++ b/xfce-base/xfce4-session/Manifest
@@ -1,2 +1,3 @@
DIST xfce4-session-4.18.3.tar.bz2 875517 BLAKE2B bc729218fb845589655e5cd35c15dab3a3fad931b348098e052212b60c52214727af734641512590f85c88cd36d2db160d8e24d98ad34d47358469c466da9f38 SHA512 65314472049c973af4b7553ec969691dfe701af2addb8cb63aebb49ff1b61ddb9e1418b2969e5eac69fd32096dd3163b7bf28fefe1d8c130c46bd5dd2bfe126c
DIST xfce4-session-4.19.1.tar.bz2 1126975 BLAKE2B 7838582c0d623f83df2610a3224f6c5c116c67f0c42d7fe6245ca9185553fb6db281d5e90ee57ceee9af0ea0997a76d1210f9cb69f764a02ee5f8362f4fce0ae SHA512 3785a834566e1a6be547035a60ce860e885cba7e9f5fdec57007154ef30ab20d88d82a834944a4ee11a27f4f5eca16d5535d9e063a5282cc9f5e156207c5e82b
+DIST xfce4-session-4.19.2.tar.bz2 1201959 BLAKE2B adc76dddec0fa19872054a1dcd64bc920df71360f42c4befa5b33a6fa8369fc1af2ae8cd9192b9f5412ca196fa6b39824971aa775773debb9d8189736e59a4f5 SHA512 35bc1daccb86791882007ea71516746909b6d69b74465a66533399b72529448bc40a64dc0f1f6cd06ddcc5c48413b728c3cd8eadb467afcc493e6d936c564600
diff --git a/xfce-base/xfce4-session/xfce4-session-4.19.2.ebuild b/xfce-base/xfce4-session/xfce4-session-4.19.2.ebuild
new file mode 100644
index 000000000000..0752877f4a6d
--- /dev/null
+++ b/xfce-base/xfce4-session/xfce4-session-4.19.2.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A session manager for the Xfce desktop environment"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/xfce4-session/start
+ https://gitlab.xfce.org/xfce/xfce4-session
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="X nls policykit wayland +xscreensaver"
+REQUIRED_USE="|| ( X wayland )"
+
+DEPEND="
+ >=dev-libs/glib-2.66.0
+ >=x11-libs/gtk+-3.24.0:3[X?,wayland?]
+ >=xfce-base/libxfce4util-4.19.2:=
+ >=xfce-base/libxfce4ui-4.18.4:=
+ >=xfce-base/libxfce4windowing-4.19.2:=
+ >=xfce-base/xfconf-4.12.0:=
+ policykit? ( >=sys-auth/polkit-0.102 )
+ wayland? (
+ >=gui-libs/gtk-layer-shell-0.7.0
+ )
+ X? (
+ >=x11-libs/libICE-1.0.10
+ >=x11-libs/libSM-1.2.3
+ >=x11-libs/libX11-1.6.7
+ >=x11-libs/libwnck-3.10.0:3
+ )
+"
+RDEPEND="
+ ${DEPEND}
+ x11-apps/xrdb
+ nls? ( x11-misc/xdg-user-dirs )
+ X? (
+ x11-apps/iceauth
+ )
+ xscreensaver? (
+ || (
+ xfce-extra/xfce4-screensaver
+ >=x11-misc/xscreensaver-5.26
+ x11-misc/light-locker
+ )
+ )
+"
+BDEPEND="
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable X x11)
+ $(use_enable policykit polkit)
+ $(use_enable wayland)
+ $(use_enable wayland gtk-layer-shell)
+ --with-xsession-prefix="${EPREFIX}"/usr
+ ICEAUTH="${EPREFIX}"/usr/bin/iceauth
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+
+ exeinto /etc/X11/Sessions
+ newexe - Xfce4 <<-EOF
+ startxfce4
+ EOF
+ dosym Xfce4 /etc/X11/Sessions/Xfce
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}