summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-09-19 14:36:50 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-09-19 14:36:50 +0200
commit6a3eb699796bf5ee4d132f612cb781e7c5e72cbc (patch)
treed39ea6f6dbfc430182fc3da2c9e4ffd2cc3ac121
parentmedia-video/smplayer: Removed old. (diff)
downloadgentoo-6a3eb699796bf5ee4d132f612cb781e7c5e72cbc.tar.gz
gentoo-6a3eb699796bf5ee4d132f612cb781e7c5e72cbc.tar.bz2
gentoo-6a3eb699796bf5ee4d132f612cb781e7c5e72cbc.zip
net-libs/libetpan: Bump to version 1.9.1
Package-Manager: Portage-2.3.49, Repoman-2.3.10
-rw-r--r--net-libs/libetpan/Manifest1
-rw-r--r--net-libs/libetpan/libetpan-1.9.1.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/net-libs/libetpan/Manifest b/net-libs/libetpan/Manifest
index e62aa4770b35..de46a350d8f0 100644
--- a/net-libs/libetpan/Manifest
+++ b/net-libs/libetpan/Manifest
@@ -1 +1,2 @@
DIST libetpan-1.8.tar.gz 6188927 BLAKE2B 730d9fc545ea2fbd4dbc0eaf3cdbd0540ec85984dee5448c5f22c83ad12e568a9e066e53734da96ef6a9c77942e5aea2eb241c2228f0ca7577755e67646aa589 SHA512 a5e97998803cc56dbd54356153c8579b52a9675fe95fbf642c3158215428d9d2cb30c4e0060c5f4dd760634fff5b1c2a32ce4bb70a5f2bc6398a071ce95e1efd
+DIST libetpan-1.9.1.tar.gz 6189971 BLAKE2B d6cffd9c333c76451d7ac26e978e09b7f1a0b225ef1f318c80f28fe00047c523f2bba32cef5892e452bc84593ce0d635a4cd075e32575c812ff853d0932b01f9 SHA512 1dd72644672e15eecc9883ffb4b29ef34d4355c55aec950cac44e7b59f252d9355f37ef0ad37007c89728c09e057144b4c3b853496a011d693598b6027356286
diff --git a/net-libs/libetpan/libetpan-1.9.1.ebuild b/net-libs/libetpan/libetpan-1.9.1.ebuild
new file mode 100644
index 000000000000..31edc45696c0
--- /dev/null
+++ b/net-libs/libetpan/libetpan-1.9.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="A portable, efficient middleware for different kinds of mail access"
+HOMEPAGE="http://libetpan.sourceforge.net/"
+SRC_URI="https://github.com/dinhviethoa/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="berkdb gnutls ipv6 liblockfile libressl sasl ssl static-libs"
+
+# BerkDB is only supported up to version 6.0
+DEPEND="sys-libs/zlib
+ berkdb? ( <sys-libs/db-6.1:= )
+ ssl? (
+ gnutls? ( net-libs/gnutls:= )
+ !gnutls? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+ )
+ sasl? ( dev-libs/cyrus-sasl:2 )
+ liblockfile? ( net-libs/liblockfile )"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0-nonnull.patch
+)
+
+pkg_setup() {
+ if use gnutls && ! use ssl ; then
+ ewarn "You have \"gnutls\" USE flag enabled but \"ssl\" USE flag disabled!"
+ ewarn "No ssl support will be available in ${PN}."
+ fi
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # in Prefix emake uses SHELL=${BASH}, export CONFIG_SHELL to the same so
+ # libtool recognises it as valid shell (bug #300211)
+ use prefix && export CONFIG_SHELL=${BASH}
+ local myeconfargs=(
+ # --enable-debug simply injects "-O2 -g" into CFLAGS
+ --disable-debug
+ $(use_enable berkdb db)
+ $(use_enable ipv6)
+ $(use_enable liblockfile lockfile)
+ $(use_enable static-libs static)
+ $(use_with sasl)
+ $(usex ssl "$(use_with gnutls) $(use_with !gnutls openssl)" '--without-gnutls --without-openssl')
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name "*.la" -delete || die
+ if ! use static-libs ; then
+ find "${ED}" -name "*.a" -delete || die
+ fi
+}