summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-26 06:13:13 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-26 06:39:14 +0100
commit6a4398be8b2a309af5025f201e5fc2fd580e8fd7 (patch)
treed197a97db03c068cd3fcb5ad976963046492b922
parentdev-python/python-utils: Bump to 3.8.2 (diff)
downloadgentoo-6a4398be8b2a309af5025f201e5fc2fd580e8fd7.tar.gz
gentoo-6a4398be8b2a309af5025f201e5fc2fd580e8fd7.tar.bz2
gentoo-6a4398be8b2a309af5025f201e5fc2fd580e8fd7.zip
dev-python/seaborn: Bump to 0.13.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/seaborn/Manifest1
-rw-r--r--dev-python/seaborn/seaborn-0.13.2.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/seaborn/Manifest b/dev-python/seaborn/Manifest
index 1c63f5dae79f..d3263edd9842 100644
--- a/dev-python/seaborn/Manifest
+++ b/dev-python/seaborn/Manifest
@@ -1 +1,2 @@
DIST seaborn-0.13.1.tar.gz 1457600 BLAKE2B 73296257f1d7525cebb90bf6f97fa6e5f91e3e9df653e0b9ab81eb6d04a1eb957a9c623aa8b4a715162175a501f55dd7e787335175503cab451bb03318e822cf SHA512 b90483bffd3435cc058143dccc854eb175ec7d7a095b8ce8261fbcad3f97f5e9b035a790a04dc2c64c35dda5b0ab8562f0b4a99e09a5e2fc9c4ee8323a153910
+DIST seaborn-0.13.2.tar.gz 1457696 BLAKE2B 82caa82da487cb880318313e2af270ac409ecde8f0b26f7c7ba39b1763f9f247fa9a4f7c90f989467004e84c41b7eeb9561d1a59e0a23d4d6994ae63e71c1894 SHA512 5a2f11865d0f5b8a9281f0dac1eaf4cd205828293b3e0a2f7f1c24e7d20c989582ecc7e40c32a0fab6736de1f7e126293d9ae5c270e9aa4e93704e86b6b51ef6
diff --git a/dev-python/seaborn/seaborn-0.13.2.ebuild b/dev-python/seaborn/seaborn-0.13.2.ebuild
new file mode 100644
index 000000000000..c377b54e8c4a
--- /dev/null
+++ b/dev-python/seaborn/seaborn-0.13.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Statistical data visualization"
+HOMEPAGE="
+ https://seaborn.pydata.org/
+ https://github.com/mwaskom/seaborn/
+ https://pypi.org/project/seaborn/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/matplotlib-3.4[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.20[${PYTHON_USEDEP}]
+ >=dev-python/pandas-1.2[${PYTHON_USEDEP}]
+ >=dev-python/statsmodels-0.12[${PYTHON_USEDEP}]
+ >=dev-python/scipy-1.7[${PYTHON_USEDEP}]
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_test() {
+ cat > matplotlibrc <<- EOF || die
+ backend : Agg
+ EOF
+
+ distutils-r1_src_test
+}