summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2023-11-05 18:36:38 +0100
committerUlrich Müller <ulm@gentoo.org>2023-11-05 18:36:38 +0100
commit6b5860ab4bbf1867c0e2592faf197469cb39f46e (patch)
treee6dd7d44ff3ff53ba955f334c5c103f114957055
parentdev-python/python-discid: Enable py3.12 (diff)
downloadgentoo-6b5860ab4bbf1867c0e2592faf197469cb39f46e.tar.gz
gentoo-6b5860ab4bbf1867c0e2592faf197469cb39f46e.tar.bz2
gentoo-6b5860ab4bbf1867c0e2592faf197469cb39f46e.zip
app-emacs/ebuild-mode: add 1.69
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
-rw-r--r--app-emacs/ebuild-mode/Manifest1
-rw-r--r--app-emacs/ebuild-mode/ebuild-mode-1.69.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/app-emacs/ebuild-mode/Manifest b/app-emacs/ebuild-mode/Manifest
index 696704fa4d14..ba533e36fc78 100644
--- a/app-emacs/ebuild-mode/Manifest
+++ b/app-emacs/ebuild-mode/Manifest
@@ -1,2 +1,3 @@
DIST ebuild-mode-1.67.tar.xz 40332 BLAKE2B 545106fbf63737015c8b80b715708c430dafc83484bd2d27901c1e81b5ecb10a0494a0f8ab9e0d3243f62c57045c1571ea75fd6813cbd74a04e507a2dadc3b3a SHA512 672c23ae77de6784a43329607b05f3ff354f0271a5051b886ede7b1d92a667f7968579a941b55e60839cbf0b79082e726aa32e1a81d3302acc84d866e3892a2b
DIST ebuild-mode-1.68.tar.xz 41060 BLAKE2B 2f4882778368b9d9e40579a661b294fef6c68a27072a7d983caa7d54338441a659c27edbeacf74b3aac870b056996c3bdca233352e7fd2a319c3c2649a49eb56 SHA512 b03d0adabd9804999317ac688763d28e2ef09539c5ac75faeeb758ac56e9015946440447a0301c98356897e1b6f19e3e2aec5aec647c0ee1ae868beda2347ddd
+DIST ebuild-mode-1.69.tar.xz 41436 BLAKE2B 9c3a41e6dac89d1c3908f72dfd4f2c2f62a1337fa9de1318d26901ae51c5b17cec429839378fa8df155f65807bc16efb9235b1913d4a3704d0d79df9fddd7af6 SHA512 2ba94f268f74a8424fccfc7ffff3d0e008261224a389253f67be91b6ade0301600fd50c0bb4b5f0487acb5b0add68dd6895a03dd7b096095034d59bc300e8a53
diff --git a/app-emacs/ebuild-mode/ebuild-mode-1.69.ebuild b/app-emacs/ebuild-mode/ebuild-mode-1.69.ebuild
new file mode 100644
index 000000000000..7c4ed2c5c19a
--- /dev/null
+++ b/app-emacs/ebuild-mode/ebuild-mode-1.69.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp optfeature
+
+DESCRIPTION="Emacs modes for editing ebuilds and other Gentoo specific files"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Emacs"
+SRC_URI="https://dev.gentoo.org/~ulm/emacs/${P}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+BDEPEND="sys-apps/texinfo"
+
+DOCS="ChangeLog keyword-generation.sh"
+ELISP_TEXINFO="${PN}.texi"
+SITEFILE="50${PN}-gentoo-1.54.el"
+
+pkg_postinst() {
+ elisp_pkg_postinst
+ optfeature "ebuild commands support" sys-apps/portage
+ optfeature "additional development tools" dev-util/pkgdev
+ optfeature "ebuild QA utilities" dev-util/pkgcheck
+ optfeature "generating HTML from GLEPs" dev-python/docutils-glep
+}