summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-08-13 23:01:20 +1200
committerKent Fredric <kentnl@gentoo.org>2020-08-13 23:04:48 +1200
commit6c0f24321312b21edd6522a242c3303459549330 (patch)
tree9cbfc669986c24175461a187a6ebd9473184eb92
parentmedia-libs/zita-alsa-pcmi: fixed flags (diff)
downloadgentoo-6c0f24321312b21edd6522a242c3303459549330.tar.gz
gentoo-6c0f24321312b21edd6522a242c3303459549330.tar.bz2
gentoo-6c0f24321312b21edd6522a242c3303459549330.zip
dev-perl/Encode-HanConvert: -r bump for EAPI7 + Fixes
- EAPI7 - Convert sed hack to "patch" - Improve dependencies - Ensure CFLAGS passed to make/compiler - Omit "Perl.pm-orig" from install image, as it is an input file for the build process, not an end-user relevant file. Package-Manager: Portage-2.3.103, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
-rw-r--r--dev-perl/Encode-HanConvert/Encode-HanConvert-0.350.0-r2.ebuild33
-rw-r--r--dev-perl/Encode-HanConvert/files/Encode-HanConvert-0.35-no-dot-inc.patch21
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-perl/Encode-HanConvert/Encode-HanConvert-0.350.0-r2.ebuild b/dev-perl/Encode-HanConvert/Encode-HanConvert-0.350.0-r2.ebuild
new file mode 100644
index 000000000000..6f8b7c8f9480
--- /dev/null
+++ b/dev-perl/Encode-HanConvert/Encode-HanConvert-0.350.0-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=AUDREYT
+DIST_VERSION=0.35
+inherit perl-module
+
+DESCRIPTION="Traditional and Simplified Chinese mappings"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=virtual/perl-Encode-1.410.0
+"
+BDEPEND="${RDEPEND}"
+PATCHES=(
+ "${FILESDIR}/${PN}-0.35-no-dot-inc.patch"
+)
+
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+ # this file is converted to Perl.pm during src_configure
+ # and not needed after that, but has to be removed after compile
+ # to avoid confusing pm_to_blib, but has to be done before src_test
+ # as tests run against the result of this.
+ rm -vf "blib/lib/Encode/HanConvert/Perl.pm-orig" || die "Can't remove Perl.pm-orig"
+}
diff --git a/dev-perl/Encode-HanConvert/files/Encode-HanConvert-0.35-no-dot-inc.patch b/dev-perl/Encode-HanConvert/files/Encode-HanConvert-0.35-no-dot-inc.patch
new file mode 100644
index 000000000000..add43d2818c1
--- /dev/null
+++ b/dev-perl/Encode-HanConvert/files/Encode-HanConvert-0.35-no-dot-inc.patch
@@ -0,0 +1,21 @@
+From 6316820623f3cc05c3fd28f34e819068685140f8 Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Thu, 13 Aug 2020 22:41:26 +1200
+Subject: Include '.' in @INC for perl 5.26+
+
+---
+ Makefile.PL | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Makefile.PL b/Makefile.PL
+index d46d7ae..9de9937 100755
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -1,3 +1,4 @@
++use lib q[.];
+ use inc::Module::Install;
+ use Config;
+
+--
+2.28.0
+