summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-03-23 09:38:18 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-03-23 09:39:17 +0100
commit6c1679c37a015b3aff52c786d2cff6adb3e82e92 (patch)
treebe7b1c32062e60edde4959eba1f282935b1f2ebc
parentdev-java/jdbc-mysql: disable tests, bug #902791 (diff)
downloadgentoo-6c1679c37a015b3aff52c786d2cff6adb3e82e92.tar.gz
gentoo-6c1679c37a015b3aff52c786d2cff6adb3e82e92.tar.bz2
gentoo-6c1679c37a015b3aff52c786d2cff6adb3e82e92.zip
kde-plasma/plasma-workspace: Fix cmake
Closes: https://bugs.gentoo.org/902797 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-plasma/plasma-workspace/files/plasma-workspace-5.27.3-cmake.patch37
-rw-r--r--kde-plasma/plasma-workspace/plasma-workspace-5.27.3-r1.ebuild1
2 files changed, 38 insertions, 0 deletions
diff --git a/kde-plasma/plasma-workspace/files/plasma-workspace-5.27.3-cmake.patch b/kde-plasma/plasma-workspace/files/plasma-workspace-5.27.3-cmake.patch
new file mode 100644
index 000000000000..e151a214dc4e
--- /dev/null
+++ b/kde-plasma/plasma-workspace/files/plasma-workspace-5.27.3-cmake.patch
@@ -0,0 +1,37 @@
+From 3f81a6559cd48d8735a7b0e7ca7cedac92db8cc8 Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Thu, 23 Mar 2023 09:32:09 +0100
+Subject: [PATCH] Find PkgConfig before first call to pkg_check_modules
+
+Follow-up to a0d707014150786ba2e508c144b2bc6b8ad8f316
+
+For some reason this would fail only when disabling Fontconfig.
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 556e017d8..c05e7275e 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -76,6 +76,7 @@ set_package_properties(KF5Baloo PROPERTIES DESCRIPTION "File Searching"
+ PURPOSE "Needed for the File Search runner."
+ )
+
++find_package(PkgConfig REQUIRED)
+ pkg_check_modules(QALCULATE libqalculate>2.0 REQUIRED IMPORTED_TARGET)
+
+ find_package(KWinDBusInterface CONFIG REQUIRED)
+@@ -151,7 +152,6 @@ else()
+ set(HAVE_XFIXES 0)
+ endif()
+
+-find_package(PkgConfig REQUIRED)
+ pkg_check_modules(PipeWire IMPORTED_TARGET libpipewire-0.3)
+ add_feature_info(PipeWire PipeWire_FOUND "Required for Wayland screencasting")
+
+--
+2.40.0
+
diff --git a/kde-plasma/plasma-workspace/plasma-workspace-5.27.3-r1.ebuild b/kde-plasma/plasma-workspace/plasma-workspace-5.27.3-r1.ebuild
index b62e1cf969f0..f228665007ac 100644
--- a/kde-plasma/plasma-workspace/plasma-workspace-5.27.3-r1.ebuild
+++ b/kde-plasma/plasma-workspace/plasma-workspace-5.27.3-r1.ebuild
@@ -164,6 +164,7 @@ PATCHES=(
"${FILESDIR}/${PN}-5.22.5-krunner-cwd-at-home.patch" # TODO upstream: KDE-bug 432975, bug 767478
"${FILESDIR}/${P}-dashboard-skip-task-switcher.patch" # KDE-bug 465303
"${FILESDIR}/${P}-nightcolor-fix-timing-strings.patch"
+ "${FILESDIR}/${P}-cmake.patch" # bug 902797
)
src_prepare() {