summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-09-19 01:53:25 -0400
committerTim Harder <radhermit@gentoo.org>2018-09-20 01:30:51 -0400
commit6d36b35f2ccdc21b5575751bbc47972fa4db0937 (patch)
tree4fbfb7500072ed75cd819c2b1b59182bb78d657e
parentmedia-sound/ncmpc: Set -Dcolors=true (diff)
downloadgentoo-6d36b35f2ccdc21b5575751bbc47972fa4db0937.tar.gz
gentoo-6d36b35f2ccdc21b5575751bbc47972fa4db0937.tar.bz2
gentoo-6d36b35f2ccdc21b5575751bbc47972fa4db0937.zip
app-vim/fugitive: version bump to 2.4
-rw-r--r--app-vim/fugitive/Manifest1
-rw-r--r--app-vim/fugitive/fugitive-2.4.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/app-vim/fugitive/Manifest b/app-vim/fugitive/Manifest
index d439d3ff431a..28a842482bb8 100644
--- a/app-vim/fugitive/Manifest
+++ b/app-vim/fugitive/Manifest
@@ -1,2 +1,3 @@
DIST fugitive-2.2.tar.gz 30651 BLAKE2B 7e6ecf372661afcfa586097e979c996f19df85bf41d3b2409e26fe9131a48c02946614a15231accecbe8906a458698f89b66cc86f3707f2f7014e00d795786fe SHA512 763fc352e495dae6346fdedee5e3993a11fe402dbad0e9ee4b002b6b416404c46b56a061b3d9e663174b371d2d62e62e22f5a2cf8767fb6aee28b236c77d9d41
DIST fugitive-2.3.tar.gz 30949 BLAKE2B ff62ad9f5b85fff6a06fe006884901ca0f80a5ee139032955a6af596cadf3dca18d73980da12429706102cbe8105fcbff5fb1dd6375b851f978746a5251f1d22 SHA512 8a176705c0326ac034abaf23423e58d490feb7f11dc45ad23641fafb95279094ed38475a90e7c2e7fc95c615558db75f3587740e2658f3988fa07a1957aa1039
+DIST fugitive-2.4.tar.gz 33340 BLAKE2B d5e5df47e0492510abae735dd47b51d797fe38862401f7d8e64404f6fa4e040641141c6febb13b05910cc44dc0372b084fe0ee8c3980a73d11d65e1a502ed627 SHA512 fb9d4129090bbafcace9400e9f21feae06bc9f903a54cfef7c4cbfa62856019a511b924c294e86fd26cd713d588ca0054a17d9676b59e2f406779ab5d51c3363
diff --git a/app-vim/fugitive/fugitive-2.4.ebuild b/app-vim/fugitive/fugitive-2.4.ebuild
new file mode 100644
index 000000000000..3ec007ea68be
--- /dev/null
+++ b/app-vim/fugitive/fugitive-2.4.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit vim-plugin
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/tpope/vim-fugitive.git"
+else
+ inherit vcs-snapshot
+ SRC_URI="https://github.com/tpope/vim-fugitive/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~ppc-macos ~x64-macos"
+fi
+
+DESCRIPTION="vim plugin: a git wrapper for vim"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=2975 https://github.com/tpope/vim-fugitive/"
+LICENSE="vim"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="dev-vcs/git"