summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2015-10-14 23:14:08 +0200
committerLars Wendler <polynomial-c@gentoo.org>2015-10-14 23:27:38 +0200
commit6f1ba19dd674e07ba66074a31ef28ef06d685dd3 (patch)
tree3b3dec711103be85a7ce9cefb64b9bd597cabffd
parentsys-cluster/ceph: Revision bump, use python-single-r1 rather than python-any-r1 (diff)
downloadgentoo-6f1ba19dd674e07ba66074a31ef28ef06d685dd3.tar.gz
gentoo-6f1ba19dd674e07ba66074a31ef28ef06d685dd3.tar.bz2
gentoo-6f1ba19dd674e07ba66074a31ef28ef06d685dd3.zip
app-editors/ted: Fixed compilation with freetype-2.6.1 (bug #562536).
Also fixed some QA warnings due to missing slot dependencies. Package-Manager: portage-2.2.23 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
-rw-r--r--app-editors/ted/files/ted-2.23-freetype261.patch11
-rw-r--r--app-editors/ted/ted-2.23.ebuild11
2 files changed, 17 insertions, 5 deletions
diff --git a/app-editors/ted/files/ted-2.23-freetype261.patch b/app-editors/ted/files/ted-2.23-freetype261.patch
new file mode 100644
index 000000000000..7e185b367194
--- /dev/null
+++ b/app-editors/ted/files/ted-2.23-freetype261.patch
@@ -0,0 +1,11 @@
+--- Ted-2.23/appFrame/appFontConfig.c
++++ Ted-2.23/appFrame/appFontConfig.c
+@@ -889,7 +889,7 @@
+
+ static const n2s xftn2s[]=
+ {
+-# include <freetype/fterrdef.h>
++# include FT_ERROR_DEFINITIONS_H
+ };
+
+ for ( i= 0; i < sizeof(xftn2s)/sizeof(n2s); i++ )
diff --git a/app-editors/ted/ted-2.23.ebuild b/app-editors/ted/ted-2.23.ebuild
index 5e52affa3b1a..549fad7a3219 100644
--- a/app-editors/ted/ted-2.23.ebuild
+++ b/app-editors/ted/ted-2.23.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -14,9 +14,9 @@ SLOT="0"
KEYWORDS="amd64 ppc sparc x86"
RDEPEND="x11-libs/gtk+:2
- media-libs/tiff
- virtual/jpeg
- media-libs/libpng
+ media-libs/tiff:=
+ virtual/jpeg:=
+ media-libs/libpng:=
x11-libs/libXft
x11-libs/libXpm"
DEPEND="${RDEPEND}
@@ -25,7 +25,8 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/Ted-${PV}"
src_prepare() {
- epatch "${FILESDIR}"/${P}-make.patch
+ epatch "${FILESDIR}"/${P}-make.patch \
+ "${FILESDIR}"/${P}-freetype261.patch
sed -i -e 's|/Ted/|/share/Ted/|' \
"${S}"/appFrame/appFrameConfig.h.in \