summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2016-11-05 22:56:39 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2016-11-05 23:23:01 +0000
commit708aa6e91457521acc529642241821f37379c6f7 (patch)
tree456be37396713443c2f17d1f175ea195b8f45a20
parentdev-haskell/authenticate: bump up to 1.3.3.2 (diff)
downloadgentoo-708aa6e91457521acc529642241821f37379c6f7.tar.gz
gentoo-708aa6e91457521acc529642241821f37379c6f7.tar.bz2
gentoo-708aa6e91457521acc529642241821f37379c6f7.zip
dev-haskell/bits-atomic: tweak for ghc-8
Package-Manager: portage-2.3.2
-rw-r--r--dev-haskell/bits-atomic/bits-atomic-0.1.3-r1.ebuild3
-rw-r--r--dev-haskell/bits-atomic/files/bits-atomic-0.1.3-ghc-8.patch9
2 files changed, 11 insertions, 1 deletions
diff --git a/dev-haskell/bits-atomic/bits-atomic-0.1.3-r1.ebuild b/dev-haskell/bits-atomic/bits-atomic-0.1.3-r1.ebuild
index ccf731538e55..fc2e0d27967e 100644
--- a/dev-haskell/bits-atomic/bits-atomic-0.1.3-r1.ebuild
+++ b/dev-haskell/bits-atomic/bits-atomic-0.1.3-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -31,4 +31,5 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}"/${P}-gcc-5.patch
+ epatch "${FILESDIR}"/${P}-ghc-8.patch
}
diff --git a/dev-haskell/bits-atomic/files/bits-atomic-0.1.3-ghc-8.patch b/dev-haskell/bits-atomic/files/bits-atomic-0.1.3-ghc-8.patch
new file mode 100644
index 000000000000..eb12edc2d4f3
--- /dev/null
+++ b/dev-haskell/bits-atomic/files/bits-atomic-0.1.3-ghc-8.patch
@@ -0,0 +1,9 @@
+diff --git a/test/test.hs b/test/test.hs
+index 38238b5..c3a99b0 100644
+--- a/test/test.hs
++++ b/test/test.hs
+@@ -35,3 +35,3 @@ testPattern = 0xdeadbeef
+
+-type PolyTest = (AtomicBits a, Storable a, Integral a, Bounded a, Show a) => a -> Assertion
++type PolyTest = forall a . (AtomicBits a, Storable a, Integral a, Bounded a, Show a) => a -> Assertion
+