summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-06-13 19:05:27 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-06-13 19:06:21 +0200
commit715403d3fd7b8c14862defcf970d13f80fd18da2 (patch)
treef79aca52696f66f64f7d3595fd6d17c12a0aadb6
parentsys-apps/kmscon: start installing fblog kernel patchset (diff)
downloadgentoo-715403d3fd7b8c14862defcf970d13f80fd18da2.tar.gz
gentoo-715403d3fd7b8c14862defcf970d13f80fd18da2.tar.bz2
gentoo-715403d3fd7b8c14862defcf970d13f80fd18da2.zip
dev-python/js2py: bump to 0.71_p20210918
2021.09.18 snapshot Bug: https://github.com/gentoo/gentoo/pull/21375/ Closes: https://bugs.gentoo.org/797520 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
-rw-r--r--dev-python/js2py/Manifest1
-rw-r--r--dev-python/js2py/js2py-0.71_p20210918.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/js2py/Manifest b/dev-python/js2py/Manifest
index 098197b5e6e9..3aada029b162 100644
--- a/dev-python/js2py/Manifest
+++ b/dev-python/js2py/Manifest
@@ -1 +1,2 @@
DIST Js2Py-0.71.tar.gz 1969618 BLAKE2B 293a830f4188e66927b23900e8c376bf1a4bfdfa8726e33aa5aa75dcdf735cde89ce463741c142fc7e487ae89c7c11421e459d2fdd09ba88edfe953e4e087e42 SHA512 75bae61619d4766117f3c163d36427f3019825ecb08b745aee7c3b6f2d33a4ea8507ca180b63c0a8e575a5f9491eb64d6963acbb912edc7b934a676b38814597
+DIST Js2Py-0.71_p20210918.tar.gz 1970784 BLAKE2B 4ea446b306e858c2acb192a699b4c098cca1a334fd97246d3149186795a013fa1ff9cf45ecc5cd9bed241b13b3eb003ebf272f5af4ed24a608564fd4709e4ff1 SHA512 810363e4b0716e324e6deb5f373968c9c57e7ecf120710c064601ad46ca2f24bc8da52f779f861296dd506de06d664be86b3c0d72bcb811892fe4e6c22ad7a6d
diff --git a/dev-python/js2py/js2py-0.71_p20210918.ebuild b/dev-python/js2py/js2py-0.71_p20210918.ebuild
new file mode 100644
index 000000000000..7f94a9dd666c
--- /dev/null
+++ b/dev-python/js2py/js2py-0.71_p20210918.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+H=b16d7ce90ac9c03358010c1599c3e87698c9993f
+MY_PN=Js2Py
+MY_P=${MY_PN}-${PV}
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="JavaScript to Python Translator & JavaScript interpreter in Python"
+HOMEPAGE=" http://piter.io/projects/js2py/
+ https://github.com/PiotrDabkowski/Js2Py/
+ https://pypi.org/project/Js2Py/"
+SRC_URI="https://github.com/PiotrDabkowski/${MY_PN}/archive/${H}.tar.gz
+ -> ${MY_P}.tar.gz"
+S="${WORKDIR}"/${MY_PN}-${H}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/pyjsparser-2.5.1[${PYTHON_USEDEP}]
+ >=dev-python/tzlocal-1.2.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ pushd ./tests >/dev/null || die
+
+ # Tests require "node_failed.txt" file where the logs are kept
+ if [[ -f ./node_failed.txt ]] ; then
+ rm ./node_failed.txt || die
+ fi
+
+ touch ./node_failed.txt || die
+ "${EPYTHON}" ./run.py || die "tests failed with ${EPYTHON}"
+
+ popd >/dev/null || die
+}