summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-18 11:14:03 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-18 11:16:52 +0200
commit717c7a4eb42c23cc28f1e6b954c76baf40b36e0c (patch)
treebbffd259c35793b0fd2a967ab2dfaae50b3644f3
parentdev-python/python-systemd: Bump to 234, py3.7, EAPI 7 (diff)
downloadgentoo-717c7a4eb42c23cc28f1e6b954c76baf40b36e0c.tar.gz
gentoo-717c7a4eb42c23cc28f1e6b954c76baf40b36e0c.tar.bz2
gentoo-717c7a4eb42c23cc28f1e6b954c76baf40b36e0c.zip
distutils-r1.eclass: Block installing '.pytest_cache'
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--eclass/distutils-r1.eclass2
1 files changed, 1 insertions, 1 deletions
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index 66920d1f7553..7c56a0c8a136 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -590,7 +590,7 @@ distutils-r1_python_install() {
esetup.py install --root="${root}" "${args[@]}"
- local forbidden_package_names=( examples test tests )
+ local forbidden_package_names=( examples test tests .pytest_cache )
local p
for p in "${forbidden_package_names[@]}"; do
if [[ -d ${root}$(python_get_sitedir)/${p} ]]; then