summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-02-02 00:15:43 +0000
committerSam James <sam@gentoo.org>2024-02-02 01:01:19 +0000
commit71ad3e6b9800a368a752f28ce58265834fb434bb (patch)
tree0fb36e9f2d29239eb904f04440b09691298859c8
parentwww-apps/gitea: add 1.21.5 (diff)
downloadgentoo-71ad3e6b9800a368a752f28ce58265834fb434bb.tar.gz
gentoo-71ad3e6b9800a368a752f28ce58265834fb434bb.tar.bz2
gentoo-71ad3e6b9800a368a752f28ce58265834fb434bb.zip
app-shells/fzf: add 0.46.1
Closes: https://bugs.gentoo.org/922932 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-shells/fzf/Manifest2
-rw-r--r--app-shells/fzf/fzf-0.46.1.ebuild72
2 files changed, 74 insertions, 0 deletions
diff --git a/app-shells/fzf/Manifest b/app-shells/fzf/Manifest
index ae97bc2f078a..2e3b02df2982 100644
--- a/app-shells/fzf/Manifest
+++ b/app-shells/fzf/Manifest
@@ -2,3 +2,5 @@ DIST fzf-0.44.0-deps.tar.xz 16844060 BLAKE2B 33f85423868719cf86664a0fd7691c42c6e
DIST fzf-0.44.0.tar.gz 250927 BLAKE2B 3689d8843a4b008abc7b77e7b0fe7b681891c5f397ac7460c26ea303e04e7bb7dcb03af4012cfea12dd8c771c012a656e8bc65684941d66ebbb6533796d09ec2 SHA512 62084284a2329250e87f107900ffaddf94043274b1d9ede1dacdeed2e8ef87722c80708addd7907c35035e742645f5168776e5f0295d5695e9512acdbb43936c
DIST fzf-0.45.0-deps.tar.xz 21803876 BLAKE2B 3a32d3da26a469f51c319627971b4f9efa193671fe039d617fa19cb73ff4589dfa015220d6e684af8bba9ff89eac466b825e58ccf1c8b9e3a481808aaa045bd6 SHA512 e79651d570050a6e7f398860a944010378be1f7bbdb0286ea2ab3c3f9656c6d6cc1a372099a42262d1a45e1fbd0192e6b9708ff645058dc573f6d46b9c333145
DIST fzf-0.45.0.tar.gz 255930 BLAKE2B 57fdc7920eb371b68ed46fce4c786c84effb8f7937340daf12c511d55ebfef5280db22330e4ee9b8cd6571ca6a6b805b35e00870cc34db30ed9c3a35ce2b6a97 SHA512 f0671cf9764ed6f7375de41865635cfac47831eed1e22dc43cec346f26aee7b6c17510a6c96b8913b5f9595de9c1511f835a43bf00dd2ac38e6dded6e8fb7998
+DIST fzf-0.46.1-deps.tar.xz 17564988 BLAKE2B d8da7d769149a3be7f44b9ca28063c113f969fdcf8a52d6c14b1ec46cd224f06cc2147e05f46e9be2af8b34c915fb4eebd31525e8a06a2d5e112ff3d52d1bd68 SHA512 14fe0947e62d1f63365df2c40dcea5353b9c8d7552ca03fd3ca5d11479a6978ab11b8a1e6dad4ffb93db9966e8e48e3465c7283098bea6f0fc7d00a3dddc653e
+DIST fzf-0.46.1.tar.gz 258918 BLAKE2B 2beb5c5048ead73cc57c96aab26b9d331299473e0253bab4bc8cf0aea0be547266a0b1bca36aec9968de740e72d41d905eb0256f4690d9a3d55ec1acff5f6bbd SHA512 c2e07be08bc2d93981acfd9857f395e0c803046754d8d61e888fa4dc4d0f6f3d62eb19b518273cce23ae2eeffe68f2ecc692cb09cdcdfc30df9443419e3fc4cb
diff --git a/app-shells/fzf/fzf-0.46.1.ebuild b/app-shells/fzf/fzf-0.46.1.ebuild
new file mode 100644
index 000000000000..f3bf2fea422f
--- /dev/null
+++ b/app-shells/fzf/fzf-0.46.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 go-module
+
+DESCRIPTION="General-purpose command-line fuzzy finder, written in Golang"
+HOMEPAGE="https://github.com/junegunn/fzf"
+
+# For fancy versioning only. Bump on the next release!
+# MY_GIT_REV is the first 7 characters of release commit, we truncate it
+# after to make it easier to copy/paste.
+MY_GIT_REV=3c0a6304756e890e0a605b742943a9bb8e1d2247
+MY_GIT_REV=${MY_GIT_REV:0:7}
+
+SRC_URI="https://github.com/junegunn/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+SRC_URI+=" https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="MIT BSD-with-disclosure"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+src_prepare() {
+ default
+ sed -i 's/-s -w //' Makefile || die # bug #795225
+}
+
+src_compile() {
+ emake PREFIX="${EPREFIX}"/usr VERSION=${PV} REVISION=${MY_GIT_REV} bin/${PN}
+}
+
+src_install() {
+ dobin bin/${PN}
+ doman man/man1/${PN}.1
+
+ dobin bin/${PN}-tmux
+ doman man/man1/${PN}-tmux.1
+
+ insinto /usr/share/vim/vimfiles/plugin
+ doins plugin/${PN}.vim
+
+ insinto /usr/share/nvim/runtime/plugin
+ doins plugin/${PN}.vim
+
+ newbashcomp shell/completion.bash ${PN}
+
+ insinto /usr/share/zsh/site-functions
+ newins shell/completion.zsh _${PN}
+
+ insinto /usr/share/fzf
+ doins shell/key-bindings.bash
+ doins shell/key-bindings.fish
+ doins shell/key-bindings.zsh
+}
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ elog "To add fzf support to your shell, make sure to use the right file"
+ elog "from ${EROOT}/usr/share/fzf."
+ elog
+ elog "For bash, add the following line to ~/.bashrc:"
+ elog
+ elog " # source ${EROOT}/usr/share/bash-completion/completions/fzf"
+ elog " # source ${EROOT}/usr/share/fzf/key-bindings.bash"
+ elog
+ elog "Plugins for Vim and Neovim are installed to respective directories"
+ elog "and will work out of the box."
+ elog
+ elog "For fzf support in tmux see fzf-tmux(1)."
+ fi
+}