summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-11-05 20:15:04 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-11-05 20:15:04 +0100
commit73b61c5bde6bba1c0646c70d71e4de57fe03c367 (patch)
tree9b5ae687569cb2905af5e7439f37d4d82c3e54a8
parentdev-lua/lua-utf8: drop 0.1.3-r1 (diff)
downloadgentoo-73b61c5bde6bba1c0646c70d71e4de57fe03c367.tar.gz
gentoo-73b61c5bde6bba1c0646c70d71e4de57fe03c367.tar.bz2
gentoo-73b61c5bde6bba1c0646c70d71e4de57fe03c367.zip
dev-lua/luaexpat: drop 1.5.0
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--dev-lua/luaexpat/Manifest1
-rw-r--r--dev-lua/luaexpat/luaexpat-1.5.0.ebuild73
2 files changed, 0 insertions, 74 deletions
diff --git a/dev-lua/luaexpat/Manifest b/dev-lua/luaexpat/Manifest
index d6467b0d62f9..77295d9bb3bb 100644
--- a/dev-lua/luaexpat/Manifest
+++ b/dev-lua/luaexpat/Manifest
@@ -1,2 +1 @@
-DIST luaexpat-1.5.0.tar.gz 53520 BLAKE2B 1793f842771e730022abf512731eece538b6edefd10786295842f467af3cbfbdc94e65ea035b1ce9bc849a1ee4f0ca445bd0b66816a6d18bb786d19ced6b3586 SHA512 0ac151148101d62f1358f5f310be57de5379891ceda76f0eb821a8b56d0d9c781feaf1db601d982339cd4837f9504b1f9b8b14ebf3a7245925473f6824bbc8b3
DIST luaexpat-1.5.1.tar.gz 53912 BLAKE2B 0e8aa342864159e7a3f3ac21bfd65a7fb4378fc51b5889a93f8c00fd497f985bf194b3889d39f28ca097fd84a6160c9804d5957744a7ac9a002d1a0b6969abf3 SHA512 45834b02d863a65c6de2ad3c5c671935ae512dd906233a647269438aeeb37c7bbd6e7166aefd8da72480b33e1aa79a86ed070ed8800a8e0f303ccc74918f3bb8
diff --git a/dev-lua/luaexpat/luaexpat-1.5.0.ebuild b/dev-lua/luaexpat/luaexpat-1.5.0.ebuild
deleted file mode 100644
index 653582b9bb6d..000000000000
--- a/dev-lua/luaexpat/luaexpat-1.5.0.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-LUA_COMPAT=( lua5-{1..4} luajit )
-
-inherit lua toolchain-funcs
-
-DESCRIPTION="A SAX XML parser based on the Expat library"
-HOMEPAGE="https://github.com/lunarmodules/luaexpat"
-SRC_URI="https://github.com/lunarmodules/${PN}/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 sparc x86"
-REQUIRED_USE="${LUA_REQUIRED_USE}"
-
-RDEPEND="
- dev-libs/expat
- ${LUA_DEPS}
-"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-HTML_DOCS=( "docs/." )
-
-src_prepare() {
- default
-
- # Respect users CFLAGS
- sed -e 's/-O2//g' -i Makefile || die
-
- lua_copy_sources
-}
-
-lua_src_compile() {
- pushd "${BUILD_DIR}" || die
-
- local myemakeargs=(
- "CC=$(tc-getCC)"
- "LUA_INC=$(lua_get_CFLAGS)"
- )
-
- emake "${myemakeargs[@]}"
-
- popd
-}
-
-src_compile() {
- lua_foreach_impl lua_src_compile
-}
-
-lua_src_install() {
- pushd "${BUILD_DIR}" || die
-
- local myemakeargs=(
- "DESTDIR=${ED}"
- "LUA_CDIR=$(lua_get_cmod_dir)"
- "LUA_INC=$(lua_get_include_dir)"
- "LUA_LDIR=$(lua_get_lmod_dir)"
- )
-
- emake "${myemakeargs[@]}" install
-
- popd
-}
-
-src_install() {
- lua_foreach_impl lua_src_install
-
- einstalldocs
-}