summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-03-06 11:31:50 +0100
committerHans de Graaff <graaff@gentoo.org>2024-03-06 11:53:56 +0100
commit73ca93601642f872f9d8fcbf04b919cd99470f34 (patch)
tree415b004c703a860abbd33e47db53c6f3762f3e25
parentdev-python/jupyter: Keyword 1.0.0-r4 riscv, #907329 (diff)
downloadgentoo-73ca93601642f872f9d8fcbf04b919cd99470f34.tar.gz
gentoo-73ca93601642f872f9d8fcbf04b919cd99470f34.tar.bz2
gentoo-73ca93601642f872f9d8fcbf04b919cd99470f34.zip
net-p2p/gtk-gnutella: drop 1.2.1-r1, 1.2.2
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--net-p2p/gtk-gnutella/Manifest1
-rw-r--r--net-p2p/gtk-gnutella/gtk-gnutella-1.2.1-r1.ebuild91
-rw-r--r--net-p2p/gtk-gnutella/gtk-gnutella-1.2.2.ebuild89
3 files changed, 0 insertions, 181 deletions
diff --git a/net-p2p/gtk-gnutella/Manifest b/net-p2p/gtk-gnutella/Manifest
index 0318b7769f7a..fac566b08c66 100644
--- a/net-p2p/gtk-gnutella/Manifest
+++ b/net-p2p/gtk-gnutella/Manifest
@@ -1,2 +1 @@
-DIST gtk-gnutella-1.2.1.tar.gz 25055800 BLAKE2B 09f68979bc4df130e2b7b4a78017c2834feab1173d6242fe07856be038b9c671609fee7a7ec270fd6f9592a2fb2bfa0bf8a08472da0f41f6e3dc2dfaafd5ed58 SHA512 e53c8e0f7d11f699e9eb77546f3d6ca240ee9fa92e8817af4631250d86714b97eb36fbcd83e46d8429cbd12532c9c9a343a2ba69eba6deda4bc9c5610e98efc8
DIST gtk-gnutella-1.2.2.tar.gz 26708793 BLAKE2B 9b8c1600914f5679c017929afa6d1f508734b21d95231c15588c64d9b1e9185ddb82ee26478d5d5d34c715fd475ccfe1e65b4b96ed4acc271444d21317013630 SHA512 d4825bb765d9b73b24d1dc7238a31c5e78c9adb7c765b0b913d4fce1467fb3655ac3214381748bca20fd3e02345ba0583d591e2177299d5130951808cd7bd325
diff --git a/net-p2p/gtk-gnutella/gtk-gnutella-1.2.1-r1.ebuild b/net-p2p/gtk-gnutella/gtk-gnutella-1.2.1-r1.ebuild
deleted file mode 100644
index 29b70da8bd1a..000000000000
--- a/net-p2p/gtk-gnutella/gtk-gnutella-1.2.1-r1.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic strip-linguas toolchain-funcs
-
-IUSE="nls dbus ssl +gtk"
-
-DESCRIPTION="A GTK+ Gnutella client"
-SRC_URI="https://github.com/gtk-gnutella/gtk-gnutella/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-HOMEPAGE="http://gtk-gnutella.sourceforge.net/"
-
-SLOT="0"
-LICENSE="CC-BY-SA-4.0 GPL-2"
-KEYWORDS="amd64 ppc ppc64 x86"
-
-RDEPEND="
- sys-libs/binutils-libs:=
- dev-libs/glib:2
- sys-libs/zlib
- gtk? ( >=x11-libs/gtk+-2.2.1:2 )
- dbus? ( >=sys-apps/dbus-0.35.2 )
- ssl? ( >=net-libs/gnutls-2.2.5 )
- nls? ( >=sys-devel/gettext-0.11.5 )"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-PATCHES=( "${FILESDIR}/${P}-glibc234.patch" )
-
-src_prepare() {
- filter-lto
- strip-linguas -i po
-
- echo "# Gentoo-selected LINGUAS" > po/LINGUAS
- for ling in ${LINGUAS}; do
- echo $ling >> po/LINGUAS
- done
-
- default
-}
-
-src_configure() {
- # There is no option to turn off optimization through the build.sh
- # script.
- sed -i -e "s/Configure -Oder/Configure -Oder -Doptimize=none/" build.sh || die
-
- # The build script does not support the equivalent --enable
- # options so we must construct the configuration by hand.
-
- local myconf
-
- if ! use nls; then
- myconf="${myconf} --disable-nls"
- fi
-
- if ! use dbus; then
- myconf="${myconf} --disable-dbus"
- fi
-
- if ! use ssl; then
- myconf="${myconf} --disable-gnutls"
- fi
-
- if use gtk; then
- myconf="${myconf} --gtk2"
- else
- myconf="${myconf} --topless"
- fi
-
- ./build.sh \
- --configure-only \
- --prefix="/usr" \
- --cc="$(tc-getCC)" \
- ${myconf}
-}
-
-src_compile() {
- # Build system is not parallel-safe, bug 500760
- emake -j1
-}
-
-src_install() {
- dodir /usr/bin
- emake INSTALL_PREFIX="${D}" install
- dodoc AUTHORS ChangeLog README TODO
-
- # Touch the symbols file into the future to avoid warnings from
- # gtk-gnutella later on, since we will most likely strip the binary.
- touch --date="next minute" "${D}/usr/lib/gtk-gnutella/gtk-gnutella.nm" || die
-}
diff --git a/net-p2p/gtk-gnutella/gtk-gnutella-1.2.2.ebuild b/net-p2p/gtk-gnutella/gtk-gnutella-1.2.2.ebuild
deleted file mode 100644
index 821479e147f3..000000000000
--- a/net-p2p/gtk-gnutella/gtk-gnutella-1.2.2.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic strip-linguas toolchain-funcs
-
-IUSE="nls dbus ssl +gtk"
-
-DESCRIPTION="A GTK+ Gnutella client"
-SRC_URI="https://github.com/gtk-gnutella/gtk-gnutella/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-HOMEPAGE="http://gtk-gnutella.sourceforge.net/"
-
-SLOT="0"
-LICENSE="CC-BY-SA-4.0 GPL-2"
-KEYWORDS="amd64 ppc ppc64 x86"
-
-RDEPEND="
- sys-libs/binutils-libs:=
- dev-libs/glib:2
- sys-libs/zlib
- gtk? ( >=x11-libs/gtk+-2.2.1:2 )
- dbus? ( >=sys-apps/dbus-0.35.2 )
- ssl? ( >=net-libs/gnutls-2.2.5 )
- nls? ( >=sys-devel/gettext-0.11.5 )"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-src_prepare() {
- filter-lto
- strip-linguas -i po
-
- echo "# Gentoo-selected LINGUAS" > po/LINGUAS
- for ling in ${LINGUAS}; do
- echo $ling >> po/LINGUAS
- done
-
- default
-}
-
-src_configure() {
- # There is no option to turn off optimization through the build.sh
- # script.
- sed -i -e "s/Configure -Oder/Configure -Oder -Doptimize=none/" build.sh || die
-
- # The build script does not support the equivalent --enable
- # options so we must construct the configuration by hand.
-
- local myconf
-
- if ! use nls; then
- myconf="${myconf} --disable-nls"
- fi
-
- if ! use dbus; then
- myconf="${myconf} --disable-dbus"
- fi
-
- if ! use ssl; then
- myconf="${myconf} --disable-gnutls"
- fi
-
- if use gtk; then
- myconf="${myconf} --gtk2"
- else
- myconf="${myconf} --topless"
- fi
-
- ./build.sh \
- --configure-only \
- --prefix="/usr" \
- --cc="$(tc-getCC)" \
- ${myconf}
-}
-
-src_compile() {
- # Build system is not parallel-safe, bug 500760
- emake -j1
-}
-
-src_install() {
- dodir /usr/bin
- emake INSTALL_PREFIX="${D}" install
- dodoc AUTHORS ChangeLog README TODO
-
- # Touch the symbols file into the future to avoid warnings from
- # gtk-gnutella later on, since we will most likely strip the binary.
- touch --date="next minute" "${D}/usr/lib/gtk-gnutella/gtk-gnutella.nm" || die
-}