summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-11-10 04:58:36 +0000
committerSam James <sam@gentoo.org>2021-11-10 04:58:36 +0000
commit74c0148d970b95d767cd36bc0b8010a062906478 (patch)
tree247cb7ffcb39e036767b53ae892ade6303bf1ff3
parentsci-libs/miopen: AMD's Machine Intelligence Library (diff)
downloadgentoo-74c0148d970b95d767cd36bc0b8010a062906478.tar.gz
gentoo-74c0148d970b95d767cd36bc0b8010a062906478.tar.bz2
gentoo-74c0148d970b95d767cd36bc0b8010a062906478.zip
app-text/xmlto: don't hardcode paths to utilities
Causes issues with say --root. Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-text/xmlto/files/xmlto-0.0.28-dont-hardcode-paths.patch35
-rw-r--r--app-text/xmlto/xmlto-0.0.28-r7.ebuild53
2 files changed, 88 insertions, 0 deletions
diff --git a/app-text/xmlto/files/xmlto-0.0.28-dont-hardcode-paths.patch b/app-text/xmlto/files/xmlto-0.0.28-dont-hardcode-paths.patch
new file mode 100644
index 000000000000..5823b7350749
--- /dev/null
+++ b/app-text/xmlto/files/xmlto-0.0.28-dont-hardcode-paths.patch
@@ -0,0 +1,35 @@
+From: Sam James <sam@gentoo.org>
+Date: Wed, 10 Nov 2021 04:53:33 +0000
+Subject: [PATCH] Don't hardcode paths to utilities
+
+The path to e.g. links at build time is not necessarily
+the same as the path at runtime.
+
+TODO: Could chop out the checks from configure but
+this package is fragile enough. Leaving it for now.
+--- a/xmlto.in
++++ b/xmlto.in
+@@ -272,13 +272,13 @@ then
+ USE_BACKEND=DEFAULT
+ fi
+
+-LINKS_PATH=@LINKS@
+-W3M_PATH=@W3M@
+-LYNX_PATH=@LYNX@
+-GCP_PATH=@GCP@
+-SED_PATH=@SED@
+-GREP_PATH=@GREP@
+-ZIP_PATH=@ZIP@
++LINKS_PATH=$(command -v links)
++W3M_PATH=$(command -v w3m)
++LYNX_PATH=$(command -v lynx)
++GCP_PATH=$(command -v cp)
++SED_PATH=$(command -v sed)
++GREP_PATH=$(command -v grep)
++ZIP_PATH=$(command -v zip)
+
+ # Process any options
+ ARGS=$(${GETOPT} \
+--
+2.33.1
+
diff --git a/app-text/xmlto/xmlto-0.0.28-r7.ebuild b/app-text/xmlto/xmlto-0.0.28-r7.ebuild
new file mode 100644
index 000000000000..c54987d45d2f
--- /dev/null
+++ b/app-text/xmlto/xmlto-0.0.28-r7.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Script for converting XML and DocBook documents to a variety of output formats"
+HOMEPAGE="https://pagure.io/xmlto"
+SRC_URI="https://releases.pagure.org/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="latex text"
+
+RDEPEND="
+ app-text/docbook-xsl-stylesheets
+ app-text/docbook-xml-dtd:4.2
+ dev-libs/libxslt
+ || ( sys-apps/util-linux app-misc/getopt )
+ text? ( || ( virtual/w3m www-client/elinks www-client/links www-client/lynx ) )
+ latex? ( dev-texlive/texlive-formatsextra )
+"
+# We only depend on flex when we patch the input lexer.
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS ChangeLog FAQ NEWS README THANKS )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.0.22-format_fo_passivetex_check.patch
+ "${FILESDIR}"/${PN}-0.0.28-allow-links.patch
+ "${FILESDIR}"/${PN}-0.0.28-dont-hardcode-paths.patch
+)
+
+src_prepare() {
+ default
+
+ # fix symbol clash on Solaris
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ sed -i -e 's/\(attrib\|val\)/XMLTO\1/g' xmlif/xmlif.l || die
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ # We don't want the script to detect /bin/sh if it is bash.
+ export ac_cv_path_BASH="${BASH}"
+ has_version sys-apps/util-linux || export GETOPT=getopt-long
+
+ econf
+}