summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2020-07-16 14:03:01 +0200
committerAlexis Ballier <aballier@gentoo.org>2020-07-16 15:02:12 +0200
commit76aafc79d298b0d569699b3c5a6a25d28993fc43 (patch)
tree446624e58458d6b3c2234300c814219663a5086f
parentdev-ros/camera_info_manager: bump eapi (diff)
downloadgentoo-76aafc79d298b0d569699b3c5a6a25d28993fc43.tar.gz
gentoo-76aafc79d298b0d569699b3c5a6a25d28993fc43.tar.bz2
gentoo-76aafc79d298b0d569699b3c5a6a25d28993fc43.zip
dev-ros/camera_calibration_parsers: bump eapi
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
-rw-r--r--dev-ros/camera_calibration_parsers/camera_calibration_parsers-9999.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/dev-ros/camera_calibration_parsers/camera_calibration_parsers-9999.ebuild b/dev-ros/camera_calibration_parsers/camera_calibration_parsers-9999.ebuild
index ff27b5050edc..50bf5757a10b 100644
--- a/dev-ros/camera_calibration_parsers/camera_calibration_parsers-9999.ebuild
+++ b/dev-ros/camera_calibration_parsers/camera_calibration_parsers-9999.ebuild
@@ -1,11 +1,10 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
ROS_REPO_URI="https://github.com/ros-perception/image_common"
KEYWORDS="~amd64 ~arm"
ROS_SUBDIR=${PN}
-PYTHON_COMPAT=( python{2_7,3_6} )
inherit ros-catkin
@@ -15,7 +14,7 @@ SLOT="0"
IUSE=""
RDEPEND="
- dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP},${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
dev-libs/boost:=[python,${PYTHON_USEDEP}]
dev-ros/rosconsole
>=dev-cpp/yaml-cpp-0.5:=
@@ -23,7 +22,10 @@ RDEPEND="
dev-ros/roscpp_serialization
"
DEPEND="${RDEPEND}
- virtual/pkgconfig
test? ( dev-python/nose )
+ dev-ros/sensor_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+BDEPEND="
+ virtual/pkgconfig
"
PATCHES=( "${FILESDIR}/boostpython.patch" )