summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-05-26 10:11:03 +0100
committerSam James <sam@gentoo.org>2021-05-26 12:33:43 +0000
commit7875cef7ec09eef6b2025cf074992bbe508d64d4 (patch)
tree955c5ae78a1ec3664fc7c63c2b463e53e9821bba
parentdev-java/helpgui: Remove last-rited pkg (diff)
downloadgentoo-7875cef7ec09eef6b2025cf074992bbe508d64d4.tar.gz
gentoo-7875cef7ec09eef6b2025cf074992bbe508d64d4.tar.bz2
gentoo-7875cef7ec09eef6b2025cf074992bbe508d64d4.zip
dev-java/j2ssh: Remove last-rited pkg
Closes: https://bugs.gentoo.org/786234 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-java/j2ssh/Manifest1
-rw-r--r--dev-java/j2ssh/files/0.2.9-extras.patch201
-rw-r--r--dev-java/j2ssh/files/0.2.9-no-versioned-jars.patch40
-rw-r--r--dev-java/j2ssh/j2ssh-0.2.9.ebuild44
-rw-r--r--dev-java/j2ssh/metadata.xml15
-rw-r--r--profiles/package.mask6
6 files changed, 0 insertions, 307 deletions
diff --git a/dev-java/j2ssh/Manifest b/dev-java/j2ssh/Manifest
deleted file mode 100644
index 4ab4d979c321..000000000000
--- a/dev-java/j2ssh/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST j2ssh-0.2.9-src.tar.gz 2182523 BLAKE2B 1c5424ac99a466d3ac114160c133d8d6daed430f67bce35300290e14bc7540c73d5698f728f2cd43f7050877c2f89978c118a420375ffb5bc6c207c397e5afd2 SHA512 d7720766dcf50205089fa22d026721dc25de5def1d451fcb6680832017becc3fc8d76c2ffb5ed2e2190e08c864da24d2544515478956f78ac4d8cf4126cab6e8
diff --git a/dev-java/j2ssh/files/0.2.9-extras.patch b/dev-java/j2ssh/files/0.2.9-extras.patch
deleted file mode 100644
index d958cba19b97..000000000000
--- a/dev-java/j2ssh/files/0.2.9-extras.patch
+++ /dev/null
@@ -1,201 +0,0 @@
-diff -ur j2ssh-0.2.9/src/com/sshtools/j2ssh/io/ByteArrayReader.java j2ssh-0.2.9_patched/src/com/sshtools/j2ssh/io/ByteArrayReader.java
---- j2ssh-0.2.9/src/com/sshtools/j2ssh/io/ByteArrayReader.java 2007-04-28 21:02:54.000000000 +0200
-+++ j2ssh-0.2.9_patched/src/com/sshtools/j2ssh/io/ByteArrayReader.java 2008-01-18 19:27:38.000000000 +0100
-@@ -118,7 +118,13 @@
- byte[] chars = new byte[(int) len];
- System.arraycopy(data, start + 4, chars, 0, len);
-
-- return new String(chars);
-+ try {
-+ return new String(chars, "UTF-8");
-+ }
-+ catch(java.io.UnsupportedEncodingException e) {
-+ // This should never happen, UTF-8 is necessarily supported.
-+ return new String(chars);
-+ }
- }
-
- /**
-@@ -163,6 +169,12 @@
- byte[] raw = new byte[(int) len];
- read(raw);
-
-- return new String(raw);
-+ try {
-+ return new String(raw, "UTF-8");
-+ }
-+ catch(java.io.UnsupportedEncodingException e) {
-+ // This should never happen, UTF-8 is necessarily supported.
-+ return new String(raw);
-+ }
- }
- }
-diff -ur j2ssh-0.2.9/src/com/sshtools/j2ssh/io/ByteArrayWriter.java j2ssh-0.2.9_patched/src/com/sshtools/j2ssh/io/ByteArrayWriter.java
---- j2ssh-0.2.9/src/com/sshtools/j2ssh/io/ByteArrayWriter.java 2007-04-29 10:54:48.000000000 +0200
-+++ j2ssh-0.2.9_patched/src/com/sshtools/j2ssh/io/ByteArrayWriter.java 2008-01-18 19:30:36.000000000 +0100
-@@ -190,15 +190,15 @@
- if (str == null) {
- writeInt(0);
- } else {
-- /*
-- writeInt(str.length());
-- // don't use US-ASCII by default!
-- write(str.getBytes());
-- */
-- // patch as of version 0.2.9
-- // for UTF-8 length of string is not necessarily
-- // equal to number of bytes
-- byte[] strBytes = str.getBytes();
-+ byte[] strBytes;
-+ try {
-+ strBytes = str.getBytes("UTF-8");
-+ }
-+ catch(java.io.UnsupportedEncodingException e) {
-+ // This should never happen, UTF-8 is necessarily supported.
-+ strBytes = str.getBytes();
-+ }
-+
- writeInt(strBytes.length);
- write(strBytes);
- }
-diff -ur j2ssh-0.2.9/src/com/sshtools/j2ssh/sftp/SftpFileInputStream.java j2ssh-0.2.9_patched/src/com/sshtools/j2ssh/sftp/SftpFileInputStream.java
---- j2ssh-0.2.9/src/com/sshtools/j2ssh/sftp/SftpFileInputStream.java 2007-04-28 21:02:54.000000000 +0200
-+++ j2ssh-0.2.9_patched/src/com/sshtools/j2ssh/sftp/SftpFileInputStream.java 2008-01-18 19:26:58.000000000 +0100
-@@ -38,7 +38,7 @@
- */
- public class SftpFileInputStream extends InputStream {
- SftpFile file;
-- UnsignedInteger64 position = new UnsignedInteger64("0");
-+ UnsignedInteger64 position;
-
- /**
- * Creates a new SftpFileInputStream object.
-@@ -48,16 +48,47 @@
- * @throws IOException
- */
- public SftpFileInputStream(SftpFile file) throws IOException {
-+ this(file, 0);
-+ }
-+
-+ /**
-+ * Creates a new SftpFileInputStream object and sets the file offset to the specified position.
-+ *
-+ * @param file
-+ * @param position the initial file offset, must be >=0
-+ *
-+ * @throws IOException
-+ */
-+ public SftpFileInputStream(SftpFile file, long position) throws IOException {
- if (file.getHandle() == null) {
- throw new IOException("The file does not have a valid handle!");
- }
--
-+
- if (file.getSFTPSubsystem() == null) {
-- throw new IOException(
-- "The file is not attached to an SFTP subsystem!");
-+ throw new IOException("The file is not attached to an SFTP subsystem!");
- }
--
-+
- this.file = file;
-+ this.position = new UnsignedInteger64(""+position);
-+ }
-+
-+ /**
-+ * Returns the current offset within the file.
-+ *
-+ * @return the current offset within the file
-+ */
-+ public long getPosition() {
-+ return position.longValue();
-+ }
-+
-+ /**
-+ * Sets the current file offset to the given position.
-+ * Subsequent calls to read methods will start reading data at this position.
-+ *
-+ * @param position the new offset, must be >=0
-+ */
-+ public void setPosition(long position) {
-+ this.position = new UnsignedInteger64(""+position);
- }
-
- /**
-diff -ur j2ssh-0.2.9/src/com/sshtools/j2ssh/sftp/SftpFileOutputStream.java j2ssh-0.2.9_patched/src/com/sshtools/j2ssh/sftp/SftpFileOutputStream.java
---- j2ssh-0.2.9/src/com/sshtools/j2ssh/sftp/SftpFileOutputStream.java 2007-04-28 21:02:54.000000000 +0200
-+++ j2ssh-0.2.9_patched/src/com/sshtools/j2ssh/sftp/SftpFileOutputStream.java 2008-01-18 19:08:55.000000000 +0100
-@@ -38,7 +38,7 @@
- */
- public class SftpFileOutputStream extends OutputStream {
- SftpFile file;
-- UnsignedInteger64 position = new UnsignedInteger64("0");
-+ UnsignedInteger64 position;
-
- /**
- * Creates a new SftpFileOutputStream object.
-@@ -48,6 +48,18 @@
- * @throws IOException
- */
- public SftpFileOutputStream(SftpFile file) throws IOException {
-+ this(file, 0);
-+ }
-+
-+ /**
-+ * Creates a new SftpFileOutputStream object and sets the file offset to the specified position.
-+ *
-+ * @param file
-+ * @param position the initial file offset, must be >=0
-+ *
-+ * @throws IOException
-+ */
-+ public SftpFileOutputStream(SftpFile file, long position) throws IOException {
- if (file.getHandle() == null) {
- throw new IOException("The file does not have a valid handle!");
- }
-@@ -58,6 +70,7 @@
- }
-
- this.file = file;
-+ this.position = new UnsignedInteger64(""+position);
- }
-
- /**
-diff -ur j2ssh-0.2.9/src/com/sshtools/j2ssh/sftp/SftpSubsystemClient.java j2ssh-0.2.9_patched/src/com/sshtools/j2ssh/sftp/SftpSubsystemClient.java
---- j2ssh-0.2.9/src/com/sshtools/j2ssh/sftp/SftpSubsystemClient.java 2007-04-28 21:02:54.000000000 +0200
-+++ j2ssh-0.2.9_patched/src/com/sshtools/j2ssh/sftp/SftpSubsystemClient.java 2008-01-21 17:48:06.000000000 +0100
-@@ -231,16 +231,28 @@
- }
-
- /**
-+ * Creates the directory with the specified path. The default permissions for the directory are 0755 ("rwxr-xr-x").
- *
-+ * @param path the path to the directory to create
-+ * @throws IOException if an error occurs
-+ */
-+ public synchronized void makeDirectory(String path) throws IOException {
-+ makeDirectory(path, 0755); // default to 755 octal (493 decimal): "rwxr-xr-x"
-+ }
-+
-+ /**
-+ * Creates the directory with the specified path and file permissions.
- *
-- * @param path
-- *
-- * @throws IOException
-+ * @param path the path to the directory to create
-+ * @param permissions the file permissions of the new directory
-+ * @throws IOException if an error occurs
- */
-- public synchronized void makeDirectory(String path)
-- throws IOException {
-+ public synchronized void makeDirectory(String path, int permissions) throws IOException {
- UnsignedInteger32 requestId = nextRequestId();
-- SshFxpMkdir msg = new SshFxpMkdir(requestId, path, new FileAttributes());
-+ FileAttributes attrs = new FileAttributes();
-+ attrs.setPermissions(new UnsignedInteger32(permissions));
-+
-+ SshFxpMkdir msg = new SshFxpMkdir(requestId, path, attrs);
- sendMessage(msg);
- getOKRequestStatus(requestId);
- }
diff --git a/dev-java/j2ssh/files/0.2.9-no-versioned-jars.patch b/dev-java/j2ssh/files/0.2.9-no-versioned-jars.patch
deleted file mode 100644
index 26d7672a3414..000000000000
--- a/dev-java/j2ssh/files/0.2.9-no-versioned-jars.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-diff --git a/j2ssh/build.xml b/j2ssh/build.xml
-index 2c867ee..7ba5814 100644
---- a/j2ssh/build.xml
-+++ b/j2ssh/build.xml
-@@ -52,7 +52,7 @@
- <mkdir dir="${build.dist.lib}"/>
-
- <!-- Build the J2SSH library files -->
-- <jar jarfile="${build.dist.lib}/j2ssh-core-${j2ssh.version.major}.${j2ssh.version.minor}.${j2ssh.version.build}.jar" basedir="${build.dist.classes}">
-+ <jar jarfile="${build.dist.lib}/j2ssh-core.jar" basedir="${build.dist.classes}">
- <include name="com/sshtools/j2ssh/**/*.class"/>
- <manifest>
- <attribute name="Product-Version"
-@@ -60,7 +60,7 @@
- </manifest>
- </jar>
-
-- <jar jarfile="${build.dist.lib}/j2ssh-ant-${j2ssh.version.major}.${j2ssh.version.minor}.${j2ssh.version.build}.jar" basedir="${build.dist.classes}">
-+ <jar jarfile="${build.dist.lib}/j2ssh-ant.jar" basedir="${build.dist.classes}">
- <include name="com/sshtools/ant/**/*.class"/>
- <manifest>
- <attribute name="Product-Version"
-@@ -68,7 +68,7 @@
- </manifest>
- </jar>
-
-- <jar jarfile="${build.dist.lib}/j2ssh-dameon-${j2ssh.version.major}.${j2ssh.version.minor}.${j2ssh.version.build}.jar" basedir="${build.dist.classes}">
-+ <jar jarfile="${build.dist.lib}/j2ssh-dameon.jar" basedir="${build.dist.classes}">
- <include name="com/sshtools/daemon/**/*.class"/>
- <exclude name="com/sshtools/daemon/windows/**/*.*"/>
- <exclude name="com/sshtools/daemon/linux/**/*.*"/>
-@@ -78,7 +78,7 @@
- </manifest>
- </jar>
-
-- <jar jarfile="${build.dist.lib}/j2ssh-common-${j2ssh.version.major}.${j2ssh.version.minor}.${j2ssh.version.build}.jar" basedir="${build.dist.classes}">
-+ <jar jarfile="${build.dist.lib}/j2ssh-common.jar" basedir="${build.dist.classes}">
- <include name="com/sshtools/common/**/*.class"/>
- <include name="com/sshtools/common/**/*.png"/>
- <include name="com/sshtools/common/**/*.gif"/>
diff --git a/dev-java/j2ssh/j2ssh-0.2.9.ebuild b/dev-java/j2ssh/j2ssh-0.2.9.ebuild
deleted file mode 100644
index 2decfdada51d..000000000000
--- a/dev-java/j2ssh/j2ssh-0.2.9.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-JAVA_PKG_IUSE="source doc examples"
-
-inherit epatch java-pkg-2 java-ant-2
-
-DESCRIPTION="Java implementation of the SSH protocol"
-HOMEPAGE="https://sourceforge.net/projects/sshtools/ http://www.sshtools.com/"
-SRC_URI="mirror://sourceforge/sshtools/${P}-src.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-CDEPEND="dev-java/commons-logging:0
- dev-java/ant-core:0"
-
-RDEPEND="${CDEPEND}
- >=virtual/jre-1.5"
-DEPEND="${CDEPEND}
- >=virtual/jdk-1.5"
-
-S="${WORKDIR}/${PN}"
-
-JAVA_ANT_REWRITE_CLASSPATH="yes"
-EANT_BUILD_TARGET="build"
-EANT_GENTOO_CLASSPATH="commons-logging,ant-core"
-
-src_prepare() {
- epatch "${FILESDIR}/${PV}-no-versioned-jars.patch"
- epatch "${FILESDIR}/${PV}-extras.patch"
-}
-
-src_install() {
- java-pkg_dojar "${S}"/dist/lib/*.jar
-
- use doc && java-pkg_dojavadoc docs/
- use source && java-pkg_dosrc "${S}"/src/com
- use examples && java-pkg_doexamples "${S}"/examples/
-}
diff --git a/dev-java/j2ssh/metadata.xml b/dev-java/j2ssh/metadata.xml
deleted file mode 100644
index 6b55c013d0a1..000000000000
--- a/dev-java/j2ssh/metadata.xml
+++ /dev/null
@@ -1,15 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>java@gentoo.org</email>
- <name>Java</name>
- </maintainer>
- <longdescription>
- SSHTools is a suite of Java SSH applications providing a Java SSH API,
- SSH Terminal, SSH secured VNC client, SFTP client and SSH Daemon.
- </longdescription>
- <upstream>
- <remote-id type="sourceforge">sshtools</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/profiles/package.mask b/profiles/package.mask
index d0356701192a..78cc6dcf9c27 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -513,12 +513,6 @@ dev-java/javolution
# see bug: https://bugs.gentoo.org/786237
dev-java/jarbundler
-# Miroslav Šulc <fordfrog@gentoo.org> (2021-04-28)
-# library with no consumer
-# removal in 30 days
-# see bug: https://bugs.gentoo.org/786234
-dev-java/j2ssh
-
# Stephan Hartmann <sultan@gentoo.org> (2021-04-24)
# Dev channel releases are only for people who
# are developers or want more experimental features