summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2022-05-27 23:23:17 +0200
committerPacho Ramos <pacho@gentoo.org>2022-05-27 23:23:53 +0200
commit78d097e83ae5ba89b913a4f34e0a6c115846cc3b (patch)
tree5f3d0ff9355ad9277fc05fd263e1c72f8de9bfee
parentsys-power/bbswitch: drop 0.8_p20200526 (diff)
downloadgentoo-78d097e83ae5ba89b913a4f34e0a6c115846cc3b.tar.gz
gentoo-78d097e83ae5ba89b913a4f34e0a6c115846cc3b.tar.bz2
gentoo-78d097e83ae5ba89b913a4f34e0a6c115846cc3b.zip
sys-power/bbswitch: drop 9999 as we are not really maintaining it
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
-rw-r--r--sys-power/bbswitch/bbswitch-9999.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/sys-power/bbswitch/bbswitch-9999.ebuild b/sys-power/bbswitch/bbswitch-9999.ebuild
deleted file mode 100644
index 1c9b2ba061f9..000000000000
--- a/sys-power/bbswitch/bbswitch-9999.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit linux-mod toolchain-funcs
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/Bumblebee-Project/${PN}.git"
- EGIT_BRANCH="develop"
-else
- COMMIT="ddbd243638c7bc2baecf43a78aff46cdc12e9b2e"
- SRC_URI="https://github.com/Bumblebee-Project/bbswitch/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~amd64 ~x86"
- S="${WORKDIR}/bbswitch-${COMMIT}"
-fi
-
-DESCRIPTION="Toggle discrete NVIDIA Optimus graphics card"
-HOMEPAGE="https://github.com/Bumblebee-Project/bbswitch"
-
-SLOT="0"
-LICENSE="GPL-3+"
-IUSE=""
-
-DEPEND="
- virtual/linux-sources
- sys-kernel/linux-headers
-"
-RDEPEND=""
-
-MODULE_NAMES="bbswitch(acpi)"
-
-pkg_setup() {
- linux-mod_pkg_setup
-
- BUILD_TARGETS="default"
- BUILD_PARAMS="KVERSION=${KV_FULL} CC=$(tc-getCC)"
-}
-
-src_prepare() {
- # Fix build failure, bug #513542 and bug #761370
- sed "s%^KDIR :=.*%KDIR := ${KV_OUT_DIR:-$KERNEL_DIR}%g" -i Makefile || die
-
- default
-}
-
-src_install() {
- einstalldocs
-
- insinto /etc/modprobe.d
- newins "${FILESDIR}"/bbswitch.modprobe bbswitch.conf
-
- linux-mod_src_install
-}