summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2021-01-27 07:28:43 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2021-01-27 07:31:07 +0000
commit7b6202e5d9222af95545350f3f34f52d18788173 (patch)
tree09ff78270c214705adeea04c51b1374602fc9766
parentsys-libs/timezone-data: bump up to 2021a (diff)
downloadgentoo-7b6202e5d9222af95545350f3f34f52d18788173.tar.gz
gentoo-7b6202e5d9222af95545350f3f34f52d18788173.tar.bz2
gentoo-7b6202e5d9222af95545350f3f34f52d18788173.zip
dev-util/radare2: bump up to 5.1.0
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
-rw-r--r--dev-util/radare2/Manifest1
-rw-r--r--dev-util/radare2/radare2-5.1.0.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/dev-util/radare2/Manifest b/dev-util/radare2/Manifest
index 13664a54135e..a8c3e0fba803 100644
--- a/dev-util/radare2/Manifest
+++ b/dev-util/radare2/Manifest
@@ -1,2 +1,3 @@
DIST radare2-4.5.1.tar.gz 8266567 BLAKE2B 0d23c1d47dd79ffd9398ca7b2c8b383ba6a7e3ec662046d1111ab34cabcdaaf1fdd449686433b3229e3c22c31c705530b0a85bbd22b5fc79891a5ad292ba0ff1 SHA512 f08a4cd1e0d65643463d9f9dbb1aacfe793c7b411ec820a18b75a5975d265cfc2cf91e593522c8823aa369098ded21415939acb07c84d8acd102889bf5aed899
DIST radare2-5.0.0.tar.gz 7897849 BLAKE2B be785b693e9de7264f21b857291286849e054e807d87b4c56a6177a132f9fa141c25661f9d28ea10b61fd298161693794f2ee70279cfd076a2b1a98c563dd2a9 SHA512 059bc341bc34c5f39ef7493af9e2d3b7e52667a2d16f12ef19c9c6ba83c911fd02e07cd527599caea503d5e81a5fedbd8ff343db4d41257e0f48ace9dd52f3ba
+DIST radare2-5.1.0.tar.gz 7908690 BLAKE2B 4757eb0f729d6fa0de9bdf41b697c2ba722f8a2815e4ddb267ee1e68d50530596eaf549a7b062fd798aede214f982e309693f27df4f26257968559d35afe3076 SHA512 f973aeeb4d3a1e9eaf889a14bba4d54568dc2527d1160c7d999a7b2c870270cec7dc11a0eed12ae8f1d0aeacf63f14a92c7ca99f44e38573a6ce2276a08180f1
diff --git a/dev-util/radare2/radare2-5.1.0.ebuild b/dev-util/radare2/radare2-5.1.0.ebuild
new file mode 100644
index 000000000000..fb93a9ece984
--- /dev/null
+++ b/dev-util/radare2/radare2-5.1.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 eutils toolchain-funcs
+
+DESCRIPTION="unix-like reverse engineering framework and commandline tools"
+HOMEPAGE="http://www.radare.org"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/radareorg/radare2"
+else
+ SRC_URI="https://github.com/radareorg/radare2/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="ssl libressl"
+
+RDEPEND="
+ dev-libs/libzip
+ dev-libs/xxhash
+ sys-apps/file
+ sys-libs/zlib
+ dev-libs/capstone:0=
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ # Fix hardcoded docdir for fortunes
+ sed -i -e "/^#define R2_FORTUNES/s/radare2/$PF/" \
+ libr/include/r_userconf.h.acr
+ default
+}
+
+src_configure() {
+ # Ideally these should be set by ./configure
+ tc-export CC AR LD OBJCOPY RANLIB
+ export HOST_CC=${CC}
+
+ econf \
+ --without-libuv \
+ --with-syscapstone \
+ --with-sysmagic \
+ --with-sysxxhash \
+ --with-syszip \
+ $(use_with ssl openssl)
+}
+
+src_install() {
+ default
+
+ insinto /usr/share/zsh/site-functions
+ doins doc/zsh/_*
+
+ newbashcomp doc/bash_autocompletion.sh "${PN}"
+ bashcomp_alias "${PN}" rafind2 r2 rabin2 rasm2 radiff2
+
+ # a workaround for unstable $(INSTALL) call, bug #574866
+ local d
+ for d in doc/*; do
+ if [[ -d $d ]]; then
+ rm -rfv "$d" || die "failed to delete '$d'"
+ fi
+ done
+
+ # These are not really docs. radare assumes
+ # uncompressed files: bug #761250
+ docompress -x /usr/share/doc/${PF}/fortunes.{creepy,fun,nsfw,tips}
+}