summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-01-15 15:12:00 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2023-01-15 15:35:03 +0100
commit7c35d64267e11ce34e728ea01b4f4e7981175b8d (patch)
tree3049ab0815d1e5f11e6da17e733a815f3e32796a
parentgames-emulation/jgemu: use RDEPEND for metapkg (diff)
downloadgentoo-7c35d64267e11ce34e728ea01b4f4e7981175b8d.tar.gz
gentoo-7c35d64267e11ce34e728ea01b4f4e7981175b8d.tar.bz2
gentoo-7c35d64267e11ce34e728ea01b4f4e7981175b8d.zip
kde-plasma/plasma-desktop: Add missing dependencies
- kde-frameworks/kpackage Used in ksplash and landingpage Upstream commit 8447cfdf67458768627def4f481d9f52f8d444e1 See also: https://invent.kde.org/plasma/plasma-desktop/-/merge_requests/1338 - x11-libs/libXcursor and x11-libs/libxkbcommon Used in mouse and keyboard KCMs. Thanks-to: Sam James <sam@gentoo.org> Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
-rw-r--r--kde-plasma/plasma-desktop/files/plasma-desktop-5.26.5-missing-kpackage-1.patch24
-rw-r--r--kde-plasma/plasma-desktop/files/plasma-desktop-5.26.5-missing-kpackage-2.patch40
-rw-r--r--kde-plasma/plasma-desktop/plasma-desktop-5.26.5-r2.ebuild (renamed from kde-plasma/plasma-desktop/plasma-desktop-5.26.5-r1.ebuild)4
3 files changed, 68 insertions, 0 deletions
diff --git a/kde-plasma/plasma-desktop/files/plasma-desktop-5.26.5-missing-kpackage-1.patch b/kde-plasma/plasma-desktop/files/plasma-desktop-5.26.5-missing-kpackage-1.patch
new file mode 100644
index 000000000000..68f4ffc07848
--- /dev/null
+++ b/kde-plasma/plasma-desktop/files/plasma-desktop-5.26.5-missing-kpackage-1.patch
@@ -0,0 +1,24 @@
+From 8447cfdf67458768627def4f481d9f52f8d444e1 Mon Sep 17 00:00:00 2001
+From: Nicolas Fella <nicolas.fella@gmx.de>
+Date: Mon, 28 Nov 2022 13:08:09 +0100
+Subject: [PATCH] Add missing KPackage link
+
+---
+ kcms/ksplash/CMakeLists.txt | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/kcms/ksplash/CMakeLists.txt b/kcms/ksplash/CMakeLists.txt
+index ea75dd743..8bf51f997 100644
+--- a/kcms/ksplash/CMakeLists.txt
++++ b/kcms/ksplash/CMakeLists.txt
+@@ -28,6 +28,7 @@ target_link_libraries(kcm_splashscreen
+ KF5::Plasma
+ KF5::PlasmaQuick
+ KF5::NewStuff
++ KF5::Package
+
+ Qt::DBus
+ Qt::Widgets
+--
+2.39.0
+
diff --git a/kde-plasma/plasma-desktop/files/plasma-desktop-5.26.5-missing-kpackage-2.patch b/kde-plasma/plasma-desktop/files/plasma-desktop-5.26.5-missing-kpackage-2.patch
new file mode 100644
index 000000000000..3ebddb75d195
--- /dev/null
+++ b/kde-plasma/plasma-desktop/files/plasma-desktop-5.26.5-missing-kpackage-2.patch
@@ -0,0 +1,40 @@
+From 8ad8d248b91d9357f4ee421e4933d89595faf80a Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sun, 15 Jan 2023 15:17:09 +0100
+Subject: [PATCH] Add missing KPackage search and link
+
+Follow-up to 8447cfdf67458768627def4f481d9f52f8d444e1
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ CMakeLists.txt | 1 +
+ kcms/landingpage/CMakeLists.txt | 1 +
+ 2 files changed, 2 insertions(+)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index e797efa50..ef2db360d 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -74,6 +74,7 @@ find_package(KF5 ${KF5_MIN_VERSION} REQUIRED COMPONENTS
+ WidgetsAddons
+ Codecs
+ Sonnet
++ Package
+ KDELibs4Support # kcms/dateandtime
+ )
+
+diff --git a/kcms/landingpage/CMakeLists.txt b/kcms/landingpage/CMakeLists.txt
+index 215d51234..e39da9f51 100644
+--- a/kcms/landingpage/CMakeLists.txt
++++ b/kcms/landingpage/CMakeLists.txt
+@@ -26,6 +26,7 @@ target_link_libraries(kcm_landingpage
+ KF5::KCMUtils
+ KF5::ConfigWidgets
+ KF5::Declarative
++ KF5::Package
+ PW::KWorkspace
+ KF5::ActivitiesStats
+
+--
+2.39.0
+
diff --git a/kde-plasma/plasma-desktop/plasma-desktop-5.26.5-r1.ebuild b/kde-plasma/plasma-desktop/plasma-desktop-5.26.5-r2.ebuild
index 26db65779408..554f71e30f2c 100644
--- a/kde-plasma/plasma-desktop/plasma-desktop-5.26.5-r1.ebuild
+++ b/kde-plasma/plasma-desktop/plasma-desktop-5.26.5-r2.ebuild
@@ -63,6 +63,7 @@ COMMON_DEPEND="
>=kde-frameworks/knewstuff-${KFMIN}:5
>=kde-frameworks/knotifications-${KFMIN}:5
>=kde-frameworks/knotifyconfig-${KFMIN}:5
+ >=kde-frameworks/kpackage-${KFMIN}:5
>=kde-frameworks/kparts-${KFMIN}:5
>=kde-frameworks/krunner-${KFMIN}:5
>=kde-frameworks/kservice-${KFMIN}:5
@@ -78,9 +79,11 @@ COMMON_DEPEND="
>=kde-plasma/plasma-workspace-${PVCUT}:5[screencast?]
>=media-libs/phonon-4.11.0
x11-libs/libX11
+ x11-libs/libXcursor
x11-libs/libXfixes
x11-libs/libXi
x11-libs/libxcb
+ x11-libs/libxkbcommon
x11-libs/libxkbfile
emoji? (
app-i18n/ibus[emoji]
@@ -130,6 +133,7 @@ BDEPEND="
PATCHES=(
"${WORKDIR}/${XORGHDRS}/${PN}-5.25.80-override-include-dirs.patch" # downstream patch
+ "${FILESDIR}"/${P}-missing-kpackage-{1,2}.patch
)
src_prepare() {