summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2021-03-20 09:01:54 +0000
committerPatrick Lauer <patrick@gentoo.org>2021-03-20 09:01:54 +0000
commit7c8e6574b9b46191467f2e1568127c801890c250 (patch)
tree799db4d88ac0e58b1c48fc3cd89c060093cbd47d
parentdev-util/opencl-headers: Bump to 2020.12.18 (diff)
downloadgentoo-7c8e6574b9b46191467f2e1568127c801890c250.tar.gz
gentoo-7c8e6574b9b46191467f2e1568127c801890c250.tar.bz2
gentoo-7c8e6574b9b46191467f2e1568127c801890c250.zip
dev-libs/ocl-icd: Bump to 2.2.14
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Patrick Lauer <patrick@gentoo.org>
-rw-r--r--dev-libs/ocl-icd/Manifest1
-rw-r--r--dev-libs/ocl-icd/ocl-icd-2.2.14.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-libs/ocl-icd/Manifest b/dev-libs/ocl-icd/Manifest
index ae9b88a9d760..8b60ba9e2d39 100644
--- a/dev-libs/ocl-icd/Manifest
+++ b/dev-libs/ocl-icd/Manifest
@@ -1 +1,2 @@
DIST ocl-icd-2.2.12.tar.gz 80718 BLAKE2B 524f9eea9782323eafa2f41858c4970333c029898c651bbf15624331e184d1b439d2259532b02defd67c9ab434a35b1b9a64a28e1515b3f42f09b3a270975df7 SHA512 f1668c3a39ecfbc089ee5a5f61f44ceb86ab80e504e58064dec306ce907daf77936c5403b4af15ed8714068891d68346c86725f285cfbc90c4fcb35d18db4048
+DIST ocl-icd-2.2.14.tar.gz 100629 BLAKE2B 4862560541c979edb06d89f7f57b78a34c02e38843c02b0f125a121649cd6a33570e29c86fe7d3fd6f0fa3d489831777100daef97264e32b82854384075cbbf2 SHA512 78510b6fa4e2c6a52141a51ccf0d0ef3110b0b4902a43bb97f7622ff0ce470b108dc05c9619c28ce8758ccea1e1cf6b2e7f1a296f8b07f52532f23b2b036a5cf
diff --git a/dev-libs/ocl-icd/ocl-icd-2.2.14.ebuild b/dev-libs/ocl-icd/ocl-icd-2.2.14.ebuild
new file mode 100644
index 000000000000..e5b4c9f26236
--- /dev/null
+++ b/dev-libs/ocl-icd/ocl-icd-2.2.14.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26 ruby27"
+inherit autotools flag-o-matic multilib-minimal ruby-single
+
+DESCRIPTION="Alternative to vendor specific OpenCL ICD loaders"
+HOMEPAGE="https://github.com/OCL-dev/ocl-icd"
+SRC_URI="https://github.com/OCL-dev/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Does nothing now but by keeping it here we avoid having to have virtual/opencl
+# handle ebuilds both with and without this flag.
+IUSE="+khronos-headers"
+
+BDEPEND="${RUBY_DEPS}"
+DEPEND=">=dev-util/opencl-headers-2020.12.18"
+RDEPEND="${DEPEND}
+ !app-eselect/eselect-opencl
+ !dev-libs/opencl-icd-loader"
+
+src_prepare() {
+ replace-flags -Os -O2 # bug 646122
+
+ default
+ eautoreconf
+}
+
+multilib_src_configure() {
+ # dev-util/opencl-headers ARE official Khronos Group headers, what this option
+ # does is disable the use of the bundled ones
+ ECONF_SOURCE="${S}" econf --enable-pthread-once --disable-official-khronos-headers
+}
+
+multilib_src_install() {
+ default
+
+ # Drop .la files
+ find "${ED}" -name '*.la' -delete || die
+}