summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Head <chead@chead.ca>2022-11-08 21:15:29 -0800
committerSam James <sam@gentoo.org>2022-12-24 07:55:10 +0000
commit7f99689aa221da85c8535863452819baa1f7bf1e (patch)
treeab8201ab52579688d4a9df5f48b5a5bc8342986b
parentdev-ruby/redis: add 4.8.0 (diff)
downloadgentoo-7f99689aa221da85c8535863452819baa1f7bf1e.tar.gz
gentoo-7f99689aa221da85c8535863452819baa1f7bf1e.tar.bz2
gentoo-7f99689aa221da85c8535863452819baa1f7bf1e.zip
app-editors/bvi: fix CFLAGS handling
* Add `-std=gnu89` as recommended as the way to build K&R-style code which will not break with Clang 16. * Append, instead of overwriting, `CFLAGS`. * Bump to EAPI 8 while at it. Closes: https://bugs.gentoo.org/880309 Closes: https://bugs.gentoo.org/880393 Signed-off-by: Christopher Head <chead@chead.ca> Closes: https://github.com/gentoo/gentoo/pull/28199 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--app-editors/bvi/bvi-1.4.1-r2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-editors/bvi/bvi-1.4.1-r2.ebuild b/app-editors/bvi/bvi-1.4.1-r2.ebuild
new file mode 100644
index 000000000000..65616724b31d
--- /dev/null
+++ b/app-editors/bvi/bvi-1.4.1-r2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+DESCRIPTION="Display-oriented editor for binary files, based on the vi texteditor"
+HOMEPAGE="http://bvi.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.src.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~sparc64-solaris ~x86-solaris"
+
+DEPEND="sys-libs/ncurses:0="
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-prototypes.patch" )
+
+src_configure() {
+ append-cflags -DANSI -std=gnu89
+ default
+}