summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-12 18:44:41 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-12 18:54:57 +0200
commit817944361014af1553327ecb02a63d35f21c64af (patch)
tree01560727dc31ea812163c0a399b42cd15bdbb9bf
parentdev-python/python-slugify: Remove redundant versions (diff)
downloadgentoo-817944361014af1553327ecb02a63d35f21c64af.tar.gz
gentoo-817944361014af1553327ecb02a63d35f21c64af.tar.bz2
gentoo-817944361014af1553327ecb02a63d35f21c64af.zip
dev-python/python-systemd: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/python-systemd/Manifest1
-rw-r--r--dev-python/python-systemd/files/233-xfail-bind.patch31
-rw-r--r--dev-python/python-systemd/python-systemd-233.ebuild37
3 files changed, 0 insertions, 69 deletions
diff --git a/dev-python/python-systemd/Manifest b/dev-python/python-systemd/Manifest
index 363ee67f4834..ea4a30d22aba 100644
--- a/dev-python/python-systemd/Manifest
+++ b/dev-python/python-systemd/Manifest
@@ -1,2 +1 @@
-DIST python-systemd-233.tar.gz 49680 BLAKE2B 7d612022738d3114a39f7ad7f4d7799ac3d027980592a5205247d4c866ac3d9520d63ee02f143e26865f0d83338f30422dd0c2299f575e8b03f3112900e9af73 SHA512 92a6cc7123db586e5ae5fbb56e5065b17be9da47ced9dbc5920d80b7db7f56d15b127e72d30889c5b24b119724a33f68be1ef322529620ed95b0f95707e4c2ab
DIST python-systemd-234.tar.gz 53900 BLAKE2B 2658ee7083036ed8259e5f4ad0714ea15227ee836ad34c7fbbdb55dd9df48751b8d9998350d789b4f47e78fe7b4a7134e12d637e5a6ebeb29a0b31e5a4575d91 SHA512 164e34ba46827711e9c6ff9ed58b2706d9a22abfc7001de030ed7d463d8ddf783eb5fee93b207c29950a3c566018cc3f1a21a549421cf3e05c1287b433367eb2
diff --git a/dev-python/python-systemd/files/233-xfail-bind.patch b/dev-python/python-systemd/files/233-xfail-bind.patch
deleted file mode 100644
index bb0fb761bd59..000000000000
--- a/dev-python/python-systemd/files/233-xfail-bind.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 1c0d575f7c058f227d27b1cb92d3936d0c170a5f Mon Sep 17 00:00:00 2001
-From: Mike Gilbert <floppym@gentoo.org>
-Date: Tue, 21 Feb 2017 17:34:28 -0500
-Subject: [PATCH] test_daemon: xfail test_notify_with_socket if bind() fails
-
-This bind() call may fail if TMPDIR is too long.
-
-Bug: https://bugs.gentoo.org/610368
----
- systemd/test/test_daemon.py | 5 ++++-
- 1 file changed, 4 insertions(+), 1 deletion(-)
-
-diff --git a/systemd/test/test_daemon.py b/systemd/test/test_daemon.py
-index e827e1d..7733552 100644
---- a/systemd/test/test_daemon.py
-+++ b/systemd/test/test_daemon.py
-@@ -238,7 +238,10 @@ def test_notify_bad_socket():
- def test_notify_with_socket(tmpdir):
- path = tmpdir.join('socket').strpath
- sock = socket.socket(socket.AF_UNIX, socket.SOCK_DGRAM)
-- sock.bind(path)
-+ try:
-+ sock.bind(path)
-+ except socket.error as e:
-+ pytest.xfail('failed to bind socket (%s)' % e)
- # SO_PASSCRED is not defined in python2.7
- SO_PASSCRED = getattr(socket, 'SO_PASSCRED', 16)
- sock.setsockopt(socket.SOL_SOCKET, SO_PASSCRED, 1)
---
-2.11.1
-
diff --git a/dev-python/python-systemd/python-systemd-233.ebuild b/dev-python/python-systemd/python-systemd-233.ebuild
deleted file mode 100644
index f5819d3df03e..000000000000
--- a/dev-python/python-systemd/python-systemd-233.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python module for native access to the systemd facilities"
-HOMEPAGE="https://github.com/systemd/python-systemd"
-SRC_URI="https://github.com/systemd/python-systemd/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ppc ppc64 sparc x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-COMMON_DEPEND="
- sys-apps/systemd:0=
-"
-DEPEND="${COMMON_DEPEND}
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-RDEPEND="${COMMON_DEPEND}
- !sys-apps/systemd[python(-)]
-"
-
-PATCHES=(
- "${FILESDIR}"/233-xfail-bind.patch
-)
-
-python_test() {
- pushd "${BUILD_DIR}/lib" > /dev/null || die
- "${EPYTHON}" -m pytest -v . || die
- popd > /dev/null || die
-}