summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2024-02-08 14:35:05 +0100
committerHans de Graaff <graaff@gentoo.org>2024-02-08 15:23:54 +0100
commit8229e3bea0e9a6674bae8c4a823c08d65e829060 (patch)
treee00dea9854daab399b434a9f1037b832dc3a3c5f
parentdev-ruby/rspec-support: add 3.12.2 (diff)
downloadgentoo-8229e3bea0e9a6674bae8c4a823c08d65e829060.tar.gz
gentoo-8229e3bea0e9a6674bae8c4a823c08d65e829060.tar.bz2
gentoo-8229e3bea0e9a6674bae8c4a823c08d65e829060.zip
dev-ruby/rspec-mocks: add 3.12.7
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/rspec-mocks/Manifest1
-rw-r--r--dev-ruby/rspec-mocks/rspec-mocks-3.12.7.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/dev-ruby/rspec-mocks/Manifest b/dev-ruby/rspec-mocks/Manifest
index d833da3c7308..85733bf6a102 100644
--- a/dev-ruby/rspec-mocks/Manifest
+++ b/dev-ruby/rspec-mocks/Manifest
@@ -1 +1,2 @@
DIST rspec-mocks-3.12.6-git.tgz 207213 BLAKE2B 0b8bded9c6a04bb79910784e67f97028b9935b9e20e6934c3d1cccdf7b981b386a8dfb2e5e0c1f58fbbc2006fb68dabb108444b0f284b7f7f3b39bb73cb01cdc SHA512 f11ef99bdef109e3b332e0cc79e0d9c46db906b0c939ec6a89782219cea03e6282fe867212caaf2bf2eb272ed7ae1f4fe059a5626d131141925f731fcda3e91d
+DIST rspec-mocks-3.12.7-git.tgz 208127 BLAKE2B 86ef82c47ae7ef4992c6394718ee29f91fde70967b7f8ba3101c6f0233ab32be22c9e0e69e9041e94b4e5a587e3e936f89a14dbf464c2bdd8f6ce7d827cc5448 SHA512 c168eb653b585a37052870521e88be0723eba1b2f7f373a04557813e75a62c67448577809fbe1c0d04b21311b29c9874ed7509800bc7c05cb618f208066c8eac
diff --git a/dev-ruby/rspec-mocks/rspec-mocks-3.12.7.ebuild b/dev-ruby/rspec-mocks/rspec-mocks-3.12.7.ebuild
new file mode 100644
index 000000000000..113c3889a987
--- /dev/null
+++ b/dev-ruby/rspec-mocks/rspec-mocks-3.12.7.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+#RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="rspec-mocks.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="https://github.com/rspec/rspec-mocks"
+SRC_URI="https://github.com/rspec/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="test"
+
+SUBVERSION="$(ver_cut 1-2)"
+
+ruby_add_rdepend "=dev-ruby/rspec-support-${SUBVERSION}*
+ >=dev-ruby/diff-lcs-1.2.0 =dev-ruby/diff-lcs-1*"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/rspec-core-3.12.0:3
+ >=dev-ruby/rspec-expectations-2.99.0:3
+ )"
+
+all_ruby_prepare() {
+ # Don't set up bundler: it doesn't understand our setup.
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+
+ # Remove the Gemfile to avoid running through 'bundle exec'
+ rm Gemfile || die
+
+ # And consequently avoid specs using bundler. This also avoids a
+ # circular dependency on aruba.
+ rm -f spec/integration/rails_support_spec.rb spec/support/aruba.rb || die
+
+ # Remove .rspec options to avoid dependency on newer rspec when
+ # bootstrapping.
+ rm .rspec || die
+
+ sed -i -e '1irequire "spec_helper"' spec/rspec/mocks/any_instance_spec.rb || die
+
+ sed -i -e 's/git ls-files --/find */' ${RUBY_FAKEGEM_GEMSPEC} || die
+}