summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-20 04:36:38 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-20 04:36:38 +0200
commit8517f345c7225a0791440251772369dae2c25e92 (patch)
treecc207b76934e0b998b79237db1119f44254042bc
parentxfce-extra/xfce4-fsguard-plugin: Bump to 1.1.3 (diff)
downloadgentoo-8517f345c7225a0791440251772369dae2c25e92.tar.gz
gentoo-8517f345c7225a0791440251772369dae2c25e92.tar.bz2
gentoo-8517f345c7225a0791440251772369dae2c25e92.zip
dev-python/pyasn1: Bump to 0.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pyasn1/Manifest1
-rw-r--r--dev-python/pyasn1/pyasn1-0.5.0.ebuild22
2 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/pyasn1/Manifest b/dev-python/pyasn1/Manifest
index 491c89541136..ab867c625aa7 100644
--- a/dev-python/pyasn1/Manifest
+++ b/dev-python/pyasn1/Manifest
@@ -1 +1,2 @@
DIST pyasn1-0.4.8.tar.gz 146820 BLAKE2B 5c00b47c2014e599d1aa2e14c3004b3688786c7afd160c85709d5a0f324166abb1d29ebbd9f3e13100166e7176710e4dc6e1b8fcf80db5f5bdaa202912f8a023 SHA512 e64e70b325c8067f87ace7c0673149e82fe564aa4b0fa146d29b43cb588ecd6e81b1b82803b8cfa7a17d3d0489b6d88b4af5afb3aa0052bf92e8a1769fe8f7b0
+DIST pyasn1-0.5.0.tar.gz 145117 BLAKE2B dbbec0bebcfe11b8de983716fedf1bf28e6bcf7d5f89e3dcba929884347cc7cd3a8ef8b5ec44bbc799a7bae3de39c90cf5e48111384de571dc2034a79c3bb52b SHA512 763690184ce891555564d76902042791865815e59e1325100fca692140110e5e182ef3da84ffdf96b1876edeb2757bbb09c06d26e752a8110760dafbf9e3ca00
diff --git a/dev-python/pyasn1/pyasn1-0.5.0.ebuild b/dev-python/pyasn1/pyasn1-0.5.0.ebuild
new file mode 100644
index 000000000000..65fba7ed2b93
--- /dev/null
+++ b/dev-python/pyasn1/pyasn1-0.5.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="ASN.1 library for Python"
+HOMEPAGE="
+ https://pypi.org/project/pyasn1/
+ https://github.com/etingof/pyasn1/
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~x64-macos"
+
+distutils_enable_tests unittest
+distutils_enable_sphinx "docs/source"