summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-16 07:11:53 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-16 07:54:07 +0100
commit87b7d7d21fa3dc09874640ceaeb9da5dcfd3e28b (patch)
tree409f542529df4abe4d9333aff190db5c59238161
parentgames-engines/scummvm: Remove old (diff)
downloadgentoo-87b7d7d21fa3dc09874640ceaeb9da5dcfd3e28b.tar.gz
gentoo-87b7d7d21fa3dc09874640ceaeb9da5dcfd3e28b.tar.bz2
gentoo-87b7d7d21fa3dc09874640ceaeb9da5dcfd3e28b.zip
games-engines/scummvm: Bump to 2.8.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--games-engines/scummvm/Manifest1
-rw-r--r--games-engines/scummvm/scummvm-2.8.1.ebuild142
2 files changed, 143 insertions, 0 deletions
diff --git a/games-engines/scummvm/Manifest b/games-engines/scummvm/Manifest
index b86ab1703f2f..98935df3170b 100644
--- a/games-engines/scummvm/Manifest
+++ b/games-engines/scummvm/Manifest
@@ -1 +1,2 @@
DIST scummvm-2.8.0.tar.xz 207362400 BLAKE2B 2e0354189bfa50b5af87c9019400c114c7fd3072afeb6cee50c230d27171ae109552c855b07f027769c10f6f325dafd77c56fa17b1c5a61b11ece3c1f54efe53 SHA512 e4e728a668fe3c1b161b56ff788011673766e7429bc27bafb2b4a7f724093b719f7fd47f0995f1db5dad42ecf3ee260fe51d549f85eb2a68862b799962c34632
+DIST scummvm-2.8.1.tar.xz 207711376 BLAKE2B 716503fbbd736e522918203400ccf777bc24a8e43c8c030c0e86d9c4f3c3da3f0c580269781fe030901e06854d43e2ed2f6ec9bc4e269c4d4dde8d3e08f494f2 SHA512 aef6c7b83f087cf0742dcd1f896f5706e2408e54c4c902e75f03e69f4c5475b1d33a2149246646afb96c02aa2e85ba93995dff732b3aa84338b7bc96c62b802c
diff --git a/games-engines/scummvm/scummvm-2.8.1.ebuild b/games-engines/scummvm/scummvm-2.8.1.ebuild
new file mode 100644
index 000000000000..3690afa59cdb
--- /dev/null
+++ b/games-engines/scummvm/scummvm-2.8.1.ebuild
@@ -0,0 +1,142 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit desktop flag-o-matic toolchain-funcs xdg
+
+DESCRIPTION="Reimplementation of the SCUMM game engine used in Lucasarts adventures"
+HOMEPAGE="https://www.scummvm.org/"
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/scummvm/scummvm"
+else
+ SRC_URI="https://downloads.scummvm.org/frs/scummvm/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+ S=${WORKDIR}/${P/_/}
+fi
+
+LICENSE="GPL-2+ LGPL-2.1 BSD GPL-3-with-font-exception"
+SLOT="0"
+IUSE="
+ a52 aac alsa debug flac fluidsynth fribidi gif +gtk jpeg lua mpeg2
+ mp3 +net opengl png sndio speech theora truetype unsupported vorbis
+ zlib
+"
+RESTRICT="test" # it only looks like there's a test there #77507
+
+DEPEND="
+ >=media-libs/libsdl2-2.0.0[sound,joystick,video]
+ a52? ( media-libs/a52dec )
+ aac? ( media-libs/faad2 )
+ alsa? ( media-libs/alsa-lib )
+ flac? ( media-libs/flac:= )
+ fluidsynth? ( media-sound/fluidsynth:= )
+ fribidi? ( dev-libs/fribidi )
+ gif? ( media-libs/giflib )
+ gtk? (
+ dev-libs/glib:2
+ x11-libs/gtk+:3
+ )
+ jpeg? ( media-libs/libjpeg-turbo:= )
+ mp3? ( media-libs/libmad )
+ mpeg2? ( media-libs/libmpeg2 )
+ net? (
+ media-libs/sdl2-net
+ net-misc/curl
+ )
+ opengl? (
+ || (
+ virtual/opengl
+ media-libs/mesa[gles2]
+ media-libs/mesa[gles1]
+ )
+ )
+ png? ( media-libs/libpng:0 )
+ sndio? ( media-sound/sndio:= )
+ speech? ( app-accessibility/speech-dispatcher )
+ truetype? ( media-libs/freetype:2 )
+ theora? ( media-libs/libtheora )
+ vorbis? (
+ media-libs/libogg
+ media-libs/libvorbis
+ )
+ zlib? ( sys-libs/zlib:= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ app-arch/xz-utils
+ truetype? ( virtual/pkgconfig )
+ x86? ( dev-lang/nasm )
+"
+
+src_prepare() {
+ default
+
+ # -g isn't needed for nasm here
+ sed -i \
+ -e '/NASMFLAGS/ s/-g//' \
+ configure || die
+ sed -i \
+ -e '/INSTALL.*doc/d' \
+ -e '/INSTALL.*\/pixmaps/d' \
+ -e 's/-s //' \
+ ports.mk || die
+}
+
+src_configure() {
+ use x86 && append-ldflags -Wl,-z,noexecstack
+ tc-export STRINGS
+
+ local myconf=(
+ --backend=sdl
+ --host=${CHOST}
+ --enable-verbose-build
+ --prefix="${EPREFIX}/usr"
+ --libdir="${EPREFIX}/usr/$(get_libdir)"
+ --opengl-mode=$(usex opengl auto none)
+ --with-sdl-prefix="${EPREFIX}/usr"
+ $(use_enable a52)
+ $(use_enable aac faad)
+ $(use_enable alsa)
+ $(use_enable debug)
+ $(use_enable !debug release-mode)
+ $(use_enable flac)
+ $(usex fluidsynth '' --disable-fluidsynth)
+ $(use_enable fribidi)
+ $(use_enable gif)
+ $(use_enable gtk)
+ $(use_enable jpeg)
+ $(use_enable lua)
+ $(use_enable mp3 mad)
+ $(use_enable mpeg2)
+ $(use_enable net libcurl)
+ $(use_enable net sdlnet)
+ $(use_enable png)
+ $(use_enable sndio)
+ $(use_enable speech tts)
+ $(use_enable theora theoradec)
+ $(use_enable truetype freetype2)
+ $(usex unsupported --enable-all-engines '')
+ $(use_enable vorbis)
+ $(use_enable zlib)
+ $(use_enable x86 nasm)
+ )
+ echo "configure ${myconf[@]}"
+ # not an autoconf script, so don't call econf
+ SDL_CONFIG="sdl2-config" \
+ ./configure "${myconf[@]}" ${EXTRA_ECONF} || die
+}
+
+src_compile() {
+ emake \
+ AR="$(tc-getAR) cru" \
+ RANLIB="$(tc-getRANLIB)"
+}
+
+src_install() {
+ default
+ doicon -s scalable icons/scummvm.svg
+}