summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-21 06:52:55 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-21 06:59:39 +0100
commit87d10bac7a34e36852cb446fce8eced4e935a3b0 (patch)
tree84982d0135a9020bb46e6b00be132db3c10c7a85
parentdev-python/argcomplete: Bump to 3.0.3 (diff)
downloadgentoo-87d10bac7a34e36852cb446fce8eced4e935a3b0.tar.gz
gentoo-87d10bac7a34e36852cb446fce8eced4e935a3b0.tar.bz2
gentoo-87d10bac7a34e36852cb446fce8eced4e935a3b0.zip
dev-python/beautifulsoup4: Bump to 4.12.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/beautifulsoup4/Manifest1
-rw-r--r--dev-python/beautifulsoup4/beautifulsoup4-4.12.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/beautifulsoup4/Manifest b/dev-python/beautifulsoup4/Manifest
index 7132c219c7e3..52f561451361 100644
--- a/dev-python/beautifulsoup4/Manifest
+++ b/dev-python/beautifulsoup4/Manifest
@@ -1 +1,2 @@
DIST beautifulsoup4-4.11.2.tar.gz 517627 BLAKE2B 19fc88dff84c398461ecce3b66b1a92c3541114e3595aa1bae7182914e174d9c36b6de37ba120200695f6dca489c6afcd361244ae9577bc469d20a0864989d48 SHA512 68f5328f881946e80ed1af36b26da184f0af58aaf124f5f623f89c40130e1578f6dbe874b11c802e52c0ec02cfbf6b681e10eb235279631f479d14c2243e7dd3
+DIST beautifulsoup4-4.12.0.tar.gz 523942 BLAKE2B a1cde7726cfe96327300a4c9d44fbf98e3196911be628aa7633633f3515ed6c5d2d0cea61b4a4c9529208bc2339ae070e8e5ffc60d0afec133ca81079b53a49b SHA512 8f4dcaccdcd220f9641c7080d685c1eaa9c851daa579c187fda75a1d85dcf2fe4cc673c2d4b2143682003390ef1d954366ea0d2820e07f8c10418350d31bccd3
diff --git a/dev-python/beautifulsoup4/beautifulsoup4-4.12.0.ebuild b/dev-python/beautifulsoup4/beautifulsoup4-4.12.0.ebuild
new file mode 100644
index 000000000000..3a46f8b73014
--- /dev/null
+++ b/dev-python/beautifulsoup4/beautifulsoup4-4.12.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pythonic idioms for iterating, searching, and modifying an HTML/XML parse tree"
+HOMEPAGE="https://www.crummy.com/software/BeautifulSoup/bs4/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/soupsieve[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+"
+# bs4 prefers cchardet > chardet > charset-normalizer
+# however, charset-normalizer causes test failures, so force the other two
+# dev-python/chardet[${PYTHON_USEDEP}]
+BDEPEND="
+ test? (
+ || (
+ dev-python/cchardet[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]
+ )
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx doc/source