summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2022-08-01 08:22:09 +0200
committerMichał Górny <mgorny@gentoo.org>2022-08-14 11:48:24 +0200
commit880f511ea944cc02920021670809b4bf21ecea21 (patch)
tree1af499a1b61614f7b989ff3b3269fa2a5a360281
parentdev-python/frozendict: fix test phase (diff)
downloadgentoo-880f511ea944cc02920021670809b4bf21ecea21.tar.gz
gentoo-880f511ea944cc02920021670809b4bf21ecea21.tar.bz2
gentoo-880f511ea944cc02920021670809b4bf21ecea21.zip
dev-python/frozendict: add 2.3.4
Closes: https://bugs.gentoo.org/865127 Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Closes: https://github.com/gentoo/gentoo/pull/26692 Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/frozendict/Manifest1
-rw-r--r--dev-python/frozendict/frozendict-2.3.4.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/frozendict/Manifest b/dev-python/frozendict/Manifest
index 7bafad669835..646b181321d3 100644
--- a/dev-python/frozendict/Manifest
+++ b/dev-python/frozendict/Manifest
@@ -1 +1,2 @@
DIST frozendict-2.3.2.gh.tar.gz 306318 BLAKE2B 3bc10f34784a8b76b7c6ca0eeccc8331e9a558f0e24d2328550eb5a985ed2ad6c94d027c51ee44f2d25af67fc453356e01b5cfee773880b87d73c55113ca10b2 SHA512 8dc88a3e7898be8fbced16fbdbdee469d07ecbb06a059512f98f71e50a8c5f2c3a4f3d4e6aa06bab121e4ae2e9cea76f6d89c73212047069f2ef88c616c7278a
+DIST frozendict-2.3.4.gh.tar.gz 307399 BLAKE2B ac6311182ed2ba4925a14a145b4d30a0241978f55ae7a81cebc534ede812ca77097f0f8c7eeb08e8cbd6240e036d3b5035bd3e9b284a55b638c93717e3a20258 SHA512 15acc4fceb5e2228ee3423d4a5b86c529e9bdcb7264f59139cbde6194983901a17da8036bebf53d7d8057ce52666031e90eb1ca358bfd374c651fd60743988dc
diff --git a/dev-python/frozendict/frozendict-2.3.4.ebuild b/dev-python/frozendict/frozendict-2.3.4.ebuild
new file mode 100644
index 000000000000..fa692c82ed56
--- /dev/null
+++ b/dev-python/frozendict/frozendict-2.3.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple immutable mapping for python"
+HOMEPAGE="
+ https://github.com/Marco-Sulla/python-frozendict/
+ https://pypi.org/project/frozendict/
+"
+SRC_URI="
+ https://github.com/Marco-Sulla/python-frozendict/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/python-${P}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+
+python_test() {
+ cd "${T}" || die
+ epytest "${S}/test"
+}