summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2016-09-15 21:48:23 +0800
committerJason Zaman <perfinion@gentoo.org>2016-09-15 22:07:44 +0800
commit8888dceb8e33d4c5ad64185994174c625df7e085 (patch)
treeb62e1b353db860d51c62b5697bcc0fd98cd46ba7
parentxfce-base/libxfce4ui: bump to 4.13.1 (diff)
downloadgentoo-8888dceb8e33d4c5ad64185994174c625df7e085.tar.gz
gentoo-8888dceb8e33d4c5ad64185994174c625df7e085.tar.bz2
gentoo-8888dceb8e33d4c5ad64185994174c625df7e085.zip
xfce-base/xfce4-settings: bump to 4.12.1
Package-Manager: portage-2.2.28
-rw-r--r--xfce-base/xfce4-settings/Manifest1
-rw-r--r--xfce-base/xfce4-settings/xfce4-settings-4.12.1.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/xfce-base/xfce4-settings/Manifest b/xfce-base/xfce4-settings/Manifest
index d17954e03496..01dd8b629107 100644
--- a/xfce-base/xfce4-settings/Manifest
+++ b/xfce-base/xfce4-settings/Manifest
@@ -1 +1,2 @@
DIST xfce4-settings-4.12.0.tar.bz2 973324 SHA256 04becef105c19d0266cfe8dbf42619e7233c3b9fa99b43dbfc9c6a5959501f81 SHA512 4a61c16f1f03de98c9968a00b50595e2934aaf28b80613c59403d33a293a7f8ef9ebb6fad98b0eeb97a6590b9100e91f73dd6363133d5d8bd06714f1126d8856 WHIRLPOOL 52a66c1b99f67b1e92ccbc223535617a6edff67857032d7c19581fe38e4b5b7e2b32a42bb5263f92ec02596035dd76f6a8f6387f17e524b035def717eda373ff
+DIST xfce4-settings-4.12.1.tar.bz2 1027325 SHA256 f6484a0b1a7dad65ba5ee4eba8e07299b7c92a2a8adb195684e0e2b959886574 SHA512 20aca9c6337433b0b7165acfb373bce14e13e368345844799cfe71bcf433a38c4d1f57d3ffe01eda347d167c3098f46ac77d0364b64a2a59bbe82e45d76a9623 WHIRLPOOL 3cfda30efeb59ac2b857efd5454139915fd053cd533fdddf7cbd718352ee18990f0dcb1ea62a532fd4b36f451818b0d1161145467e47691e76cc9e310d409922
diff --git a/xfce-base/xfce4-settings/xfce4-settings-4.12.1.ebuild b/xfce-base/xfce4-settings/xfce4-settings-4.12.1.ebuild
new file mode 100644
index 000000000000..f609e5462c2d
--- /dev/null
+++ b/xfce-base/xfce4-settings/xfce4-settings-4.12.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit xfconf
+
+DESCRIPTION="Configuration system for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="debug input_devices_libinput libcanberra libnotify upower +xklavier"
+
+RDEPEND=">=dev-libs/dbus-glib-0.100
+ >=dev-libs/glib-2.24
+ media-libs/fontconfig
+ >=x11-libs/gtk+-2.20:2
+ x11-libs/libX11
+ >=x11-libs/libXcursor-1.1
+ >=x11-libs/libXi-1.3
+ >=x11-libs/libXrandr-1.2
+ >=xfce-base/garcon-0.2
+ >=xfce-base/exo-0.8
+ >=xfce-base/libxfce4ui-4.11
+ >=xfce-base/libxfce4util-4.11
+ >=xfce-base/xfconf-4.10
+ libcanberra? ( >=media-libs/libcanberra-0.25[sound] )
+ input_devices_libinput? ( x11-drivers/xf86-input-libinput )
+ libnotify? ( >=x11-libs/libnotify-0.7 )
+ upower? ( || ( >=sys-power/upower-0.9.23 sys-power/upower-pm-utils ) )
+ xklavier? ( >=x11-libs/libxklavier-5 )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext
+ >=x11-proto/inputproto-1.4
+ x11-proto/xproto"
+
+pkg_setup() {
+ XFCONF=(
+ $(use_enable upower upower-glib)
+ $(use_enable input_devices_libinput xorg-libinput)
+ $(use_enable libnotify)
+ $(use_enable xklavier libxklavier)
+ $(use_enable libcanberra sound-settings)
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS TODO )
+}