summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2022-09-29 10:07:34 +0200
committerJakov Smolić <jsmolic@gentoo.org>2022-09-29 10:07:38 +0200
commit8bfd440a755b77c146e1f0e0c48ed1190fc82a7b (patch)
tree780c5013c75bb5800fcf3784ae33d17c4068dea0
parentdev-python/flask-babelex: Remove last-rited pkg (diff)
downloadgentoo-8bfd440a755b77c146e1f0e0c48ed1190fc82a7b.tar.gz
gentoo-8bfd440a755b77c146e1f0e0c48ed1190fc82a7b.tar.bz2
gentoo-8bfd440a755b77c146e1f0e0c48ed1190fc82a7b.zip
dev-python/flask-security: Remove last-rited pkg
Closes: https://bugs.gentoo.org/867415 Closes: https://bugs.gentoo.org/863509 Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
-rw-r--r--dev-python/flask-security/Manifest2
-rw-r--r--dev-python/flask-security/flask-security-4.1.4.ebuild66
-rw-r--r--dev-python/flask-security/flask-security-4.1.5.ebuild67
-rw-r--r--dev-python/flask-security/metadata.xml13
-rw-r--r--profiles/package.mask12
5 files changed, 0 insertions, 160 deletions
diff --git a/dev-python/flask-security/Manifest b/dev-python/flask-security/Manifest
deleted file mode 100644
index 372f0361383a..000000000000
--- a/dev-python/flask-security/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-DIST flask-security-4.1.4.gh.tar.gz 408532 BLAKE2B 5fd401da8a907ff56ab7fe1fc79ec586222c26d60d921534afea4743cbc6840098f8a1d231741f83f061e2a4f747c4937be848aa4bfee8b3cf4bc06a8928e437 SHA512 d9ec87d1d2baa11b00db437135060630ea06451d96057fc8712ced8bc433fb6779f7b2561ad1c96d8f192a43acdc93dddf7f44ec75f89297204fd1796dcad1df
-DIST flask-security-4.1.5.gh.tar.gz 408704 BLAKE2B 18a1711e99794293fec17cca90ab9fcc7437c4882d7f14fb8c5abfddf137724a37ecf968cebd3801ef509f5b34f9671428405477894166d9c4350e1fd4a59054 SHA512 cf0a4ea6d8ad519ae5055898d2b7eb1bea8b3ceb3fffd2a79b47b92c6ccb72b692ed9483088fbea3987ff6fa3aaf60fcc388b7553a7e3e6ba8edfce63c714ad3
diff --git a/dev-python/flask-security/flask-security-4.1.4.ebuild b/dev-python/flask-security/flask-security-4.1.4.ebuild
deleted file mode 100644
index 80cde17b13c7..000000000000
--- a/dev-python/flask-security/flask-security-4.1.4.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Simple security for Flask apps"
-HOMEPAGE="
- https://github.com/Flask-Middleware/flask-security/
- https://pypi.org/project/Flask-Security-Too/"
-SRC_URI="
- https://github.com/Flask-Middleware/flask-security/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~riscv x86"
-
-RDEPEND="
- >=dev-python/bleach-3.3.1[${PYTHON_USEDEP}]
- >=dev-python/blinker-1.4[${PYTHON_USEDEP}]
- dev-python/cachetools[${PYTHON_USEDEP}]
- >=dev-python/flask-1.1.1[${PYTHON_USEDEP}]
- >=dev-python/flask-babelex-0.9.3[${PYTHON_USEDEP}]
- >=dev-python/flask-login-0.4.1[${PYTHON_USEDEP}]
- >=dev-python/flask-principal-0.4.0[${PYTHON_USEDEP}]
- >=dev-python/flask-wtf-0.14.3[${PYTHON_USEDEP}]
- >=dev-python/itsdangerous-1.1.0[${PYTHON_USEDEP}]
- >=dev-python/passlib-1.7.2[${PYTHON_USEDEP}]
- >=dev-python/python-email-validator-1.1.1[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- dev-python/Babel[${PYTHON_USEDEP}]
- test? (
- >=dev-python/argon2-cffi-19.1.0[${PYTHON_USEDEP}]
- >=dev-python/bcrypt-3.1.5[${PYTHON_USEDEP}]
- dev-python/bleach[${PYTHON_USEDEP}]
- >=dev-python/cryptography-2.3.1[${PYTHON_USEDEP}]
- >=dev-python/flask-mail-0.9.1[${PYTHON_USEDEP}]
- >=dev-python/flask-sqlalchemy-2.3[${PYTHON_USEDEP}]
- >=dev-python/mongomock-3.19.0[${PYTHON_USEDEP}]
- >=dev-python/peewee-3.11.2[${PYTHON_USEDEP}]
- >=dev-python/phonenumbers-8.11.1[${PYTHON_USEDEP}]
- >=dev-python/psycopg-2.8.4:2[${PYTHON_USEDEP}]
- >=dev-python/pymysql-0.9.3[${PYTHON_USEDEP}]
- >=dev-python/pyqrcode-1.2[${PYTHON_USEDEP}]
- >=dev-python/zxcvbn-4.4.28[${PYTHON_USEDEP}]
- >=dev-python/pony-0.7.11[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- sed -i -e 's@--cache-clear@-p no:httpbin@' pytest.ini || die
- distutils-r1_src_prepare
-}
-
-python_configure_all() {
- esetup.py compile_catalog
-}
diff --git a/dev-python/flask-security/flask-security-4.1.5.ebuild b/dev-python/flask-security/flask-security-4.1.5.ebuild
deleted file mode 100644
index d0756bee2e8a..000000000000
--- a/dev-python/flask-security/flask-security-4.1.5.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Simple security for Flask apps"
-HOMEPAGE="
- https://github.com/Flask-Middleware/flask-security/
- https://pypi.org/project/Flask-Security-Too/"
-SRC_URI="
- https://github.com/Flask-Middleware/flask-security/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~riscv ~x86"
-
-RDEPEND="
- >=dev-python/bleach-3.3.1[${PYTHON_USEDEP}]
- >=dev-python/blinker-1.4[${PYTHON_USEDEP}]
- dev-python/cachetools[${PYTHON_USEDEP}]
- >=dev-python/flask-1.1.1[${PYTHON_USEDEP}]
- >=dev-python/flask-babelex-0.9.3[${PYTHON_USEDEP}]
- >=dev-python/flask-login-0.4.1[${PYTHON_USEDEP}]
- >=dev-python/flask-principal-0.4.0[${PYTHON_USEDEP}]
- >=dev-python/flask-wtf-0.14.3[${PYTHON_USEDEP}]
- >=dev-python/itsdangerous-1.1.0[${PYTHON_USEDEP}]
- >=dev-python/passlib-1.7.2[${PYTHON_USEDEP}]
- >=dev-python/python-email-validator-1.1.1[${PYTHON_USEDEP}]
-"
-
-BDEPEND="
- dev-python/Babel[${PYTHON_USEDEP}]
- test? (
- >=dev-python/argon2-cffi-19.1.0[${PYTHON_USEDEP}]
- >=dev-python/bcrypt-3.1.5[${PYTHON_USEDEP}]
- dev-python/bleach[${PYTHON_USEDEP}]
- >=dev-python/cryptography-2.3.1[${PYTHON_USEDEP}]
- >=dev-python/flask-mail-0.9.1[${PYTHON_USEDEP}]
- >=dev-python/flask-sqlalchemy-2.3[${PYTHON_USEDEP}]
- >=dev-python/mongomock-3.19.0[${PYTHON_USEDEP}]
- >=dev-python/peewee-3.11.2[${PYTHON_USEDEP}]
- >=dev-python/phonenumbers-8.11.1[${PYTHON_USEDEP}]
- >=dev-python/psycopg-2.8.4:2[${PYTHON_USEDEP}]
- >=dev-python/pymysql-0.9.3[${PYTHON_USEDEP}]
- >=dev-python/pyqrcode-1.2[${PYTHON_USEDEP}]
- >=dev-python/zxcvbn-4.4.28[${PYTHON_USEDEP}]
- >=dev-python/pony-0.7.11[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- sed -e 's/--cache-clear/-p no:httpbin/' -i pytest.ini || die
- distutils-r1_src_prepare
-}
-
-python_configure_all() {
- esetup.py compile_catalog
-}
diff --git a/dev-python/flask-security/metadata.xml b/dev-python/flask-security/metadata.xml
deleted file mode 100644
index 9b41c5afc845..000000000000
--- a/dev-python/flask-security/metadata.xml
+++ /dev/null
@@ -1,13 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <stabilize-allarches/>
- <upstream>
- <remote-id type="pypi">Flask-Security-Too</remote-id>
- <remote-id type="github">Flask-Middleware/flask-security</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/profiles/package.mask b/profiles/package.mask
index 3471f2db6849..1d8b551b9991 100644
--- a/profiles/package.mask
+++ b/profiles/package.mask
@@ -186,18 +186,6 @@ app-backup/attic
# bugs #829447, #836227, #862504
mail-filter/sigh
-# Michał Górny <mgorny@gentoo.org> (2022-08-30)
-# Flask-Security-Too is a package with high maintenance cost
-# and no revdeps in ::gentoo. The next version bump (once more)
-# introduces more dependencies.
-#
-# The remaining listed packages are used exclusively by this package
-# (or its tests). If you find one of them useful, please let us know
-# and we'll keep it.
-#
-# Removal on 2022-09-29. Bug #867415.
-dev-python/flask-security
-
# hololeap <hololeap@protonmail.com> (2022-08-21)
# doctest-parallel does not currently work with Setup.hs (used internally by
# haskell-cabal.eclass)