summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-08-21 14:38:19 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-08-21 14:38:19 +0200
commit8c1f6fc465f21fc07e40925bd835695eebf63ae9 (patch)
tree27ae49e3fd9d4aa0add4ea8dcdb7818cef78ea0e
parentwww-servers/resin: Remove vunerable versions. Fixes security bug 431416. (diff)
downloadgentoo-8c1f6fc465f21fc07e40925bd835695eebf63ae9.tar.gz
gentoo-8c1f6fc465f21fc07e40925bd835695eebf63ae9.tar.bz2
gentoo-8c1f6fc465f21fc07e40925bd835695eebf63ae9.zip
media-libs/mlt: convert to python-single-r1
Package-Manager: portage-2.2.20.1
-rw-r--r--media-libs/mlt/mlt-0.9.8.ebuild22
1 files changed, 5 insertions, 17 deletions
diff --git a/media-libs/mlt/mlt-0.9.8.ebuild b/media-libs/mlt/mlt-0.9.8.ebuild
index 3f52506761f0..e7ec6d2a9b65 100644
--- a/media-libs/mlt/mlt-0.9.8.ebuild
+++ b/media-libs/mlt/mlt-0.9.8.ebuild
@@ -3,8 +3,8 @@
# $Id$
EAPI=5
-PYTHON_DEPEND="python? 2:2.6"
-inherit eutils toolchain-funcs multilib python
+PYTHON_COMPAT=( python2_7 )
+inherit eutils toolchain-funcs multilib python-single-r1
DESCRIPTION="An open source multimedia framework, designed and developed for television broadcasting"
HOMEPAGE="http://www.mltframework.org/"
@@ -60,7 +60,7 @@ DEPEND="${RDEPEND}
compressed-lumas? ( || ( media-gfx/imagemagick[png]
media-gfx/graphicsmagick[imagemagick,png] ) )
lua? ( ${SWIG_DEPEND} virtual/pkgconfig )
- python? ( ${SWIG_DEPEND} )
+ python? ( ${SWIG_DEPEND} ${PYTHON_DEPS} )
ruby? ( ${SWIG_DEPEND} )"
# java? ( ${SWIG_DEPEND} >=virtual/jdk-1.5 )
# perl? ( ${SWIG_DEPEND} )
@@ -68,8 +68,7 @@ DEPEND="${RDEPEND}
# tcl? ( ${SWIG_DEPEND} )
pkg_setup() {
- python_set_active_version 2
- python_pkg_setup
+ python-single-r1_pkg_setup
}
src_prepare() {
@@ -164,6 +163,7 @@ src_install() {
exeinto $(python_get_sitedir)
doexe _mlt.so
dodoc play.py
+ python_optimize
fi
if use ruby; then
@@ -174,15 +174,3 @@ src_install() {
fi
# TODO: java perl php tcl
}
-
-pkg_postinst() {
- if use python; then
- python_mod_optimize mlt.py
- fi
-}
-
-pkg_postrm() {
- if use python; then
- python_mod_cleanup mlt.py
- fi
-}