summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2024-03-25 22:41:21 +0000
committerJames Le Cuirot <chewi@gentoo.org>2024-03-25 22:42:33 +0000
commit8c3976940c45b7f1ee118c0530f041cdee613248 (patch)
tree365c00af3d2d0a4c006aca6e272f7a77591b8fa6
parentdev-util/xdelta: Fix building 1.1.4 with GCC 14 (diff)
downloadgentoo-8c3976940c45b7f1ee118c0530f041cdee613248.tar.gz
gentoo-8c3976940c45b7f1ee118c0530f041cdee613248.tar.bz2
gentoo-8c3976940c45b7f1ee118c0530f041cdee613248.zip
games-util/loki_patch: Fix building with GCC 14, EAPI 8
Thanks to NHOrus for the patch. Closes: https://bugs.gentoo.org/926323 Signed-off-by: James Le Cuirot <chewi@gentoo.org>
-rw-r--r--games-util/loki_patch/files/loki_patch-20091105-xdelta-gzip.patch44
-rw-r--r--games-util/loki_patch/loki_patch-20091105-r1.ebuild (renamed from games-util/loki_patch/loki_patch-20091105.ebuild)8
-rw-r--r--games-util/loki_patch/metadata.xml11
3 files changed, 56 insertions, 7 deletions
diff --git a/games-util/loki_patch/files/loki_patch-20091105-xdelta-gzip.patch b/games-util/loki_patch/files/loki_patch-20091105-xdelta-gzip.patch
new file mode 100644
index 000000000000..ec4eeb758a3a
--- /dev/null
+++ b/games-util/loki_patch/files/loki_patch-20091105-xdelta-gzip.patch
@@ -0,0 +1,44 @@
+--- a/loki_patch/loki_xdelta.c
++++ b/loki_patch/loki_xdelta.c
+@@ -179,6 +179,7 @@ struct _XdFileHandle
+ guint narrow_high;
+ guint current_pos;
+ FILE* in;
++ gzFile zin;
+ gboolean (* in_read) (XdFileHandle* handle, void* buf, gint nbyte);
+ gboolean (* in_close) (XdFileHandle* handle);
+ gboolean in_compressed;
+@@ -520,7 +521,7 @@ xd_gzwrite (XdFileHandle* fh, const void* buf, gint nbyte)
+ static gboolean
+ xd_gzread (XdFileHandle* fh, void* buf, gint nbyte)
+ {
+- return gzread (fh->in, buf, nbyte) == nbyte;
++ return gzread (fh->zin, buf, nbyte) == nbyte;
+ }
+
+ static gboolean
+@@ -532,7 +533,7 @@ xd_gzclose (XdFileHandle* fh)
+ static gboolean
+ xd_gzrclose (XdFileHandle* fh)
+ {
+- return gzclose (fh->in) == Z_OK;
++ return gzclose (fh->zin) == Z_OK;
+ }
+
+ static void
+@@ -1022,13 +1023,13 @@ xd_handle_narrow (XdFileHandle* fh, guint low, guint high, gboolean compressed)
+ }
+
+ g_assert (fh->fd >= 0);
+- fh->in = gzdopen (dup (fh->fd), "rb");
++ fh->zin = gzdopen (dup (fh->fd), "rb");
+ fh->in_read = &xd_gzread;
+ fh->in_close = &xd_gzrclose;
+ fh->in_compressed = TRUE;
+ fh->current_pos = 0;
+
+- if (! fh->in)
++ if (! fh->zin)
+ {
+ xd_error ("gzdopen failed: %s\n", g_strerror (errno));
+ return -1;
diff --git a/games-util/loki_patch/loki_patch-20091105.ebuild b/games-util/loki_patch/loki_patch-20091105-r1.ebuild
index 1fc2b57f633a..aba786f80e73 100644
--- a/games-util/loki_patch/loki_patch-20091105.ebuild
+++ b/games-util/loki_patch/loki_patch-20091105-r1.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
inherit autotools
DESCRIPTION="Loki Software binary patch tool"
-HOMEPAGE="http://www.icculus.org/loki_setup/"
+HOMEPAGE="https://github.com/icculus/loki_patch"
SRC_URI="
mirror://gentoo/${P}.tar.bz2
mirror://gentoo/loki_setupdb-${PV}.tar.bz2"
@@ -23,9 +23,11 @@ DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
S="${WORKDIR}"
+
PATCHES=(
"${FILESDIR}"/${P}-build.patch
"${FILESDIR}"/${P}-patchdata.patch
+ "${FILESDIR}"/${P}-xdelta-gzip.patch
)
src_prepare() {
diff --git a/games-util/loki_patch/metadata.xml b/games-util/loki_patch/metadata.xml
index 1c3ba213c494..5b4310eed8d7 100644
--- a/games-util/loki_patch/metadata.xml
+++ b/games-util/loki_patch/metadata.xml
@@ -1,8 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer type="project">
- <email>games@gentoo.org</email>
- <name>Gentoo Games Project</name>
-</maintainer>
+ <maintainer type="project">
+ <email>games@gentoo.org</email>
+ <name>Gentoo Games Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">icculus/loki_patch</remote-id>
+ </upstream>
</pkgmetadata>